aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon van der Maas <svdm-gentoo@protonmail.com>2021-02-18 11:13:49 +0100
committerSimon van der Maas <svdm-gentoo@protonmail.com>2021-02-18 11:13:49 +0100
commit4d49bc35a8ba636556dacee3d2a62036d378aa70 (patch)
tree8a77f88d7f648f96d46c812ae49b69d15949f879
parentnet-misc/rtv: fix ebuild (diff)
downloadguru-4d49bc35a8ba636556dacee3d2a62036d378aa70.tar.gz
guru-4d49bc35a8ba636556dacee3d2a62036d378aa70.tar.bz2
guru-4d49bc35a8ba636556dacee3d2a62036d378aa70.zip
gui-wm/dwl: fixed ebuild
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Simon van der Maas <svdm-gentoo@protonmail.com>
-rw-r--r--gui-wm/dwl/dwl-0.2.ebuild4
-rw-r--r--gui-wm/dwl/files/dwl-0.2-prefix.patch11
2 files changed, 3 insertions, 12 deletions
diff --git a/gui-wm/dwl/dwl-0.2.ebuild b/gui-wm/dwl/dwl-0.2.ebuild
index 415e0dd75..fbd1f9833 100644
--- a/gui-wm/dwl/dwl-0.2.ebuild
+++ b/gui-wm/dwl/dwl-0.2.ebuild
@@ -15,4 +15,6 @@ DEPEND="gui-libs/wlroots
dev-libs/wayland-protocols"
RDEPEND="${DEPEND}"
-PATCHES=( "${FILESDIR}/${P}-prefix.patch" )
+src_install() {
+ emake PREFIX="${D}"/usr install
+}
diff --git a/gui-wm/dwl/files/dwl-0.2-prefix.patch b/gui-wm/dwl/files/dwl-0.2-prefix.patch
deleted file mode 100644
index 3020247b0..000000000
--- a/gui-wm/dwl/files/dwl-0.2-prefix.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff --git a/config.mk b/config.mk
-index cd4e821..bdb2687 100644
---- a/config.mk
-+++ b/config.mk
-@@ -1,5 +1,5 @@
- # paths
--PREFIX = /usr/local
-+PREFIX = /var/tmp/portage/gui-wm/dwl-0.2/image
-
- # Default compile flags (overridable by environment)
- CFLAGS ?= -g -Wall -Wextra -Werror -Wno-unused-parameter -Wno-sign-compare -Wno-unused-function -Wno-unused-variable -Wdeclaration-after-statement