aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac.paragon@gmail.com>2022-03-01 21:26:22 +0200
committerViorel Munteanu <ceamac.paragon@gmail.com>2022-03-01 21:26:22 +0200
commit5000b1df9feb59fb2fbdd7858b7ebab5d85595c8 (patch)
tree6d18a709763a73997860504890d9cd6b23f1165a
parentnet-misc/freetube-bin: Add a description (diff)
downloadguru-5000b1df9feb59fb2fbdd7858b7ebab5d85595c8.tar.gz
guru-5000b1df9feb59fb2fbdd7858b7ebab5d85595c8.tar.bz2
guru-5000b1df9feb59fb2fbdd7858b7ebab5d85595c8.zip
dev-python/desktop-notifier: add 3.3.3
Signed-off-by: Viorel Munteanu <ceamac.paragon@gmail.com>
-rw-r--r--dev-python/desktop-notifier/Manifest1
-rw-r--r--dev-python/desktop-notifier/desktop-notifier-3.3.3.ebuild34
-rw-r--r--dev-python/desktop-notifier/files/desktop-notifier-3.3.3-resources-png.patch15
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/desktop-notifier/Manifest b/dev-python/desktop-notifier/Manifest
index 25ed24757..8cf57889d 100644
--- a/dev-python/desktop-notifier/Manifest
+++ b/dev-python/desktop-notifier/Manifest
@@ -1 +1,2 @@
DIST desktop-notifier-3.3.2.tar.gz 4595234 BLAKE2B c53383b8f15c36acb21a77695b8a76e782f912078ba7c5946fe55c2e8c3c950ece7581a81a69dbee12553be7155364c9165336d7f2b814ccb0e3076dc082cf85 SHA512 d93825ea4880428e9eb41f0adff27e963ebeae23aa5cdc8c77e4a60aecee69aa1448f9aca8b12520597b52df531580e29e3458c2ea7b4f2e60eda68de5dfbe9f
+DIST desktop-notifier-3.3.3.tar.gz 4595797 BLAKE2B e27f6927d67603d20ab3729ddbd436d75110a97cb82d3db80e4229c8e297803783f9b4f3212b284f83989778354600fc7efe553b20a66cc6ea3d8eccafc00466 SHA512 a0b9dbd50b53380712529636df949621a418f58f06ad97251b22f744f0dfbb47ef0d5697fc279fa49b085f653494dc6acc18a6531752b6a288831b9c05e4a241
diff --git a/dev-python/desktop-notifier/desktop-notifier-3.3.3.ebuild b/dev-python/desktop-notifier/desktop-notifier-3.3.3.ebuild
new file mode 100644
index 000000000..14d30b9e2
--- /dev/null
+++ b/dev-python/desktop-notifier/desktop-notifier-3.3.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="desktop-notifier is a Python library for cross-platform desktop notifications"
+HOMEPAGE="
+ https://desktop-notifier.readthedocs.io
+ https://pypi.org/project/desktop-notifier
+ https://github.com/samschott/desktop-notifier
+"
+SRC_URI="https://github.com/samschott/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/wheel[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/python-dbus-next[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/importlib_resources[${PYTHON_USEDEP}]' python3_8)
+"
+
+PATCHES=(
+ "${FILESDIR}"/desktop-notifier-3.3.3-resources-png.patch
+)
+
+distutils_enable_sphinx docs
diff --git a/dev-python/desktop-notifier/files/desktop-notifier-3.3.3-resources-png.patch b/dev-python/desktop-notifier/files/desktop-notifier-3.3.3-resources-png.patch
new file mode 100644
index 000000000..55b43a654
--- /dev/null
+++ b/dev-python/desktop-notifier/files/desktop-notifier-3.3.3-resources-png.patch
@@ -0,0 +1,15 @@
+python.png went missing in the new build system
+
+--- a/setup.cfg
++++ b/setup.cfg
+@@ -53,7 +53,9 @@
+ sphinx_rtd_theme
+
+ [options.package_data]
+-desktop_notifier = resources/*; py.typed
++desktop_notifier =
++ resources/*; py.typed
++ resources/*.png
+
+ [flake8]
+ ignore = E203,E501,W503,H306