aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2020-04-25 09:22:35 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2020-04-25 09:25:57 +0200
commit51e1ff3ce73f924ee1142ca9a458a393d18332fd (patch)
tree29f443767fa97cf3de6208f515fbf099526868bb
parentx11-misc/xob: New package. (diff)
downloadguru-51e1ff3ce73f924ee1142ca9a458a393d18332fd.tar.gz
guru-51e1ff3ce73f924ee1142ca9a458a393d18332fd.tar.bz2
guru-51e1ff3ce73f924ee1142ca9a458a393d18332fd.zip
dev-python/pytest-cython: disable tests for now
tests requiring(?) a masked dependency Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--dev-python/pytest-cython/Manifest1
-rw-r--r--dev-python/pytest-cython/metadata.xml8
-rw-r--r--dev-python/pytest-cython/pytest-cython-0.1.0.ebuild31
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pytest-cython/Manifest b/dev-python/pytest-cython/Manifest
new file mode 100644
index 000000000..e28b85e2d
--- /dev/null
+++ b/dev-python/pytest-cython/Manifest
@@ -0,0 +1 @@
+DIST pytest-cython-0.1.0.tar.gz 19109 BLAKE2B 75895992402f36010385e0851cce4532825d374cc9d5af1b45d4dc938070da1f9e8c9901601ac10e3fa9a76fd4f0affd3f0dac6d8857eea88c73cbc1686ce613 SHA512 65d8d25f95f2419ae76902cad8f0f4c9b810dbbba80621d301f53d2128dfeb11c4d74e2ac4f1e39f63aadfc1404e9000c0668efbab4793d307f0b90345023771
diff --git a/dev-python/pytest-cython/metadata.xml b/dev-python/pytest-cython/metadata.xml
new file mode 100644
index 000000000..d4c3950f8
--- /dev/null
+++ b/dev-python/pytest-cython/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="pypi">pytest-cython</remote-id>
+ <remote-id type="github">lgpage/pytest-cython</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-cython/pytest-cython-0.1.0.ebuild b/dev-python/pytest-cython/pytest-cython-0.1.0.ebuild
new file mode 100644
index 000000000..a339433aa
--- /dev/null
+++ b/dev-python/pytest-cython/pytest-cython-0.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Plugin for testing Cython extension modules"
+HOMEPAGE="https://github.com/lgpage/pytest-cython"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64"
+#IUSE="test"
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+#DEPEND="
+# ${RDEPEND}
+# test? (
+# dev-python/check-manifest[${PYTHON_USEDEP}]
+# dev-python/docutils[${PYTHON_USEDEP}]
+# dev-python/pygments[${PYTHON_USEDEP}]
+# dev-python/readme_renderer[${PYTHON_USEDEP}]
+# )
+#"
+
+#distutils_enable_tests pytest
+distutils_enable_sphinx docs