aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNickolas Raymond Kaczynski <nrk@disroot.org>2022-03-03 19:01:55 +0600
committerNickolas Raymond Kaczynski <nrk@disroot.org>2022-03-03 19:01:55 +0600
commit5340918136b3c065747b22dd6eb015082ec9470a (patch)
tree9ed4c8f50affcb360ad7e981c5b0d2fb0e19040a
parentdev-python/confluent-kafka: enable py3.9 (diff)
downloadguru-53409181.tar.gz
guru-53409181.tar.bz2
guru-53409181.zip
media-gfx/nsxiv: add v29, drop v27.1
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Nickolas Raymond Kaczynski <nrk@disroot.org>
-rw-r--r--media-gfx/nsxiv/Manifest2
-rw-r--r--media-gfx/nsxiv/nsxiv-29.ebuild (renamed from media-gfx/nsxiv/nsxiv-27.1.ebuild)33
-rw-r--r--media-gfx/nsxiv/nsxiv-9999.ebuild17
3 files changed, 26 insertions, 26 deletions
diff --git a/media-gfx/nsxiv/Manifest b/media-gfx/nsxiv/Manifest
index 92958780b..6969ab8c5 100644
--- a/media-gfx/nsxiv/Manifest
+++ b/media-gfx/nsxiv/Manifest
@@ -1,2 +1,2 @@
-DIST nsxiv-27.1.tar.gz 54242 BLAKE2B baed35787874b02e0051e0b19b2cb9670a66ce01de1ca3446a8ca5f99fcebd785232a5b3715f0f3dd733314096e3a46a6ebcc8960417abfc1a6e5e09224f15d2 SHA512 08a250a43a92a08258e2a6e871d6d5f596206af344fe3896505c0e85bdf556d02f13b1dbc9b365ce7c597770425d0e3635878b3fceb37f324957674ccc1b1eb0
DIST nsxiv-28.tar.gz 60699 BLAKE2B d52d5933005492c55b0133b594a2b9613443324aca22ffe48dff90bdc62afc6cd48eac14ed578db9fcff5d147b5b6020edaf538335f9b26499232d0670935a3e SHA512 a1d61dc57f41e5b50225dd1e8120b8f1e31b042d43f7443ec27d2fc227e8eb98e96116357e8329011b7ca9aac10e7f0f2259bad3b57fbb1b2951a8fe4d8930bf
+DIST nsxiv-29.tar.gz 64012 BLAKE2B 1b964736619a56cc8fb4092979f12749389fa347e3fda7a40fcfdc1b07a72e101c61d99fb12b10f4ea7ab6459c8068d5c64d754e3e988ec6bfd4504813bcc485 SHA512 d891fc0885f280a622401e105dc1ed9ba39e40f3e760e3e0cd34ae79fdb32187b1d3dc15590bbefd68a18db2aa12795433907e6e744561cc891fc03e7a1f1e94
diff --git a/media-gfx/nsxiv/nsxiv-27.1.ebuild b/media-gfx/nsxiv/nsxiv-29.ebuild
index f53c57016..615ed9c70 100644
--- a/media-gfx/nsxiv/nsxiv-27.1.ebuild
+++ b/media-gfx/nsxiv/nsxiv-29.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -18,25 +18,23 @@ HOMEPAGE="https://github.com/nsxiv/nsxiv"
LICENSE="GPL-2"
SLOT="0"
-IUSE="exif +gif +jpeg +png webp tiff +inotify"
+IUSE="+statusbar exif +inotify +gif +jpeg +png webp tiff"
RDEPEND="
+ statusbar? ( x11-libs/libXft )
exif? ( media-libs/libexif )
gif? ( media-libs/giflib:0= )
+ webp? ( media-libs/libwebp )
media-libs/imlib2[X,gif?,jpeg?,png?,webp?,tiff?]
x11-libs/libX11
- x11-libs/libXft
"
DEPEND="${RDEPEND}"
pkg_setup() {
if use inotify; then
- nsxiv_autoreload="inotify"
CONFIG_CHECK+=" ~INOTIFY_USER"
ERROR_INOTIFY_USER="${P} requires inotify in-kernel support."
linux-info_pkg_setup
- else
- nsxiv_autoreload="nop"
fi
}
@@ -47,23 +45,26 @@ src_prepare() {
}
src_configure() {
- sed -i \
- -e '/-include config.mk/d' \
- -e '/\$(OBJS): / s|config.mk||' \
- -e '/^install: / s|: all|:|' \
+ sed -i -e '/^install: / s|: all|:|' \
+ -e 's|^CFLAGS =|CFLAGS +=|' \
Makefile || die "sed failed"
}
src_compile() {
- emake CC="$(tc-getCC)" \
- HAVE_LIBEXIF=$(usex exif 1 0) \
- HAVE_LIBGIF=$(usex gif 1 0) \
- AUTORELOAD="${nsxiv_autoreload}"
+ emake CC="$(tc-getCC)" OPT_DEP_DEFAULT=0 \
+ HAVE_INOTIFY="$(usex inotify 1 0)" \
+ HAVE_LIBFONTS="$(usex statusbar 1 0)" \
+ HAVE_LIBGIF="$(usex gif 1 0)" \
+ HAVE_LIBWEBP="$(usex webp 1 0)" \
+ HAVE_LIBEXIF="$(usex exif 1 0)"
}
src_install() {
- emake DESTDIR="${ED}" PREFIX=/usr install
- emake -C icon DESTDIR="${ED}" PREFIX=/usr install
+ emake \
+ DESTDIR="${ED}" \
+ PREFIX="/usr" \
+ EGPREFIX="/usr/share/doc/${P}/examples" \
+ install install-icon
dodoc README.md
domenu nsxiv.desktop
diff --git a/media-gfx/nsxiv/nsxiv-9999.ebuild b/media-gfx/nsxiv/nsxiv-9999.ebuild
index 6c5bd08ad..615ed9c70 100644
--- a/media-gfx/nsxiv/nsxiv-9999.ebuild
+++ b/media-gfx/nsxiv/nsxiv-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -45,8 +45,8 @@ src_prepare() {
}
src_configure() {
- sed -i -e '/^install: / s|: all|:|' \
- -e 's|^CFLAGS ?=|CFLAGS +=|' \
+ sed -i -e '/^install: / s|: all|:|' \
+ -e 's|^CFLAGS =|CFLAGS +=|' \
Makefile || die "sed failed"
}
@@ -60,12 +60,11 @@ src_compile() {
}
src_install() {
- export DESTDIR="${ED}"
- export PREFIX="/usr"
- export EGPREFIX="${PREFIX}/share/doc/${P}/examples"
-
- emake install
- emake install-icon
+ emake \
+ DESTDIR="${ED}" \
+ PREFIX="/usr" \
+ EGPREFIX="/usr/share/doc/${P}/examples" \
+ install install-icon
dodoc README.md
domenu nsxiv.desktop