aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArtemis Everfree <artemis@artemis.sh>2023-06-29 13:09:47 -0700
committerArtemis Everfree <artemis@artemis.sh>2023-06-29 13:15:03 -0700
commit576ee93db3c9db57a0dcc1cb4ea3d99a3fc1157d (patch)
tree97e96567b7c9a48789faccf53830e011b07473cb
parentapp-misc/ledger-live: add 2.62.2, drop 2.54.0 (diff)
downloadguru-576ee93d.tar.gz
guru-576ee93d.tar.bz2
guru-576ee93d.zip
sys-boot/zfsbootmenu: add 2.2.0
Signed-off-by: Artemis Everfree <artemis@artemis.sh>
-rw-r--r--sys-boot/zfsbootmenu/Manifest1
-rw-r--r--sys-boot/zfsbootmenu/files/zfsbootmenu-stub-location.patch13
-rw-r--r--sys-boot/zfsbootmenu/zfsbootmenu-2.2.0.ebuild45
3 files changed, 59 insertions, 0 deletions
diff --git a/sys-boot/zfsbootmenu/Manifest b/sys-boot/zfsbootmenu/Manifest
index 9fdbab689..c25b59cb0 100644
--- a/sys-boot/zfsbootmenu/Manifest
+++ b/sys-boot/zfsbootmenu/Manifest
@@ -1 +1,2 @@
DIST zfsbootmenu-1.12.0.tar.gz 1688946 BLAKE2B 291dcc813767def653bc4983cb9ff4c5b1d9f191cb8fee6e9a58cd6826fe0204606aa095339e9eeb6e4dd3201f5f9ad1b4cc3a26712960bf057198225f4b65f9 SHA512 5af3d258eee3ade3e9e11e084f4de0d251acc952348fdc4d3656b32f8fec7460c2d59fa883e06f482bd2f59e1055d6b908cf43c29aee47059d369231197a6645
+DIST zfsbootmenu-2.2.0.tar.gz 1825473 BLAKE2B 3ec2c3b7fb7bfa0f2859978bbfe61fea0702000e8eeb03040cab6230195bb413d8e29dc256154606a3330ab403d05908fe2df6190c133885877e45948e7d5429 SHA512 7428ce3d5b168e65d26e9f2e26196d48287f16ed05c650600990fc5effa27c68d9f3af03eeb16ae7158c761e489ecef31bfbd868c64cc0bdee356ed00e7c0cfe
diff --git a/sys-boot/zfsbootmenu/files/zfsbootmenu-stub-location.patch b/sys-boot/zfsbootmenu/files/zfsbootmenu-stub-location.patch
new file mode 100644
index 000000000..d3daec194
--- /dev/null
+++ b/sys-boot/zfsbootmenu/files/zfsbootmenu-stub-location.patch
@@ -0,0 +1,13 @@
+diff --git a/etc/zfsbootmenu/config.yaml b/etc/zfsbootmenu/config.yaml
+index e8b196c..38b2812 100644
+--- a/etc/zfsbootmenu/config.yaml
++++ b/etc/zfsbootmenu/config.yaml
+@@ -14,6 +14,7 @@ Components:
+ Enabled: false
+ EFI:
+ ImageDir: /boot/efi/EFI/zbm
++ Stub: /usr/lib/systemd/boot/efi/linuxx64.elf.stub
+ Versions: false
+ Enabled: false
+ Kernel:
+
diff --git a/sys-boot/zfsbootmenu/zfsbootmenu-2.2.0.ebuild b/sys-boot/zfsbootmenu/zfsbootmenu-2.2.0.ebuild
new file mode 100644
index 000000000..32175a42e
--- /dev/null
+++ b/sys-boot/zfsbootmenu/zfsbootmenu-2.2.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="ZFS bootloader for root-on-ZFS systems"
+HOMEPAGE="https://zfsbootmenu.org"
+SRC_URI="https://github.com/zbm-dev/zfsbootmenu/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-stub-location.patch
+)
+
+RDEPEND="
+app-shells/fzf
+dev-lang/perl
+dev-perl/boolean
+dev-perl/Config-IniFiles
+dev-perl/Sort-Versions
+dev-perl/YAML-PP
+sys-apps/kexec-tools
+sys-block/mbuffer
+sys-fs/zfs
+sys-kernel/dracut
+"
+
+
+src_compile() {
+ # There's a makefile in the source repo but it's only for install. There's
+ # nothing to compile since zfsbootmenu is all scripts.
+ true
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+}
+
+pkg_postinst () {
+ elog "Please consult upstream doumentation to install the bootloader
+ https://github.com/zbm-dev/zfsbootmenu"
+}