aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2021-10-24 23:56:36 +0300
committerSergey Torokhov <torokhov-s-a@yandex.ru>2021-10-25 00:05:57 +0300
commit584e239fa636150d6680c82fb0a21c7a764ba650 (patch)
tree95d1f0773f6b6d8ca1fe7a11dcf0d088b3328e5a
parentx11-terms/dmd5620: new package (diff)
downloadguru-584e239fa636150d6680c82fb0a21c7a764ba650.tar.gz
guru-584e239fa636150d6680c82fb0a21c7a764ba650.tar.bz2
guru-584e239fa636150d6680c82fb0a21c7a764ba650.zip
sci-physics/SU2: restrict with MPI 3.1 impl. Add custom-mpi option
Meson.build script isn't properly detect mpich as MPI impl., therefore meson option 'custom-mpi' is used now with export of CC=mpicc and CXX=mpicxx as compilers. Mpi implementations is restricted with MPI 3.1 within ebuild. FEATURES="-network-sandbox" could be required to run tests for some mpi implementations/versions. Closes: https://bugs.gentoo.org/819060 Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru>
-rw-r--r--sci-physics/SU2/SU2-7.2.0.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/sci-physics/SU2/SU2-7.2.0.ebuild b/sci-physics/SU2/SU2-7.2.0.ebuild
index 7b3091907..32027c04f 100644
--- a/sci-physics/SU2/SU2-7.2.0.ebuild
+++ b/sci-physics/SU2/SU2-7.2.0.ebuild
@@ -35,7 +35,7 @@ REQUIRED_USE="
RDEPEND="
${PYTHON_DEPS}
- mpi? ( virtual/mpi[cxx] )
+ mpi? ( || ( >=sys-cluster/openmpi-1.10.7[cxx] >=sys-cluster/mpich-3.3[cxx] ) )
mkl? ( sci-libs/mkl )
openblas? ( sci-libs/openblas )
"
@@ -87,6 +87,11 @@ src_prepare(){
}
src_configure() {
+ if use mpi ; then
+ export CC=mpicc
+ export CXX=mpicxx
+ fi
+
local emesonargs=(
-Denable-autodiff=false
-Denable-directdiff=false
@@ -94,6 +99,7 @@ src_configure() {
-Denable-pywrapper=false
-Dwith-omp=false
$(meson_feature mpi with-mpi)
+ $(meson_use mpi custom-mpi)
$(meson_use cgns enable-cgns)
$(meson_use mkl enable-mkl)
$(meson_use mpp enable-mpp)