aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-03-01 06:22:24 +0100
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-03-01 06:28:31 +0100
commit5a37335ff00e3982117155c5089e50a0790c7950 (patch)
tree4a09b83344b04faa5cc6c62016e0d63220649dd1
parentdev-python/spotipy: version bump 2.17.1 (diff)
downloadguru-5a37335f.tar.gz
guru-5a37335f.tar.bz2
guru-5a37335f.zip
sys-auth/mrsh: make systemd units not executable
Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--sys-auth/mrsh/mrsh-2.12-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sys-auth/mrsh/mrsh-2.12-r1.ebuild b/sys-auth/mrsh/mrsh-2.12-r1.ebuild
new file mode 100644
index 000000000..d984b9d20
--- /dev/null
+++ b/sys-auth/mrsh/mrsh-2.12-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit systemd
+
+DESCRIPTION="Mrsh is a set of remote shell programs that use munge authentication."
+HOMEPAGE="https://github.com/chaos/mrsh"
+SRC_URI="https://github.com/chaos/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="pam shadow"
+DEPEND="
+ sys-auth/munge
+
+ pam? ( sys-libs/pam )
+ shadow? ( sys-apps/shadow )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/union-wait-deprecated.diff" )
+
+src_configure() {
+ local myconf=(
+ --disable-static
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+ $(use_with pam)
+ $(use_with shadow)
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ #remove executable bit from systemd units
+ chmod a-x "${ED}/$(systemd_get_systemunitdir)"/* || die
+}