aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPascal Jäger <pascal.jaeger@leimstift.de>2022-05-02 21:29:12 +0200
committerPascal Jäger <pascal.jaeger@leimstift.de>2022-05-02 21:29:12 +0200
commit5ab9a350f060f3666e0a394c0d0fd0de293fccee (patch)
tree622b124d96a8b790a17b9a5d06fc9d9538a2214a
parentsci-biology/cmdock: masked (diff)
downloadguru-5ab9a350.tar.gz
guru-5ab9a350.tar.bz2
guru-5ab9a350.zip
games-misc/an-anime-game-launcher-bin: changed dependency
Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de>
-rw-r--r--games-misc/an-anime-game-launcher-bin/an-anime-game-launcher-bin-2.3.1-r1.ebuild (renamed from games-misc/an-anime-game-launcher-bin/an-anime-game-launcher-bin-2.3.1.ebuild)32
1 files changed, 8 insertions, 24 deletions
diff --git a/games-misc/an-anime-game-launcher-bin/an-anime-game-launcher-bin-2.3.1.ebuild b/games-misc/an-anime-game-launcher-bin/an-anime-game-launcher-bin-2.3.1-r1.ebuild
index d26efcf26..b01224940 100644
--- a/games-misc/an-anime-game-launcher-bin/an-anime-game-launcher-bin-2.3.1.ebuild
+++ b/games-misc/an-anime-game-launcher-bin/an-anime-game-launcher-bin-2.3.1-r1.ebuild
@@ -1,4 +1,3 @@
-
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
@@ -6,18 +5,17 @@ EAPI=8
inherit xdg-utils
-DESCRIPTION="Open Source An Anime Game launcher for Linux with automatic anti-cheat patching and telemetry disabling"
+DESCRIPTION="Open Source An Anime Game launcher for Linux with automatic anti-cheat patching and telemetry disabling, binary package"
HOMEPAGE="https://gitlab.com/an-anime-team/an-anime-game-launcher"
SRC_URI="https://gitlab.com/an-anime-team/aagl-ebuilds/-/archive/${PV}/aagl-ebuilds-${PV}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64"
-IUSE=""
DEPEND="
|| ( dev-libs/libayatana-appindicator dev-libs/libayatana-appindicator-bin ) \
net-libs/webkit-gtk \
- dev-util/xdelta \
+ dev-util/xdelta[lzma] \
app-arch/tar \
dev-vcs/git \
app-arch/unzip \
@@ -30,8 +28,6 @@ DEPEND="
app-emulation/winetricks \
virtual/wine \
"
-# !games-misc/an-anime-game-launcher \
-# "
RDEPEND="${DEPEND}"
@@ -41,7 +37,6 @@ S="${WORKDIR}/aagl-ebuilds-${PV}"
src_prepare(){
mv "icon.png" "${PN}.png"
mv "launcher.sh" "${PN}"
- chmod +x "An_Anime_Game_Launcher.AppImage"
./An_Anime_Game_Launcher.AppImage --appimage-extract || die "Extraction Failed"
chrpath -d "squashfs-root/public/discord-rpc/discord-rpc" || die "Patching Library Failed"
eapply_user
@@ -49,27 +44,16 @@ src_prepare(){
src_install(){
insinto "/usr/lib/${PN}"
- einfo "Inserting Launcher Files"
- doins -r "squashfs-root/resources.neu"
- einfo "Inserting Launcher Binary"
- doins -r "squashfs-root/an-anime-game-launcher"
- einfo "Setting Executable Permissions for Binary"
- chmod +x "${D}/usr/lib/${PN}/an-anime-game-launcher"
- einfo "Inserting More Launcher Files"
+ doins "squashfs-root/resources.neu"
+ exeinto "/usr/lib/${PN}"
+ doexe "squashfs-root/an-anime-game-launcher"
doins -r "squashfs-root/public"
- einfo "Inserting Icons"
insinto "/usr/share/pixmaps"
- doins "${PN}.png" || die "Insertion Failed"
- einfo "Inserting Start Script"
- insinto "/usr/bin"
- doins "${PN}" || die "Insertion Failed"
- einfo "Setting Executable Permissions for Launch Script"
- chmod +x "${D}/usr/bin/${PN}"
- einfo "Inserting Desktop Shortcut"
+ doins "${PN}.png"
+ exeinto "/usr/bin"
+ doexe "${PN}"
insinto "/usr/share/applications/"
doins "${PN}.desktop"
- einfo "Setting Read Permissions for Launcher Files"
- chmod -R 775 "${D}/usr/lib/${PN}/public"
}
pkg_postinst() {