aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlberto Gireud <agireud@protonmail.com>2024-03-03 21:36:51 -0600
committerAlberto Gireud <agireud@protonmail.com>2024-03-03 22:57:35 -0600
commit60e5c5396db601c04febca6629d109b44fd441cc (patch)
tree644edbec8b1345c1bd39cff5343a898842cd8809
parentprofiles: Unmask app-admin/ananicy-cpp (diff)
downloadguru-60e5c539.tar.gz
guru-60e5c539.tar.bz2
guru-60e5c539.zip
app-admin/ananicy-cpp: add 1.1.1
Signed-off-by: Alberto Gireud <agireud@protonmail.com>
-rw-r--r--app-admin/ananicy-cpp/Manifest1
-rw-r--r--app-admin/ananicy-cpp/ananicy-cpp-1.1.1.ebuild49
-rw-r--r--app-admin/ananicy-cpp/metadata.xml4
3 files changed, 54 insertions, 0 deletions
diff --git a/app-admin/ananicy-cpp/Manifest b/app-admin/ananicy-cpp/Manifest
index a6cc104622..16a5793651 100644
--- a/app-admin/ananicy-cpp/Manifest
+++ b/app-admin/ananicy-cpp/Manifest
@@ -1,2 +1,3 @@
DIST ananicy-cpp-v1.0.0-rc6.tar.bz2 41819 BLAKE2B f2d051e12784a66a141c294dd38c84f3d7d392cad0b8e7c8e563b11990695493ceb326df30869ca3647ac19be5eeda1e360e5dd358e1ab7e6af32f58cb240fbf SHA512 8703fd4a12a7a81385f6289a3eb16f7f42f160eebfc3493b3f82eeb2b104539e1911dafcacfc772a2add71dec89bcf94e53958021868f999bdfd1bdf06edac32
+DIST ananicy-cpp-v1.1.1.tar.bz2 326329 BLAKE2B b9e62e2e2a2ee956b6e1e3b0e484e340bbaa8a62f851c342efa5ce9a896d477213cd10aea5dc2f9978fdaddc85d17473a9ed9a0544d83fca01b52ecb09f6bbfd SHA512 ef351d45d54c6f3c60be9208e105d3952b88ad31708247dbda02c2de0e4852f29f06ba8c4f82a50f8d2bd1aa51f6fc914f9d7c13f598e21b527155bd0cbde27c
DIST minq-ananicy-9180bb4511e2de5229428303df1a4954b0c516d9.tar.gz 48127 BLAKE2B f8cd256b141df6cca7feba22595afa7f2d92284a86b9fc9794630faad339828b1343dae87537fd054b33a87d59278f56178fbcb5af545e710232e8c518ac9e66 SHA512 846849c4c0466166f09cf3da4ef1e5a339680bbe5b823838b4aa7f8b5b69871498c9387aff2eb01c09991cad894d145b3ae76bce4403f55bf14c78b42a81a1a5
diff --git a/app-admin/ananicy-cpp/ananicy-cpp-1.1.1.ebuild b/app-admin/ananicy-cpp/ananicy-cpp-1.1.1.ebuild
new file mode 100644
index 0000000000..9ccfb2cf21
--- /dev/null
+++ b/app-admin/ananicy-cpp/ananicy-cpp-1.1.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Ananicy rewritten in C++ for much lower CPU and memory usage"
+HOMEPAGE="https://gitlab.com/ananicy-cpp/ananicy-cpp"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+regex systemd +threads"
+
+SRC_URI="https://gitlab.com/ananicy-cpp/ananicy-cpp/-/archive/v${PV}/${PN}-v${PV}.tar.bz2"
+S="${WORKDIR}/${PN}-v${PV}"
+
+DEPEND="
+ !app-admin/ananicy
+ >=dev-cpp/nlohmann_json-3.9
+ >=dev-libs/libfmt-8
+ >=dev-libs/spdlog-1.9
+ regex? ( >=dev-libs/libpcre2-8 )
+ systemd? ( sys-apps/systemd )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_REGEX_SUPPORT=$(usex regex)
+ -DENABLE_SYSTEMD=$(usex systemd)
+ -DENABLE_THREADS=$(usex threads)
+ -DUSE_EXTERNAL_FMTLIB=ON
+ -DUSE_EXTERNAL_JSON=ON
+ -DUSE_EXTERNAL_SPDLOG=ON
+ -DVERSION=${PV}
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ if ! use systemd ; then
+ doinitd "${FILESDIR}/${PN}.initd"
+ fi
+
+ keepdir /etc/ananicy.d
+}
diff --git a/app-admin/ananicy-cpp/metadata.xml b/app-admin/ananicy-cpp/metadata.xml
index 52724a1795..7f705e1709 100644
--- a/app-admin/ananicy-cpp/metadata.xml
+++ b/app-admin/ananicy-cpp/metadata.xml
@@ -10,4 +10,8 @@
<remote-id type="gitlab">ananicy-cpp/ananicy-cpp</remote-id>
<remote-id type="github">kuche1/minq-ananicy</remote-id>
</upstream>
+ <use>
+ <flag name="regex">Enable regex support.</flag>
+ <flag name="threads">Enable threading support.</flag>
+ </use>
</pkgmetadata>