aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2022-11-03 04:13:43 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2022-11-03 06:12:52 +0500
commit62688c3054329d2e12c243ebf4af33719af67625 (patch)
treeb3bc56d250e5bcddde19633d9eff3c921e883af4
parentdev-cpp/cli11: add 2.3.1, drop 2.2.0 (diff)
downloadguru-62688c30.tar.gz
guru-62688c30.tar.bz2
guru-62688c30.zip
dev-python/asyncpg: add 0.27.0, drop 0.25.0
Closes: https://bugs.gentoo.org/878787 Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
-rw-r--r--dev-python/asyncpg/Manifest2
-rw-r--r--dev-python/asyncpg/asyncpg-0.25.0.ebuild26
-rw-r--r--dev-python/asyncpg/asyncpg-0.27.0.ebuild37
3 files changed, 38 insertions, 27 deletions
diff --git a/dev-python/asyncpg/Manifest b/dev-python/asyncpg/Manifest
index 4ccb5036a..af055e2fe 100644
--- a/dev-python/asyncpg/Manifest
+++ b/dev-python/asyncpg/Manifest
@@ -1,2 +1,2 @@
-DIST asyncpg-0.25.0.tar.gz 804292 BLAKE2B 55e679716fe6dab82be9142f1abaa0e47671341b91f4fd182ad564e41a61dbc91990f767e6b0e7d0d00658d530075493d67f284272239c92d3015016ec0dfb2b SHA512 7afa5ae42c0d5cab93bb1c3266bad11ce2e7c271d7ffd2c5d92e373fd8e06be89e4b18e8fd3ffd7e750e913944630f1ae6c947e20faa63f99ded7d867ad6cd80
DIST asyncpg-0.26.0.tar.gz 809997 BLAKE2B 360dfadcd729ade63c156e3a16def7f652dbc4d0c76189ac88e01fa814f9a3ab4f1bd2852658a93e22a8e275fb1a4e69df2e3c30f457110291f0641ac6d12d8d SHA512 ef92316fd430a1819aa8170abd67ecfc1cf29c42cb6dc06cf5047cdd71d4abf441c8b86bacafaaa8c0c0fd7c66daa275e9ed68b00e5166bb27929f25cab1dcbd
+DIST asyncpg-0.27.0.tar.gz 808881 BLAKE2B e4fe88346a3fb4d9b6ce74a4e12db333f1aefd8844d6b08091a1e507a56754bb74dcbdd1b43329f1df24725f03c808a1862c8c4587c9ec95c4800f30ab78458c SHA512 66d4e16cba8ebebfa0403c7d3b1d3ee1b9b8f55a9b70f57e809d28161873d74750152e6ed548b17ceb97ca84f7a669a5fa503c824a861b295db731f86bfb0137
diff --git a/dev-python/asyncpg/asyncpg-0.25.0.ebuild b/dev-python/asyncpg/asyncpg-0.25.0.ebuild
deleted file mode 100644
index 19f81658b..000000000
--- a/dev-python/asyncpg/asyncpg-0.25.0.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="A fast PostgreSQL Database Client Library for Python/asyncio."
-HOMEPAGE="https://github.com/MagicStack/asyncpg"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-# ModuleNotFoundError: No module named 'asyncpg.protocol.protocol'
-# for some reason, still doesn't work if package is already installed
-# or with distutils_install_for_testing function
-RESTRICT="test"
-
-BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs dev-python/sphinxcontrib-asyncio dev-python/sphinx_rtd_theme
diff --git a/dev-python/asyncpg/asyncpg-0.27.0.ebuild b/dev-python/asyncpg/asyncpg-0.27.0.ebuild
new file mode 100644
index 000000000..8a3356cc1
--- /dev/null
+++ b/dev-python/asyncpg/asyncpg-0.27.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} ) # doesn't build with pypy3
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="A fast PostgreSQL Database Client Library for Python/asyncio"
+HOMEPAGE="https://github.com/MagicStack/asyncpg"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-db/postgresql
+ dev-python/flake8[${PYTHON_USEDEP}]
+ dev-python/uvloop[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+distutils_enable_sphinx docs dev-python/sphinxcontrib-asyncio dev-python/sphinx_rtd_theme
+
+python_test() {
+ cd "${T}" || die
+ for opt in "" "1"; do
+ einfo " testing with USE_UVLOOP='${opt}'"
+ USE_UVLOOP="${opt}" eunittest "${S}"/tests
+ done
+}