aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-10-04 00:22:37 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-10-04 00:22:37 +0200
commit649b6269243b88fc75ecba8a21d958d60637cdb7 (patch)
treee36a22a871e01232c517ecbad743a3d3bc2896f7
parentdev-python/autoflake: EAPI 8 (diff)
downloadguru-649b6269.tar.gz
guru-649b6269.tar.bz2
guru-649b6269.zip
dev-python/manhole: EPYTEST_DESELECT
Package-Manager: Portage-3.0.26, Repoman-3.0.3 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--dev-python/manhole/manhole-1.8.0-r1.ebuild46
-rw-r--r--dev-python/manhole/manhole-1.8.0.ebuild49
2 files changed, 46 insertions, 49 deletions
diff --git a/dev-python/manhole/manhole-1.8.0-r1.ebuild b/dev-python/manhole/manhole-1.8.0-r1.ebuild
new file mode 100644
index 0000000000..a49107d059
--- /dev/null
+++ b/dev-python/manhole/manhole-1.8.0-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+EPYTEST_DESELECT=(
+ "tests/test_manhole.py::test_non_daemon_connection"
+ "tests/test_manhole.py::test_daemon_connection"
+ "tests/test_manhole.py::test_uwsgi"
+ "tests/test_manhole.py::test_fork_exec"
+ "tests/test_manhole.py::test_connection_handler_exec[str]"
+ "tests/test_manhole.py::test_connection_handler_exec[func]"
+ "tests/test_manhole.py::test_environ_variable_activation"
+ "tests/test_manhole.py::test_stderr_doesnt_deadlock"
+ "tests/test_manhole_cli.py"
+)
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Debugging manhole for python application"
+HOMEPAGE="
+ https://github.com/ionelmc/python-manhole
+ https://pypi.org/project/manhole
+"
+SRC_URI="https://github.com/ionelmc/python-${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/python-${PN}-${PV}"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+DEPEND="
+ test? (
+ dev-python/gevent[${PYTHON_USEDEP}]
+ dev-python/process-tests[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/eventlet[${PYTHON_USEDEP}]' python3.8 python3.9)
+ )
+"
+
+DOCS=( AUTHORS.rst CHANGELOG.rst README.rst )
+
+distutils_enable_tests --install pytest
+distutils_enable_sphinx docs dev-python/sphinx-py3doc-enhanced-theme
diff --git a/dev-python/manhole/manhole-1.8.0.ebuild b/dev-python/manhole/manhole-1.8.0.ebuild
deleted file mode 100644
index eae6b4e6c4..0000000000
--- a/dev-python/manhole/manhole-1.8.0.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-inherit distutils-r1
-
-DESCRIPTION="Debugging manhole for python application"
-HOMEPAGE="
- https://github.com/ionelmc/python-manhole
- https://pypi.org/project/manhole
-"
-SRC_URI="https://github.com/ionelmc/python-${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/python-${PN}-${PV}"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-
-BDEPEND="test? (
- dev-python/gevent[${PYTHON_USEDEP}]
- dev-python/process-tests[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- $(python_gen_cond_dep \
- 'dev-python/eventlet[${PYTHON_USEDEP}]' python3.8 python3.9)
-)"
-
-DOCS=( AUTHORS.rst CHANGELOG.rst README.rst )
-
-distutils_enable_tests --install pytest
-distutils_enable_sphinx docs dev-python/sphinx-py3doc-enhanced-theme
-
-python_test() {
- epytest_args=(
- --deselect tests/test_manhole.py::test_non_daemon_connection
- --deselect tests/test_manhole.py::test_daemon_connection
- --deselect tests/test_manhole.py::test_uwsgi
- --deselect tests/test_manhole.py::test_fork_exec
- --deselect tests/test_manhole.py::test_connection_handler_exec[str]
- --deselect tests/test_manhole.py::test_connection_handler_exec[func]
- --deselect tests/test_manhole.py::test_environ_variable_activation
- --deselect tests/test_manhole.py::test_stderr_doesnt_deadlock
- --deselect tests/test_manhole_cli.py
- )
-
- epytest "${epytest_args[@]}"
-}