aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna Vyalkova <cyber@sysrq.in>2021-05-16 20:27:13 +0500
committerAnna Vyalkova <cyber@sysrq.in>2021-05-16 21:11:07 +0500
commit6589ae6d525486533404f8303423bec001288cd1 (patch)
tree1685b14e4ddff67d7cb6bafb3f51f7267148937f
parentsys-cluster/sionlib: fix tests (diff)
downloadguru-6589ae6d.tar.gz
guru-6589ae6d.tar.bz2
guru-6589ae6d.zip
media-gfx/azpainter: fix AR and paths, drop old
Closes: https://bugs.gentoo.org/785097 Signed-off-by: Anna Vyalkova <cyber@sysrq.in>
-rw-r--r--media-gfx/azpainter/Manifest1
-rw-r--r--media-gfx/azpainter/azpainter-2.1.6.ebuild36
-rw-r--r--media-gfx/azpainter/azpainter-2.1.7.ebuild14
-rw-r--r--media-gfx/azpainter/files/azpainter-2.1.6-fix_configure.patch83
-rw-r--r--media-gfx/azpainter/files/azpainter-2.1.6-signed_char.patch156
5 files changed, 13 insertions, 277 deletions
diff --git a/media-gfx/azpainter/Manifest b/media-gfx/azpainter/Manifest
index aa609f178..40a96a355 100644
--- a/media-gfx/azpainter/Manifest
+++ b/media-gfx/azpainter/Manifest
@@ -1,2 +1 @@
-DIST azpainter-2.1.6.tar.xz 747464 BLAKE2B a3d242cb3fa881c761711595686362924e55125f7b33def30949c321b6a23ccb2bed1b4d3df0b7e73ebd4a5f6a75e7c4b99c4116d5e6af62518d03fc92e6de81 SHA512 94ebe3ad8df7148d73a6f73fe383df2d8b9203aa67ef77ebcc68c8fa937ba134315ca757693c5ad33bdf79afd90915779a3086d24f5a81ab767eced50d4d97d9
DIST azpainter-2.1.7.tar.xz 758960 BLAKE2B a70371777d8f5a8a976032fb13fe21343d852442c3ca1eaa8d4ebdb0aeec25bf9d532a2d03c58c55df629b4a299b2d40100ba83909476d4e0a15b05ea27a5527 SHA512 7edcfe1e3a1f87b6cd3006da288d9a11c3667f49da73d9fa7665f4e2edb90282b30ec356b5f1eda3559b3c51c1f99e585f4b60d6039ba3c8c28da50022f9c798
diff --git a/media-gfx/azpainter/azpainter-2.1.6.ebuild b/media-gfx/azpainter/azpainter-2.1.6.ebuild
deleted file mode 100644
index 911ef759a..000000000
--- a/media-gfx/azpainter/azpainter-2.1.6.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 2018-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs xdg
-
-DESCRIPTION="Full color painting software for Linux for illustration drawing"
-HOMEPAGE="http://azsky2.html.xdomain.jp/soft/azpainter.html https://github.com/Symbian9/azpainter"
-SRC_URI="https://github.com/Symbian9/azpainter/releases/download/v${PV}/${P}.tar.xz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="
- x11-libs/libX11:=
- x11-libs/libXext:=
- x11-libs/libXi:=
- media-libs/freetype:=
- media-libs/fontconfig:=
- sys-libs/zlib:=
- media-libs/libpng:=
- media-libs/libjpeg-turbo:=
-"
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}/${P}-fix_configure.patch"
- "${FILESDIR}/${P}-signed_char.patch"
-)
-
-src_configure() {
- sh ./configure --prefix=/usr CC="$(tc-getCC)" CFLAGS="${CFLAGS:-02}" LDFLAGS="${LDFLAGS}"
-}
diff --git a/media-gfx/azpainter/azpainter-2.1.7.ebuild b/media-gfx/azpainter/azpainter-2.1.7.ebuild
index d23ebdfa5..0a46c057a 100644
--- a/media-gfx/azpainter/azpainter-2.1.7.ebuild
+++ b/media-gfx/azpainter/azpainter-2.1.7.ebuild
@@ -26,6 +26,18 @@ DEPEND="
"
RDEPEND="${DEPEND}"
+DOCS=( AUTHORS ChangeLog ReadMe_en ReadMe_ja manual_ja.html )
+
src_configure() {
- sh ./configure --prefix=/usr CC="$(tc-getCC)" CFLAGS="${CFLAGS:-02}" LDFLAGS="${LDFLAGS}"
+ sh ./configure --prefix=/usr CC="$(tc-getCC)" CFLAGS="${CFLAGS:-02}" LDFLAGS="${LDFLAGS}" || die "./configure failed"
+}
+
+src_compile() {
+ tc-export AR
+ default
+}
+
+src_install() {
+ default
+ rm -r "${D}/usr/share/doc/${PN}" || die
}
diff --git a/media-gfx/azpainter/files/azpainter-2.1.6-fix_configure.patch b/media-gfx/azpainter/files/azpainter-2.1.6-fix_configure.patch
deleted file mode 100644
index f8824dd68..000000000
--- a/media-gfx/azpainter/files/azpainter-2.1.6-fix_configure.patch
+++ /dev/null
@@ -1,83 +0,0 @@
-From 185bf21dd0040a11cbffddb6e4bcf7af46a5bef7 Mon Sep 17 00:00:00 2001
-From: app4soft <appsoft@ua.fm>
-Date: Sun, 26 Apr 2020 06:54:09 +0300
-Subject: [PATCH] Update configure
-
----
- README | 2 +-
- README_ja | 2 +-
- configure | 11 ++++++-----
- 3 files changed, 8 insertions(+), 7 deletions(-)
- mode change 100755 => 100644 configure
-
-diff --git a/README b/README
-index ba5f2c8..610e423 100644
---- a/README
-+++ b/README
-@@ -90,7 +90,7 @@ $ gmake
-
- ## MacOS
-
--$ ./configure --prefix=/usr/X11
-+$ ./configure --prefix=/opt/X11
- $ make
- $ sudo make install
-
-diff --git a/README_ja b/README_ja
-index db190f2..997a499 100644
---- a/README_ja
-+++ b/README_ja
-@@ -102,7 +102,7 @@ $ gmake
-
- ## MacOS
-
--$ ./configure --prefix=/usr/X11
-+$ ./configure --prefix=/opt/X11
- $ make
- $ sudo make install
-
-diff --git a/configure b/configure
-old mode 100755
-new mode 100644
-index cb9a9f6..e98b20f
---- a/configure
-+++ b/configure
-@@ -9,7 +9,7 @@ cat <<_ZYXW_
-
- Options:
- --help display this help
-- --debug create debug exe (CFLAGS += -g)
-+ --debug create debug exe (CFLAGS = -g)
- --arch=[ARCH] CFLAGS += "-march=ARCH"
-
- --prefix=[PREFIX] install dir
-@@ -202,7 +202,8 @@ for opt;do
- --no-check-lib)
- cf_check_lib=no ;;
- *=*)
-- eval "$opt" ;;
-+ tmp2=`expr "X$opt" : 'X\([^=]*\)=.*'`
-+ eval $tmp2=\'$tmp1\' ;;
- *)
- echo "unknown option: $opt"
- exit 1 ;;
-@@ -226,8 +227,8 @@ tmp1=`uname`
- if test "$tmp1" = Linux;then cf_os=linux
- elif test "$tmp1" = Darwin;then
- cf_os=mac
-- CFLAGS=`fc_add_string "$CFLAGS" "-I/usr/X11/include"`
-- LDFLAGS=`fc_add_string "$LDFLAGS" "-L/usr/X11/lib"`
-+ CFLAGS=`fc_add_string "$CFLAGS" "-I/opt/X11/include"`
-+ LDFLAGS=`fc_add_string "$LDFLAGS" "-L/opt/X11/lib"`
- elif test "$tmp1" = FreeBSD;then
- cf_os=freebsd
- cf_make=gmake
-@@ -311,7 +312,7 @@ fc_check_lib libjpeg "libjpeg" "" "-ljpeg" "stdio.h jpeglib.h" "libjpeg-dev or l
- fc_check_lib X11 "x11" "" "-lX11" "X11/Xlib.h" "libx11-dev or libX11-devel or libx11"
- fc_check_lib Xext "xext" "" "-lXext" "X11/Xlib.h X11/extensions/XShm.h" "libxext-dev or libXext-devel or libxext"
- fc_check_lib XInput "xi" "" "-lXi" "X11/Xlib.h X11/extensions/XInput2.h" "libxi-dev or libXi-devel or libxi"
--fc_check_lib fontconfig "fontconfig" "-I/usr/include/freetype2 -I/usr/X11/include/freetype2 -I/usr/local/include/freetype2" "-lfontconfig -lfreetype" "fontconfig/fontconfig.h" "libfontconfig1-dev or libfontconfig-devel or fontconfig"
-+fc_check_lib fontconfig "fontconfig" "-I/usr/include/freetype2 -I/opt/X11/include/freetype2 -I/usr/local/include/freetype2" "-lfontconfig -lfreetype" "fontconfig/fontconfig.h" "libfontconfig1-dev or libfontconfig-devel or fontconfig"
- fc_check_lib freetype2 "freetype2" "" "" "ft2build.h" "libfreetype6-dev or libfreetype6-devel or freetype2"
-
- #------------------
diff --git a/media-gfx/azpainter/files/azpainter-2.1.6-signed_char.patch b/media-gfx/azpainter/files/azpainter-2.1.6-signed_char.patch
deleted file mode 100644
index 37ce20e4a..000000000
--- a/media-gfx/azpainter/files/azpainter-2.1.6-signed_char.patch
+++ /dev/null
@@ -1,156 +0,0 @@
-From ae5f30e94afff11c2ba2bf87954465b99f015a32 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Charl=C3=A8ne?= <julianaito@posteo.jp>
-Date: Fri, 24 Apr 2020 18:32:52 +0200
-Subject: [PATCH] Some architectures like powerpc and arm have unsigned char by
- default, unlike the others, and it causes runtime issues like
- https://github.com/Symbian9/azpainter/issues/6
-
-As such, use signed char when necessary.
----
- mlib/include/mTextParam.h | 2 +-
- mlib/include/mUtilStr.h | 2 +-
- mlib/src/mStr.c | 3 ++-
- mlib/src/mTextParam.c | 2 +-
- mlib/src/mUtilStr.c | 2 +-
- src/configfile.c | 2 +-
- src/other/FillPolygon.c | 4 ++--
- src/other/undo_compress.c | 4 ++--
- src/widget/DockObject.c | 2 +-
- 9 files changed, 12 insertions(+), 11 deletions(-)
-
-diff --git a/mlib/include/mTextParam.h b/mlib/include/mTextParam.h
-index 7e177d4..449dc94 100755
---- a/mlib/include/mTextParam.h
-+++ b/mlib/include/mTextParam.h
-@@ -27,7 +27,7 @@ extern "C" {
- typedef struct _mTextParam mTextParam;
-
- void mTextParamFree(mTextParam *p);
--mTextParam *mTextParamCreate(const char *text,char split,char splitparam);
-+mTextParam *mTextParamCreate(const char *text,char split,signed char splitparam);
-
- mBool mTextParamGetInt(mTextParam *p,const char *key,int *dst);
- mBool mTextParamGetInt_range(mTextParam *p,const char *key,int *dst,int min,int max);
-diff --git a/mlib/include/mUtilStr.h b/mlib/include/mUtilStr.h
-index aacb043..40bdcdf 100755
---- a/mlib/include/mUtilStr.h
-+++ b/mlib/include/mUtilStr.h
-@@ -55,7 +55,7 @@ mBool mIsMatchString(const char *text,const char *pattern,mBool bNoCase);
- mBool mIsMatchStringSum(const char *text,const char *pattern,char split,mBool bNoCase);
- int mGetEqStringIndex(const char *text,const char *enumtext,char split,mBool bNoCase);
-
--char *mGetFormatStrParam(const char *text,const char *key,char split,char paramsplit,mBool bNoCase);
-+char *mGetFormatStrParam(const char *text,const char *key,signed char split,signed char paramsplit,mBool bNoCase);
-
- #ifdef __cplusplus
- }
-diff --git a/mlib/src/mStr.c b/mlib/src/mStr.c
-index 55f0819..a657a4e 100755
---- a/mlib/src/mStr.c
-+++ b/mlib/src/mStr.c
-@@ -793,7 +793,8 @@ int mStrSetURIList(mStr *str,const char *uri,mBool localfile)
-
- void mStrSetURLEncode(mStr *str,const char *text)
- {
-- char c,flag,m[6];
-+ char flag,m[6];
-+ signed char c;
-
- mStrEmpty(str);
-
-diff --git a/mlib/src/mTextParam.c b/mlib/src/mTextParam.c
-index e88f8be..3696ec7 100755
---- a/mlib/src/mTextParam.c
-+++ b/mlib/src/mTextParam.c
-@@ -185,7 +185,7 @@ void mTextParamFree(mTextParam *p)
- * @param split ';' など、各値を区切る文字
- * @param splitparam '=' など、キーと値を区切る文字 (-1 で '=') */
-
--mTextParam *mTextParamCreate(const char *text,char split,char splitparam)
-+mTextParam *mTextParamCreate(const char *text,char split,signed char splitparam)
- {
- mTextParam *p;
-
-diff --git a/mlib/src/mUtilStr.c b/mlib/src/mUtilStr.c
-index d82abed..5f0c993 100755
---- a/mlib/src/mUtilStr.c
-+++ b/mlib/src/mUtilStr.c
-@@ -655,7 +655,7 @@ int mGetEqStringIndex(const char *text,const char *enumtext,char split,mBool bNo
- * @return 確保された文字列。NULL でなし */
-
- char *mGetFormatStrParam(const char *text,const char *key,
-- char split,char paramsplit,mBool bNoCase)
-+ signed char split,signed char paramsplit,mBool bNoCase)
- {
- const char *pc,*pend,*pkeyend;
- int ret;
-diff --git a/src/configfile.c b/src/configfile.c
-index a54be5f..ce77aad 100755
---- a/src/configfile.c
-+++ b/src/configfile.c
-@@ -166,7 +166,7 @@ static void _load_draw_rule_record(mIniRead *ini)
- static void _normalize_panel_layout(ConfigData *cf)
- {
- char *pc;
-- char buf[4];
-+ signed char buf[4];
- int i,no,pos;
-
- //----- ペイン
-diff --git a/src/other/FillPolygon.c b/src/other/FillPolygon.c
-index 7bf91e6..8265a8e 100755
---- a/src/other/FillPolygon.c
-+++ b/src/other/FillPolygon.c
-@@ -317,7 +317,7 @@ mBool FillPolygon_getIntersection_noAA(FillPolygon *p,int yy)
- {
- int i,x;
- mDoublePoint *ptbuf,*pt1,*pt2;
-- char dir;
-+ signed char dir;
- double y;
-
- //交点クリア
-@@ -413,7 +413,7 @@ static mBool _get_intersection_aa(FillPolygon *p,double y)
- {
- mDoublePoint *ptbuf,pt1,pt2,pttmp;
- int i,x;
-- char dir;
-+ signed char dir;
-
- //交点クリア
-
-diff --git a/src/other/undo_compress.c b/src/other/undo_compress.c
-index 171692c..a86fd61 100755
---- a/src/other/undo_compress.c
-+++ b/src/other/undo_compress.c
-@@ -91,7 +91,7 @@ void UndoByteDecode(uint8_t *dst,uint8_t *src,int srcsize)
- {
- uint8_t *ps,*psend;
- int len;
-- char lenb;
-+ signed char lenb;
-
- ps = src;
- psend = src + srcsize;
-@@ -193,7 +193,7 @@ int UndoWordDecode(uint8_t *dst,uint8_t *src,int srcsize)
- uint8_t *ps,*psend;
- uint16_t *pd,val;
- int len,size;
-- char lenb;
-+ signed char lenb;
-
- pd = (uint16_t *)dst;
- ps = src;
-diff --git a/src/widget/DockObject.c b/src/widget/DockObject.c
-index 733b158..35aefd2 100755
---- a/src/widget/DockObject.c
-+++ b/src/widget/DockObject.c
-@@ -313,7 +313,7 @@ void DockObjects_all_windowMode(int type)
-
- void DockObject_normalize_layout_config()
- {
-- char buf[DOCKWIDGET_NUM + 2];
-+ signed char buf[DOCKWIDGET_NUM + 2];
- int i,pos,paneno,no;
- char *pc;
-