aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2021-01-05 16:46:02 +0300
committerSergey Torokhov <torokhov-s-a@yandex.ru>2021-01-05 16:46:02 +0300
commit66db3c61843e58a56d2855f7b9445e3f19620bae (patch)
treeece8f0b4264826c6cdf9bbcacbcd9b92eb2003f4
parentsci-physics/SU2: drop old 7.0.6, 7.0.7 (diff)
downloadguru-66db3c61.tar.gz
guru-66db3c61.tar.bz2
guru-66db3c61.zip
sci-physics/SU2: 7.0.8-r1, mv fix-python-optimize.patch to external repo
Due to large size of "SU2-7.0.8-fix-python-optimize.patch" move it to external repository to fetch separately. This patch is required only to generate ".pyc" files during execution "python_optimize" command on "src_install()" phase to fix "TabError: inconsistent use of tabs and spaces in indentation". Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru>
-rw-r--r--sci-physics/SU2/SU2-7.0.8-r1.ebuild (renamed from sci-physics/SU2/SU2-7.0.8.ebuild)13
1 files changed, 7 insertions, 6 deletions
diff --git a/sci-physics/SU2/SU2-7.0.8.ebuild b/sci-physics/SU2/SU2-7.0.8-r1.ebuild
index 30feedd45..f7e5b83f1 100644
--- a/sci-physics/SU2/SU2-7.0.8.ebuild
+++ b/sci-physics/SU2/SU2-7.0.8-r1.ebuild
@@ -11,6 +11,7 @@ DESCRIPTION="SU2: An Open-Source Suite for Multiphysics Simulation and Design"
HOMEPAGE="https://su2code.github.io/"
SRC_URI="
https://github.com/su2code/SU2/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/band-a-prend/gentoo-overlay/raw/master/sci-physics/${PN}/files/${P}-fix-python-optimize.patch
test? ( https://github.com/su2code/TestCases/archive/v7.0.7.tar.gz -> ${PN}-7.0.7-TestCases.tar.gz )
tutorials? ( https://github.com/su2code/Tutorials/archive/v7.0.7.tar.gz -> ${PN}-7.0.7-Tutorials.tar.gz )
"
@@ -42,12 +43,12 @@ DEPEND="
BDEPEND="virtual/pkgconfig"
PATCHES=(
- "${FILESDIR}/${P}-fix-env.patch"
"${FILESDIR}/${PN}-7.0.4-unbundle_boost.patch"
- "${FILESDIR}/${P}-fix-python-optimize.patch"
+ "${FILESDIR}/${P}-fix-env.patch"
+ "${DISTDIR}/${P}-fix-python-optimize.patch"
)
-DOCS=( "LICENSE.md" "README.md" "SU2_PY/documentation.txt" )
+DOCS=( "README.md" "SU2_PY/documentation.txt" )
src_unpack() {
unpack "${P}.tar.gz"
@@ -57,7 +58,7 @@ src_unpack() {
fi
if use tutorials ; then
einfo "Unpacking ${PN}-7.0.7-Tutorials.tar.gz to /var/tmp/portage/sci-physics/${P}/work/${P}"
- mkdir "${P}"/Tutorials
+ mkdir "${P}"/Tutorials || die
tar -C "${P}"/Tutorials --strip-components=1 -xzf "${DISTDIR}/${PN}-7.0.7-Tutorials.tar.gz" || die
fi
}
@@ -103,8 +104,8 @@ src_test() {
src_install() {
meson_src_install
- mkdir -p "${ED}$(python_get_sitedir)"
- mv "${ED}"/usr/bin/{FSI,SU2,*.py} -t "${ED}$(python_get_sitedir)"
+ mkdir -p "${ED}$(python_get_sitedir)" || die
+ mv "${ED}"/usr/bin/{FSI,SU2,*.py} -t "${ED}$(python_get_sitedir)" || die
python_optimize "${D}/$(python_get_sitedir)"
if use tutorials ; then