aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2022-01-22 02:29:38 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2022-01-22 02:30:32 +0500
commit69b68d7ffa779e2a920b999e7e8a52ee69641891 (patch)
tree759db02b2b45763068aece06e64a36d055b4208f
parentmedia-fonts/twemoji: initial import (diff)
downloadguru-69b68d7f.tar.gz
guru-69b68d7f.tar.bz2
guru-69b68d7f.zip
app-vim/dracula: initial import
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
-rw-r--r--app-vim/dracula/Manifest1
-rw-r--r--app-vim/dracula/dracula-2.0.0.ebuild31
-rw-r--r--app-vim/dracula/metadata.xml11
3 files changed, 43 insertions, 0 deletions
diff --git a/app-vim/dracula/Manifest b/app-vim/dracula/Manifest
new file mode 100644
index 0000000000..eafbb74f01
--- /dev/null
+++ b/app-vim/dracula/Manifest
@@ -0,0 +1 @@
+DIST dracula-2.0.0-vim.tar.gz 12112 BLAKE2B 08fe4e138ad34f9cebbf88836d30ff2cb12e58817d192d9b2d1f40b9f9fe0f30e3686754d7f87ebba14d748e5f1bd48d10acd14b6391681054ad2adb83fc5093 SHA512 cd86681aff1bd5dfc3b6747e7468fa192776c00cd10dbf6ae99703a679f2576d7c9e1439a829c22459b7bc3248d3657213c6a8d68acd579bb90cf496fa089c71
diff --git a/app-vim/dracula/dracula-2.0.0.ebuild b/app-vim/dracula/dracula-2.0.0.ebuild
new file mode 100644
index 0000000000..1f409fcf73
--- /dev/null
+++ b/app-vim/dracula/dracula-2.0.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vim-plugin
+
+DESCRIPTION="Dark theme for Vim"
+HOMEPAGE="https://draculatheme.com/vim"
+SRC_URI="https://github.com/${PN}/vim/archive/refs/tags/v${PV}.tar.gz -> ${P}-vim.tar.gz"
+S="${WORKDIR}/vim-${PV}"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+
+VIM_PLUGIN_HELPFILES="dracula"
+
+src_prepare() {
+ default
+ rm -r .github || die
+
+ # collision with app-vim/airline-themes
+ rm -r autoload/airline || die
+
+ # avoid collision with other packages
+ cd after/syntax || die
+ for file in *.vim; do
+ mkdir "${file%.vim}" || die
+ mv "${file}" "${file%.vim}/${PN}.vim" || die
+ done
+}
diff --git a/app-vim/dracula/metadata.xml b/app-vim/dracula/metadata.xml
new file mode 100644
index 0000000000..fe9a58440f
--- /dev/null
+++ b/app-vim/dracula/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>cyber+gentoo@sysrq.in</email>
+ <name>Anna</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">dracula/vim</remote-id>
+ </upstream>
+</pkgmetadata>