aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Matous <m@matous.dev>2022-04-03 02:10:11 +0200
committerMartin Matous <m@matous.dev>2022-04-03 02:12:37 +0200
commit6bec5c2f8a78f2c79dca2400c9dc7970dab8b6ba (patch)
treef87a21e49adca0a9fb72b47c50b6124c1df7a981
parentsys-boot/limine: drop v2.85* (diff)
downloadguru-6bec5c2f.tar.gz
guru-6bec5c2f.tar.bz2
guru-6bec5c2f.zip
x11-themes/neonly-cursor: new package
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Martin Matouš <m@matous.dev>
-rw-r--r--x11-themes/neonly-cursor/Manifest1
-rw-r--r--x11-themes/neonly-cursor/metadata.xml12
-rw-r--r--x11-themes/neonly-cursor/neonly-cursor-1.0.0.ebuild24
3 files changed, 37 insertions, 0 deletions
diff --git a/x11-themes/neonly-cursor/Manifest b/x11-themes/neonly-cursor/Manifest
new file mode 100644
index 0000000000..543b3bdbdc
--- /dev/null
+++ b/x11-themes/neonly-cursor/Manifest
@@ -0,0 +1 @@
+DIST neonly-cursor-1.0.0.tar.gz 1023663 BLAKE2B d0b1df6777f1181c8523469b518318415fa5f093b32a288bdf12f6643860062d8202ec4d715a01fe2766827f5c1a504be17148bc6dca2ae6c438be53e463d686 SHA512 4178c29e80af0a7aacfb6c4026fd9a832f4c28722bb0d9e5106dd2acfe09a3fb2e126f1c2f4c5558dcd6f677b5d16782d5317809afcf2bffd3a6c00a00c25afa
diff --git a/x11-themes/neonly-cursor/metadata.xml b/x11-themes/neonly-cursor/metadata.xml
new file mode 100644
index 0000000000..6d7c34cf0a
--- /dev/null
+++ b/x11-themes/neonly-cursor/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>m@matous.dev</email>
+ <name>Martin Matouš</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/alvatip/Neonly/issues</bugs-to>
+ <remote-id type="github">alvatip/Neonly</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-themes/neonly-cursor/neonly-cursor-1.0.0.ebuild b/x11-themes/neonly-cursor/neonly-cursor-1.0.0.ebuild
new file mode 100644
index 0000000000..f323dd70f9
--- /dev/null
+++ b/x11-themes/neonly-cursor/neonly-cursor-1.0.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg
+
+MY_PV="v$(ver_cut 1-2)"
+
+DESCRIPTION="Cursor theme using a custom color palette inspired by boreal colors"
+HOMEPAGE="https://github.com/alvatip/Neonly"
+SRC_URI="https://github.com/alvatip/Neonly/releases/download/${MY_PV}/Neonly.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-3"
+
+KEYWORDS="~amd64"
+SLOT="0"
+RESTRICT="mirror"
+
+S="${WORKDIR}"
+
+src_install() {
+ insinto "/usr/share/icons/${PN}"
+ doins -r cursors index.theme
+}