aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@riseup.net>2021-04-16 21:37:53 +0200
committerMaciej Barć <xgqt@riseup.net>2021-04-16 21:38:02 +0200
commit6c8bd373b7a11ae00c4aec2a588a2e63181c4a31 (patch)
tree42bb67747f18aa47e453291849128f01054e0bb4
parentgames-emulation/np2kai: Test the ebuild and move to ~amd64 (diff)
downloadguru-6c8bd373.tar.gz
guru-6c8bd373.tar.bz2
guru-6c8bd373.zip
dev-lang/fennel: new pkg; add 0.9.1 and live
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Maciej Barć <xgqt@riseup.net>
-rw-r--r--dev-lang/fennel/Manifest1
-rw-r--r--dev-lang/fennel/fennel-0.9.1.ebuild41
-rw-r--r--dev-lang/fennel/fennel-9999.ebuild41
-rw-r--r--dev-lang/fennel/metadata.xml26
4 files changed, 109 insertions, 0 deletions
diff --git a/dev-lang/fennel/Manifest b/dev-lang/fennel/Manifest
new file mode 100644
index 000000000..fc8d0dcd8
--- /dev/null
+++ b/dev-lang/fennel/Manifest
@@ -0,0 +1 @@
+DIST fennel-0.9.1.tar.gz 203441 BLAKE2B 74f461b3e7a24cdae0c8dde590814cb9753a12ab62e797746cc8753d178007a09084037e443d8309fa11ff309a5c6bf6c2e369942ef357aa0402883cef278542 SHA512 87e7ffbef0b49499a93255f50e77f53b9be4faa6d4609d8d65e3a64470bbf07b49a55e7dd547fda4b0e5fe0f4f1e6ece18282cc89955a57ed0a50be8dc01261c
diff --git a/dev-lang/fennel/fennel-0.9.1.ebuild b/dev-lang/fennel/fennel-0.9.1.ebuild
new file mode 100644
index 000000000..d2adba074
--- /dev/null
+++ b/dev-lang/fennel/fennel-0.9.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit lua-single
+
+DESCRIPTION="Fennel is a lisp that compiles to Lua"
+HOMEPAGE="https://fennel-lang.org/"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.sr.ht/~technomancy/fennel"
+else
+ SRC_URI="https://git.sr.ht/~technomancy/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+BDEPEND="${LUA_DEPS}"
+RDEPEND="${BDEPEND}"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ lua-single_pkg_setup
+}
+
+src_compile() {
+ emake LUA_VERSION="$(lua_get_version)" PREFIX="${D}/usr"
+}
+
+src_install() {
+ emake LUA_VERSION="$(lua_get_version)" PREFIX="${D}/usr" install
+ doman "${PN}.1"
+ dodoc *.md
+}
diff --git a/dev-lang/fennel/fennel-9999.ebuild b/dev-lang/fennel/fennel-9999.ebuild
new file mode 100644
index 000000000..d2adba074
--- /dev/null
+++ b/dev-lang/fennel/fennel-9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit lua-single
+
+DESCRIPTION="Fennel is a lisp that compiles to Lua"
+HOMEPAGE="https://fennel-lang.org/"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.sr.ht/~technomancy/fennel"
+else
+ SRC_URI="https://git.sr.ht/~technomancy/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+BDEPEND="${LUA_DEPS}"
+RDEPEND="${BDEPEND}"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ lua-single_pkg_setup
+}
+
+src_compile() {
+ emake LUA_VERSION="$(lua_get_version)" PREFIX="${D}/usr"
+}
+
+src_install() {
+ emake LUA_VERSION="$(lua_get_version)" PREFIX="${D}/usr" install
+ doman "${PN}.1"
+ dodoc *.md
+}
diff --git a/dev-lang/fennel/metadata.xml b/dev-lang/fennel/metadata.xml
new file mode 100644
index 000000000..52244949b
--- /dev/null
+++ b/dev-lang/fennel/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@riseup.net</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <longdescription lang="en">
+ Fennel is a lisp that compiles to Lua. It aims to be easy to use,
+ expressive, and has almost zero overhead compared to handwritten Lua.
+
+ - Full Lua compatibility - You can use any function or library from Lua.
+ - Zero overhead - Compiled code should be just as or more efficient
+ than hand-written Lua.
+ - Compile-time macros - Ship compiled code with no runtime dependency
+ on Fennel.
+ - Embeddable - Fennel is a one-file library as well as an executable.
+ Embed it in other programs to support runtime extensibility and
+ interactive development.
+
+ At https://fennel-lang.org there's a live in-browser repl you can use without installing anything.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">bakpakin/Fennel</remote-id>
+ </upstream>
+</pkgmetadata>