aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Anderson <telans@posteo.de>2021-02-08 15:51:37 +1300
committerTheo Anderson <telans@posteo.de>2021-02-08 15:51:37 +1300
commit6e1300788ed113f1e222ae4e3e78163b78ef430d (patch)
tree5b34c35e6b037bf9741993e6f8be8f0f62aff4de
parentapp-text/OCRmyPDF: drop old (diff)
downloadguru-6e1300788ed113f1e222ae4e3e78163b78ef430d.tar.gz
guru-6e1300788ed113f1e222ae4e3e78163b78ef430d.tar.bz2
guru-6e1300788ed113f1e222ae4e3e78163b78ef430d.zip
dev-python/pykeepass: bump to 4.0.0; enable tests
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Theo Anderson <telans@posteo.de>
-rw-r--r--dev-python/pykeepass/Manifest1
-rw-r--r--dev-python/pykeepass/files/pykeepass-4.0.0-fix-tests-install.patch (renamed from dev-python/pykeepass/files/0001-setup.py-exclude-tests-directory.patch)2
-rw-r--r--dev-python/pykeepass/pykeepass-4.0.0.ebuild40
3 files changed, 42 insertions, 1 deletions
diff --git a/dev-python/pykeepass/Manifest b/dev-python/pykeepass/Manifest
index 0a6671729..b01fc9000 100644
--- a/dev-python/pykeepass/Manifest
+++ b/dev-python/pykeepass/Manifest
@@ -1,2 +1,3 @@
DIST pykeepass-3.2.0.tar.gz 68381 BLAKE2B 05b0dbf86f5211596487a026ef0de438c540e302edf1a2b57403bbcd212d99a995fe91bf770d963f47a77a05adb66817b26d73154585254f1ed1b956e40bdaf6 SHA512 8ecdf667ef03f6189d75ce5d6fe0ec49fc683ebccc94a77fe31807b43abfc77417a26058281758aee5721558c267458106bc2626cddbf9ff29225297dc4896fb
DIST pykeepass-3.2.1.tar.gz 46615 BLAKE2B fac973f9992b15d5f0bad94eb99201c6cf76e0fbf20fa2e04cc51bc6686a65c746608054afe4f0a0cfea1f534e55829d2e485def321ecf9b2dda0e729e6fc4ff SHA512 559287581741d5b3465fa722d0dc51dbbcb46776349c7a4ce2b688b8e692f188078718adcdf527723e35f30b3f68efa4625bba5db5109841b75d2590d0b67ff8
+DIST pykeepass-4.0.0.tar.gz 88720 BLAKE2B 7dcce1ded4527f32e0a602d9a7b742fabd32ee6c5e6836f0d4d217c3117177f258e974275670c9cea408e05335004996bea6a68ba12fe02ac30b0276ac7cfb54 SHA512 03483c9dc78774b2c5d4088f9995db9a9142bc69a8d4bc1824f4868175d3556434cb155c1f35a3fa0c04fca72f571af518166f59bcbe21431b7fe34a20b57cb2
diff --git a/dev-python/pykeepass/files/0001-setup.py-exclude-tests-directory.patch b/dev-python/pykeepass/files/pykeepass-4.0.0-fix-tests-install.patch
index 4f357a4d8..2b2572165 100644
--- a/dev-python/pykeepass/files/0001-setup.py-exclude-tests-directory.patch
+++ b/dev-python/pykeepass/files/pykeepass-4.0.0-fix-tests-install.patch
@@ -19,7 +19,7 @@ index 773acfc..2a8c17b 100644
@@ -11,7 +11,7 @@ setup(
author="Philipp Schmitt",
author_email="philipp@schmitt.co",
- url="https://github.com/pschmitt/pykeepass",
+ url="https://github.com/libkeepass/pykeepass",
- packages=find_packages(),
+ packages=find_packages(exclude=("tests")),
install_requires=[
diff --git a/dev-python/pykeepass/pykeepass-4.0.0.ebuild b/dev-python/pykeepass/pykeepass-4.0.0.ebuild
new file mode 100644
index 000000000..0770c7d77
--- /dev/null
+++ b/dev-python/pykeepass/pykeepass-4.0.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to interact with keepass databases (supports KDBX3 and KDBX4) "
+HOMEPAGE="https://github.com/libkeepass/pykeepass"
+SRC_URI="https://github.com/libkeepass/pykeepass/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/argon2-cffi-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/construct-2.10.54[${PYTHON_USEDEP}]
+ >=dev-python/future-0.18.2[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.3.5[${PYTHON_USEDEP}]
+ >=dev-python/pycryptodome-3.8.2[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.1[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/pykeepass-4.0.0-fix-tests-install.patch )
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+ # pycryptodomex to pycryptodome conversion
+ sed -i 's/Cryptodome/Crypto/g' pykeepass/kdbx_parsing/{common,twofish}.py || die
+}
+
+python_test() {
+ "${EPYTHON}" tests/tests.py -v || die
+}