aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2021-11-18 05:22:13 +0100
committerRonny (tastytea) Gutbrod <gentoo@tastytea.de>2021-11-19 00:56:15 +0100
commit6fd539f850738cfbbd69ef45fb4ef24ddac2bd36 (patch)
tree536d3516226a6bb8545b606f071008e91f96ce60
parentdev-libs/mtxclient: Remove old ebuild. (diff)
downloadguru-6fd539f850738cfbbd69ef45fb4ef24ddac2bd36.tar.gz
guru-6fd539f850738cfbbd69ef45fb4ef24ddac2bd36.tar.bz2
guru-6fd539f850738cfbbd69ef45fb4ef24ddac2bd36.zip
dev-cpp/qt-jdenticon: New package.
Creates reproducible avatars from hashes. Dependency for net-im/nheko. Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de>
-rw-r--r--dev-cpp/qt-jdenticon/Manifest1
-rw-r--r--dev-cpp/qt-jdenticon/metadata.xml12
-rw-r--r--dev-cpp/qt-jdenticon/qt-jdenticon-0.2.0.ebuild27
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-cpp/qt-jdenticon/Manifest b/dev-cpp/qt-jdenticon/Manifest
new file mode 100644
index 000000000..8bf046a60
--- /dev/null
+++ b/dev-cpp/qt-jdenticon/Manifest
@@ -0,0 +1 @@
+DIST qt-jdenticon-0.2.0.tar.gz 11605 BLAKE2B a75db20e5830c5e06a94628d5e6ea992ee1553bc26fd5c615b941f1a78a49389dd29791c7ca992c1bdb511c8e723034ced2e13f33e07ee73d42d2b06ad2189ff SHA512 14cd4632ee627bffd64169c2fc27ffd556e5781d151537c70431cad3e6672b23ea2ecfd4f9504db66d3bae7e0ecf14181e20c150e67b1f9166084241cde54cee
diff --git a/dev-cpp/qt-jdenticon/metadata.xml b/dev-cpp/qt-jdenticon/metadata.xml
new file mode 100644
index 000000000..cbc269df2
--- /dev/null
+++ b/dev-cpp/qt-jdenticon/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@tastytea.de</email>
+ <name>Ronny (tastytea) Gutbrod</name>
+ </maintainer>
+ <longdescription lang="de">
+ It creates highly recognizable identicons from a hash. Identicons are
+ reproducible computer generated avatars.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-cpp/qt-jdenticon/qt-jdenticon-0.2.0.ebuild b/dev-cpp/qt-jdenticon/qt-jdenticon-0.2.0.ebuild
new file mode 100644
index 000000000..f7916f42f
--- /dev/null
+++ b/dev-cpp/qt-jdenticon/qt-jdenticon-0.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qmake-utils
+
+DESCRIPTION="Qt5 / C++14 Port of Jdenticon"
+HOMEPAGE="https://github.com/Nheko-Reborn/qt-jdenticon"
+SRC_URI="https://github.com/Nheko-Reborn/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-qt/qtgui
+"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ eqmake5
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+}