aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-04-28 18:21:12 +0200
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-04-28 18:21:12 +0200
commit70202c215739ea810f46fabbbc5a185950afed13 (patch)
tree738fa03202092b7041ff2f66af050f24f50e0cc1
parenteclass/docs: more documentation fixes (diff)
downloadguru-70202c21.tar.gz
guru-70202c21.tar.bz2
guru-70202c21.zip
dev-python/pytest-isort: Plugin to check import ordering using isort
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
-rw-r--r--dev-python/pytest-isort/Manifest1
-rw-r--r--dev-python/pytest-isort/metadata.xml13
-rw-r--r--dev-python/pytest-isort/pytest-isort-0.3.1.ebuild25
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pytest-isort/Manifest b/dev-python/pytest-isort/Manifest
new file mode 100644
index 000000000..50f41acd6
--- /dev/null
+++ b/dev-python/pytest-isort/Manifest
@@ -0,0 +1 @@
+DIST pytest-isort-0.3.1.tar.gz 6429 BLAKE2B cf68cfe061be097c576c9cb7ad0a808729aa03f031128d2d1064bc960c7aa27e0d94fc18c238d95ac2074f056ecb8fb33064f6f0311756c73ce8379d1b8317f9 SHA512 2fd39108a6acacf18ce68bb537d2adeb4ff7cd8ea4c9611e5312edea5a0bc4841111ffb544318aa7b3bebe38e9f4744f07a45b2ebcbf872f79003b249ee115ca
diff --git a/dev-python/pytest-isort/metadata.xml b/dev-python/pytest-isort/metadata.xml
new file mode 100644
index 000000000..3add1c90d
--- /dev/null
+++ b/dev-python/pytest-isort/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrewammerlaan@riseup.net</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">moccu/pytest-isort</remote-id>
+ <remote-id type="pypi">pytest-isort</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-isort/pytest-isort-0.3.1.ebuild b/dev-python/pytest-isort/pytest-isort-0.3.1.ebuild
new file mode 100644
index 000000000..0092d516f
--- /dev/null
+++ b/dev-python/pytest-isort/pytest-isort-0.3.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Plugin to check import ordering using isort"
+HOMEPAGE="https://github.com/moccu/pytest-isort"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+distutils_enable_tests pytest
+
+RDEPEND="
+ >=dev-python/pytest-3.5[${PYTHON_USEDEP}]
+ >=dev-python/isort-4.0[${PYTHON_USEDEP}]
+"