aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-08-28 17:14:10 +0200
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-08-28 17:26:10 +0200
commit72f44d1de88005a990707710c0b4009d7f59217b (patch)
treee4f08cc5f3a7345134a813a87a933864808dfa62
parentdev-python/factory_boy: version bump 3.0.1 (diff)
downloadguru-72f44d1d.tar.gz
guru-72f44d1d.tar.bz2
guru-72f44d1d.zip
dev-python/pytest-randomly: version bump 3.4.1
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
-rw-r--r--dev-python/pytest-randomly/Manifest2
-rw-r--r--dev-python/pytest-randomly/pytest-randomly-3.3.1-r1.ebuild55
-rw-r--r--dev-python/pytest-randomly/pytest-randomly-3.4.1.ebuild (renamed from dev-python/pytest-randomly/pytest-randomly-3.3.1-r2.ebuild)17
3 files changed, 8 insertions, 66 deletions
diff --git a/dev-python/pytest-randomly/Manifest b/dev-python/pytest-randomly/Manifest
index 8c9c3779f1..03807ea58f 100644
--- a/dev-python/pytest-randomly/Manifest
+++ b/dev-python/pytest-randomly/Manifest
@@ -1 +1 @@
-DIST pytest-randomly-3.3.1.tar.gz 31404 BLAKE2B 28a77b2c7043ece3305e1971957b23a7188bf1889483c9747f2fe925bfe72e872d8e8f4a52e3dc372f9934dd81c3e88bbc9be52bc574605faed80e57fa852d3c SHA512 242274b1e9fcbb03278766ddd46e8d3dca2374f09db0d111feb0bebdabab4d46ecc63d17f17e692cf4adf662dd3b450f87fe14e248488acb4d3c629567d54458
+DIST pytest-randomly-3.4.1.tar.gz 32468 BLAKE2B 6aaddfca7434a8b7060aa32d69f84ff5e03e5f43bcfdfacc56f792ba6e1a1f5f49dca641a0100ed4ddf0f6947017aa354ab4fcc2ad837bb5b072aab8142f07b6 SHA512 3f1006ce67478221fb57369f6b0dcbb41bdd38798059112cff2e113ab101a4d07e72e5f302ffdf6159cc8600999f691f0f665fda4c0fcf58bba3c4fe5a12c039
diff --git a/dev-python/pytest-randomly/pytest-randomly-3.3.1-r1.ebuild b/dev-python/pytest-randomly/pytest-randomly-3.3.1-r1.ebuild
deleted file mode 100644
index 89096d8747..0000000000
--- a/dev-python/pytest-randomly/pytest-randomly-3.3.1-r1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{6,7,8} )
-
-inherit distutils-r1
-
-DESCRIPTION="Pytest plugin to randomly order tests and control random.seed"
-HOMEPAGE="
- https://pypi.python.org/pypi/pytest-randomly
- https://github.com/pytest-dev/pytest-randomly
-"
-SRC_URI="https://github.com/pytest-dev/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-# many failures, both with pytest-5 and 4
-RESTRICT="test"
-
-RDEPEND="
- dev-python/docutils[${PYTHON_USEDEP}]
- dev-python/factory_boy[${PYTHON_USEDEP}]
- dev-python/faker[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
-
- $(python_gen_cond_dep 'dev-python/importlib_metadata[${PYTHON_USEDEP}]' python3_6 python3_7)
-"
-#not really needed
-# dev-python/isort[${PYTHON_USEDEP}]
-# $(python_gen_cond_dep 'dev-python/black[${PYTHON_USEDEP}]' python3_8)
-# dev-python/secretstorage[${PYTHON_USEDEP}]
-# dev-python/twine[${PYTHON_USEDEP}]
-
-DEPEND="
- test? (
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )
-"
-#not really needed
-# $(python_gen_cond_dep 'dev-python/check-manifest[${PYTHON_USEDEP}]' python3_8)
-# dev-python/multilint[${PYTHON_USEDEP}]
-
-distutils_enable_tests pytest
-
-python_test() {
- distutils_install_for_testing
- pytest -vv || die "Testsuite failed under ${EPYTHON}"
-}
diff --git a/dev-python/pytest-randomly/pytest-randomly-3.3.1-r2.ebuild b/dev-python/pytest-randomly/pytest-randomly-3.4.1.ebuild
index 1e902ac9b0..ba4a52f47b 100644
--- a/dev-python/pytest-randomly/pytest-randomly-3.3.1-r2.ebuild
+++ b/dev-python/pytest-randomly/pytest-randomly-3.4.1.ebuild
@@ -4,7 +4,7 @@
EAPI="7"
DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{7,8} )
inherit distutils-r1
@@ -19,6 +19,11 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+# No clue what's going on here
+# AssertionError: assert ['collecting ... collected 4 items',\n '',\n 'test_one.py::test_d PASSED',\n 'test_one.py::test_c PASSED'] ==
+# ['test_one.py::test_d PASSED',\n 'test_one.py::test_c PASSED',\n 'test_one.py::test_a PASSED',\n 'test_one.py::test_b PASSED']
+RESTRICT="test"
+
RDEPEND="
dev-python/docutils[${PYTHON_USEDEP}]
dev-python/factory_boy[${PYTHON_USEDEP}]
@@ -27,22 +32,14 @@ RDEPEND="
dev-python/pygments[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/importlib_metadata[${PYTHON_USEDEP}]' python3_6 python3_7)
+ $(python_gen_cond_dep 'dev-python/importlib_metadata[${PYTHON_USEDEP}]' python3_7)
"
-#not really needed
-# dev-python/isort[${PYTHON_USEDEP}]
-# $(python_gen_cond_dep 'dev-python/black[${PYTHON_USEDEP}]' python3_8)
-# dev-python/secretstorage[${PYTHON_USEDEP}]
-# dev-python/twine[${PYTHON_USEDEP}]
DEPEND="
test? (
dev-python/pytest-xdist[${PYTHON_USEDEP}]
)
"
-#not really needed
-# $(python_gen_cond_dep 'dev-python/check-manifest[${PYTHON_USEDEP}]' python3_8)
-# dev-python/multilint[${PYTHON_USEDEP}]
distutils_enable_tests pytest