aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-04-09 00:20:44 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-04-15 22:34:18 +0200
commit74e4456110f6313a5d6ae0b1adb7512986ee2493 (patch)
tree69329a44ae613fae13fc74c18d09081dbe604e94
parentdev-python/asyncssh: deselect network tests (diff)
downloadguru-74e4456110f6313a5d6ae0b1adb7512986ee2493.tar.gz
guru-74e4456110f6313a5d6ae0b1adb7512986ee2493.tar.bz2
guru-74e4456110f6313a5d6ae0b1adb7512986ee2493.zip
sys-cluster/heat: add missing dep, remove hacking test
Bug: https://bugs.gentoo.org/836793 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--sys-cluster/heat/heat-18.0.0.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/sys-cluster/heat/heat-18.0.0.ebuild b/sys-cluster/heat/heat-18.0.0.ebuild
index cc37073c7..c3567fa91 100644
--- a/sys-cluster/heat/heat-18.0.0.ebuild
+++ b/sys-cluster/heat/heat-18.0.0.ebuild
@@ -25,6 +25,7 @@ IUSE="+mysql +memcached postgres sqlite"
RDEPEND="
>=dev-python/pbr-3.1.1[${PYTHON_USEDEP}]
>=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ >=dev-python/ddt-1.4.1[${PYTHON_USEDEP}]
>=dev-python/croniter-0.3.4[${PYTHON_USEDEP}]
>=dev-python/cryptography-2.5[${PYTHON_USEDEP}]
>=dev-python/debtcollector-1.19.0[${PYTHON_USEDEP}]
@@ -126,13 +127,14 @@ REQUIRED_USE="
distutils_enable_tests pytest
python_prepare_all() {
+ rm -r heat/tests/test_hacking.py || die
sed -i '/^hacking/d' test-requirements.txt || die
distutils-r1_python_prepare_all
}
python_compile_all() {
- oslo-config-generator --config-file=config-generator.conf
- oslopolicy-sample-generator --config-file etc/heat/heat-policy-generator.conf
+ oslo-config-generator --config-file=config-generator.conf || die
+ oslopolicy-sample-generator --config-file etc/heat/heat-policy-generator.conf || die
}
python_install_all() {