aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Anderson <telans@posteo.de>2021-01-09 10:14:33 +1300
committerTheo Anderson <telans@posteo.de>2021-01-09 10:14:33 +1300
commit7840ff0da3502a04b1d10beacd3e28a70cf95c1f (patch)
treebd1f46c055dcc071d73f157a0cb16071632f958c
parentnet-p2p/monero: bump to 0.17.1.9 (diff)
downloadguru-7840ff0d.tar.gz
guru-7840ff0d.tar.bz2
guru-7840ff0d.zip
net-p2p/monero: drop old (security)
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Theo Anderson <telans@posteo.de>
-rw-r--r--net-p2p/monero/Manifest2
-rw-r--r--net-p2p/monero/monero-0.17.1.7.ebuild117
-rw-r--r--net-p2p/monero/monero-0.17.1.8.ebuild117
3 files changed, 0 insertions, 236 deletions
diff --git a/net-p2p/monero/Manifest b/net-p2p/monero/Manifest
index 745879ca9..841b64b94 100644
--- a/net-p2p/monero/Manifest
+++ b/net-p2p/monero/Manifest
@@ -1,3 +1 @@
-DIST monero-0.17.1.7.tar.gz 10598750 BLAKE2B 03a80f3c38bc1b643d8d9ddba4ee1de59e0f4c6d66cfc5dcb700d19659a5cb66add4fcf1320c1ed2b7dfa15fdfe9548eb758e67661832f9da7bd0e173b5a0ae1 SHA512 b049a738eb5752a620fc19dfafd5e2996d3f33d89737774264a5ef69b7fcfcd9fe852b89e35187486f48fdc8bb73c2010a1917d1ed7fcb4f1f87b18a6bb4c2d5
-DIST monero-0.17.1.8.tar.gz 10603308 BLAKE2B f515c90fac83bcf866cc042b34be38d366c7e48a70db76b2a900e9922ca460db7604aa15f4f03b2e5301647a75f40ad0f04c2dadd416a079da2f77be46d584a2 SHA512 e9cde3c77d71dd468237e823f647551fb3fef89f7132ebe2be1ac10545dd926f2d2b07794af4664d82e4d19b8b3b8b69fa090ed64ccab7ca63ffae3c0559eec0
DIST monero-0.17.1.9.tar.gz 10607015 BLAKE2B 2746fa1d8feafead39f10d1c8800ecd82e4049930b7acae42e946474558114422703e8cb37f1bd3833e57ec9987ccdff2fd530a632693cab206420153f8e6ab4 SHA512 b529d1c691584a5bf1e1fa342909dbb296ef57b0b7d018d95dd40ee418257a15f8f94ec74f780762f28f57f5db4a953becce97558af407f89828d55da88e61d8
diff --git a/net-p2p/monero/monero-0.17.1.7.ebuild b/net-p2p/monero/monero-0.17.1.7.ebuild
deleted file mode 100644
index fb62cb795..000000000
--- a/net-p2p/monero/monero-0.17.1.7.ebuild
+++ /dev/null
@@ -1,117 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake systemd
-
-DESCRIPTION="The secure, private, untraceable cryptocurrency"
-HOMEPAGE="https://github.com/monero-project/monero"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/monero-project/monero.git"
-else
- SRC_URI="https://github.com/monero-project/monero/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm64 ~x86"
-fi
-
-LICENSE="BSD MIT"
-SLOT="0"
-IUSE="+daemon libressl readline +tools +wallet-cli +wallet-rpc"
-REQUIRED_USE="|| ( daemon tools wallet-cli wallet-rpc )"
-RESTRICT="test"
-
-DEPEND="
- acct-group/monero
- acct-user/monero
- dev-libs/boost:=[nls,threads]
- dev-libs/libsodium:=
- dev-libs/randomx
- dev-libs/rapidjson
- dev-libs/supercop
- net-dns/unbound:=[threads]
- net-libs/czmq:=
- net-libs/miniupnpc
- !libressl? ( dev-libs/openssl:= )
- libressl? ( dev-libs/libressl:= )
- readline? ( sys-libs/readline:0= )
-"
-RDEPEND="${DEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.17.1.7-linkjobs.patch"
- "${FILESDIR}/${PN}-0.17.1.7-unbundle-dependencies.patch"
-)
-
-src_configure() {
- local mycmakeargs=(
- # TODO: Update CMake to install built libraries (help wanted)
- -DBUILD_SHARED_LIBS=OFF
- -DMANUAL_SUBMODULES=ON
- -DMONERO_PARALLEL_LINK_JOBS=1
- -DUSE_DEVICE_TREZOR=OFF
- )
-
- cmake_src_configure
-}
-
-src_compile() {
- local targets=()
- use daemon && targets+=(daemon)
- use tools && targets+=(blockchain_{ancestry,blackball,db,depth,export,import,prune,prune_known_spent_data,stats,usage})
- use wallet-cli && targets+=(simplewallet)
- use wallet-rpc && targets+=(wallet_rpc_server)
- cmake_build ${targets[@]}
-}
-
-src_install() {
- einstalldocs
-
- # Install all binaries.
- find "${BUILD_DIR}/bin/" -type f -executable -print0 |
- while IFS= read -r -d '' line; do
- dobin "$line"
- done
-
- if use daemon; then
- dodoc utils/conf/monerod.conf
-
- # data-dir
- keepdir /var/lib/monero
- fowners monero:monero /var/lib/monero
- fperms 0755 /var/lib/monero
-
- # log-file dir
- keepdir /var/log/monero
- fowners monero:monero /var/log/monero
- fperms 0755 /var/log/monero
-
- # /etc/monero/monerod.conf
- insinto /etc/monero
- doins "${FILESDIR}/monerod.conf"
-
- # OpenRC
- newconfd "${FILESDIR}/monerod.confd" monerod
- newinitd "${FILESDIR}/monerod.initd" monerod
-
- # systemd
- systemd_dounit "${FILESDIR}/monerod.service"
- fi
-}
-
-pkg_postinst() {
- if use daemon; then
- elog "Start the Monero P2P daemon as a system service with"
- elog "'rc-service monerod start'. Enable it at startup with"
- elog "'rc-update add monerod default'."
- elog
- elog "Run monerod status as any user to get sync status and other stats."
- elog
- elog "The Monero blockchain can take up a lot of space (80 GiB) and is stored"
- elog "in /var/lib/monero by default. You may want to enable pruning by adding"
- elog "'prune-blockchain=1' to /etc/monero/monerod.conf to prune the blockchain"
- elog "or move the data directory to another disk."
- fi
-}
diff --git a/net-p2p/monero/monero-0.17.1.8.ebuild b/net-p2p/monero/monero-0.17.1.8.ebuild
deleted file mode 100644
index fb62cb795..000000000
--- a/net-p2p/monero/monero-0.17.1.8.ebuild
+++ /dev/null
@@ -1,117 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake systemd
-
-DESCRIPTION="The secure, private, untraceable cryptocurrency"
-HOMEPAGE="https://github.com/monero-project/monero"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/monero-project/monero.git"
-else
- SRC_URI="https://github.com/monero-project/monero/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm64 ~x86"
-fi
-
-LICENSE="BSD MIT"
-SLOT="0"
-IUSE="+daemon libressl readline +tools +wallet-cli +wallet-rpc"
-REQUIRED_USE="|| ( daemon tools wallet-cli wallet-rpc )"
-RESTRICT="test"
-
-DEPEND="
- acct-group/monero
- acct-user/monero
- dev-libs/boost:=[nls,threads]
- dev-libs/libsodium:=
- dev-libs/randomx
- dev-libs/rapidjson
- dev-libs/supercop
- net-dns/unbound:=[threads]
- net-libs/czmq:=
- net-libs/miniupnpc
- !libressl? ( dev-libs/openssl:= )
- libressl? ( dev-libs/libressl:= )
- readline? ( sys-libs/readline:0= )
-"
-RDEPEND="${DEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.17.1.7-linkjobs.patch"
- "${FILESDIR}/${PN}-0.17.1.7-unbundle-dependencies.patch"
-)
-
-src_configure() {
- local mycmakeargs=(
- # TODO: Update CMake to install built libraries (help wanted)
- -DBUILD_SHARED_LIBS=OFF
- -DMANUAL_SUBMODULES=ON
- -DMONERO_PARALLEL_LINK_JOBS=1
- -DUSE_DEVICE_TREZOR=OFF
- )
-
- cmake_src_configure
-}
-
-src_compile() {
- local targets=()
- use daemon && targets+=(daemon)
- use tools && targets+=(blockchain_{ancestry,blackball,db,depth,export,import,prune,prune_known_spent_data,stats,usage})
- use wallet-cli && targets+=(simplewallet)
- use wallet-rpc && targets+=(wallet_rpc_server)
- cmake_build ${targets[@]}
-}
-
-src_install() {
- einstalldocs
-
- # Install all binaries.
- find "${BUILD_DIR}/bin/" -type f -executable -print0 |
- while IFS= read -r -d '' line; do
- dobin "$line"
- done
-
- if use daemon; then
- dodoc utils/conf/monerod.conf
-
- # data-dir
- keepdir /var/lib/monero
- fowners monero:monero /var/lib/monero
- fperms 0755 /var/lib/monero
-
- # log-file dir
- keepdir /var/log/monero
- fowners monero:monero /var/log/monero
- fperms 0755 /var/log/monero
-
- # /etc/monero/monerod.conf
- insinto /etc/monero
- doins "${FILESDIR}/monerod.conf"
-
- # OpenRC
- newconfd "${FILESDIR}/monerod.confd" monerod
- newinitd "${FILESDIR}/monerod.initd" monerod
-
- # systemd
- systemd_dounit "${FILESDIR}/monerod.service"
- fi
-}
-
-pkg_postinst() {
- if use daemon; then
- elog "Start the Monero P2P daemon as a system service with"
- elog "'rc-service monerod start'. Enable it at startup with"
- elog "'rc-update add monerod default'."
- elog
- elog "Run monerod status as any user to get sync status and other stats."
- elog
- elog "The Monero blockchain can take up a lot of space (80 GiB) and is stored"
- elog "in /var/lib/monero by default. You may want to enable pruning by adding"
- elog "'prune-blockchain=1' to /etc/monero/monerod.conf to prune the blockchain"
- elog "or move the data directory to another disk."
- fi
-}