aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2021-01-28 02:41:08 +0100
committerRonny (tastytea) Gutbrod <gentoo@tastytea.de>2021-01-28 02:41:08 +0100
commit78881a38c5cd8a75345bf2da25e75c7a4f3dc70d (patch)
tree4669195f8b7ec48ccf3b51d6fffa2435faa63d0d
parentdev-libs/mtxclient: Delete old ebuilds. (diff)
downloadguru-78881a38.tar.gz
guru-78881a38.tar.bz2
guru-78881a38.zip
net-im/nheko: Version bump 0.8.1.
Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de>
-rw-r--r--net-im/nheko/Manifest1
-rw-r--r--net-im/nheko/nheko-0.8.1.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/net-im/nheko/Manifest b/net-im/nheko/Manifest
index c30dc70aa4..5d5d6e00c9 100644
--- a/net-im/nheko/Manifest
+++ b/net-im/nheko/Manifest
@@ -1,2 +1,3 @@
DIST nheko-0.7.2.tar.gz 899562 BLAKE2B 39a21c5a164cdc1090479422607297e48ca0e1d5455e3fabd4cf4e2af6ee8527409fbde58b0320ae0938757f055929ca5188e5b4bb9be3d1a2832d66914588a6 SHA512 8f253bdac22a2d3412fcb18671145d9601d8609dbc79358412e81a17a9677a1cb44b6fc4d029f4d850818cb3fe3531adc869a7e54273e7bb17d0aa7ef85dce17
DIST nheko-0.8.0.tar.gz 1150754 BLAKE2B ef932f824a2e519514836aa1362504b11c4c9f511e8e66889008891cf5ac008442629afc56deb221dfaebda42c91c9c145f5e489733fee95838e100b4d4c5b77 SHA512 c427904bc846956aeda57ec6bc1bcf25962caa99f47da669c006d5adeb10b8b14c75aa98d9879fa91b558af8d0e9b475f52c60a1a3ee34b2cd5780f84130bcdb
+DIST nheko-0.8.1.tar.gz 1176445 BLAKE2B 5ef1523b23b1512d56cd6109f05ec3f710629a561ddf8e766d8f3f3a2d3bdd65d6a83da381f3e53bfbd1ee470243dae8ff488880973dadc166cc82e52d03abbe SHA512 180c876121338ea6d45e85d11a3cfd1f988a084a650becacfa5a9cbb4a556a0f47625194e3d9870bb6692b15d16c5ac75999e241f08a2828ec471b3d64c1eb62
diff --git a/net-im/nheko/nheko-0.8.1.ebuild b/net-im/nheko/nheko-0.8.1.ebuild
new file mode 100644
index 0000000000..a017628ce0
--- /dev/null
+++ b/net-im/nheko/nheko-0.8.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake xdg
+
+DESCRIPTION="Desktop client for Matrix using Qt and C++14"
+HOMEPAGE="https://github.com/Nheko-Reborn/nheko"
+SRC_URI="https://github.com/Nheko-Reborn/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtmultimedia:5[gstreamer,qml]
+ dev-qt/qtquickcontrols2:5
+ dev-qt/qtgraphicaleffects:5
+ dev-qt/qtsvg:5
+ dev-qt/qtconcurrent:5
+ app-text/cmark
+ dev-libs/tweeny
+ dev-db/lmdb++
+ >=dev-libs/mtxclient-0.4.1
+ dev-cpp/nlohmann_json
+ dev-libs/qtkeychain
+"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/spdlog
+"
+BDEPEND="dev-qt/linguist-tools:5"
+
+src_prepare() {
+ cmake_src_prepare
+ xdg_src_prepare
+}
+
+# # Preparation for when gstreamer >= 1.18 lands in ::gentoo.
+# MY_GSTREAMER_V="1.18"
+#
+# voip? (
+# >=media-libs/gstreamer-${MY_GSTREAMER_V}
+# >=media-plugins/gst-plugins-meta-${MY_GSTREAMER_V}[opus,vpx]
+# >=media-libs/gst-plugins-base-${MY_GSTREAMER_V}[opengl]
+# >=media-libs/gst-plugins-good-${MY_GSTREAMER_V}
+# >=media-libs/gst-plugins-bad-${MY_GSTREAMER_V}
+# >=media-plugins/gst-plugins-dtls-${MY_GSTREAMER_V}
+# >=media-plugins/gst-plugins-srtp-${MY_GSTREAMER_V}
+# >=media-plugins/gst-plugins-webrtc-${MY_GSTREAMER_V}
+# net-libs/libnice
+# )