aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRandall T. Vasquez <ran.dall@icloud.com>2022-05-22 07:40:03 -0700
committerRandall T. Vasquez <ran.dall@icloud.com>2022-05-22 07:40:03 -0700
commit78a3d626d46d831df759e6a084408795a0bf676b (patch)
tree03a3f01092c864cd92052e4e0edf52925a78eb0d
parentgames-emulation/citra: add system-libfmt flag (diff)
downloadguru-78a3d626.tar.gz
guru-78a3d626.tar.bz2
guru-78a3d626.zip
dev-util/shfmt: tidy shfmt ebuilds
This commits fixes the manifest of the shfmt 3.5.0 ebuild; along with some other general tidying of all the shfmt ebuilds. Signed-off-by: Randall T. Vasquez <ran.dall@icloud.com>
-rw-r--r--dev-util/shfmt/Manifest2
-rw-r--r--dev-util/shfmt/shfmt-3.5.0.ebuild6
-rw-r--r--dev-util/shfmt/shfmt-9999.ebuild5
3 files changed, 6 insertions, 7 deletions
diff --git a/dev-util/shfmt/Manifest b/dev-util/shfmt/Manifest
index 15f0d5e01..2a1bf631e 100644
--- a/dev-util/shfmt/Manifest
+++ b/dev-util/shfmt/Manifest
@@ -1,2 +1,2 @@
DIST shfmt-3.5.0-deps.tar.xz 3121980 BLAKE2B 411e7df230864d1692899b89c4b5e25f54582752a10bde30a8a5e1ae03da3b325353d9bab71b46795f3d285747fbbcc63dd367ecddc8055d5df45013c5f491ae SHA512 562fc2a58c0c115d132c9107c569f5139d7e1f817c91077b80151d0043601c328b083ce8261301689ce72deecabe3957bc11e4dc4388024234a2791c9f118743
-DIST shfmt-3.5.0.tar.gz 222314 BLAKE2B 733785dbeb4af946f316aae1c9bf917c0d70598e3b19b993f592d35bbce53ef8ab613935ebc5ecbfb11677b722e4ca12175b85e30be2467abed381d30b6c3159 SHA512 8a3225a39a415d4926e44f214e8de6d25fedf5a0fe6b09743cc43e1c849094a3d8a34f327d00bffaaf93e4552f7ea03b681d3bb97f59727ab36ac66bafb6d4e7
+DIST shfmt-3.5.0.tar.gz 222262 BLAKE2B a54c91afd1da39084637aba43dc9e3af82c2c57dabdd3e24cd80bbfc5fed9632da0e98b5a65169dc439216218a4664afcc8dc77cd409f15a35cd0b505d39dd39 SHA512 9071a015369088dbba8eb7221305893095ebeaa72124e1ca964b7b1e6f34dedc9d11f2daa2f679d24637b04925cbf58427a24cc4885d8e918cb81844e71d3c6b
diff --git a/dev-util/shfmt/shfmt-3.5.0.ebuild b/dev-util/shfmt/shfmt-3.5.0.ebuild
index 069e7e3d8..dbf998adf 100644
--- a/dev-util/shfmt/shfmt-3.5.0.ebuild
+++ b/dev-util/shfmt/shfmt-3.5.0.ebuild
@@ -3,6 +3,8 @@
EAPI=8
+inherit go-module
+
DESCRIPTION="Shell script formatter"
HOMEPAGE="https://github.com/mvdan/sh"
if [[ ${PV} == *9999 ]]; then
@@ -10,12 +12,11 @@ if [[ ${PV} == *9999 ]]; then
EGIT_REPO_URI="https://github.com/mvdan/sh.git"
RESTRICT="fetch mirror test"
else
- inherit go-module
SRC_URI="https://github.com/mvdan/sh/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
SRC_URI+=" https://github.com/ran-dall/portage-deps/raw/master/${P}-deps.tar.xz"
KEYWORDS="~amd64 ~arm64 ~x86"
RESTRICT="mirror test"
- S="${WORKDIR}/${PN/fmt}-${PV}"
+ S="${WORKDIR}/${PN//fmt}-${PV}"
fi
LICENSE="MIT"
@@ -35,7 +36,6 @@ src_unpack() {
ego get
popd || die "location reset from module building failed"
else
- mv mvdan-sh-* || die "correct placement of directory failed"
go-module_src_unpack
fi
default
diff --git a/dev-util/shfmt/shfmt-9999.ebuild b/dev-util/shfmt/shfmt-9999.ebuild
index d9c9cc2c4..dbf998adf 100644
--- a/dev-util/shfmt/shfmt-9999.ebuild
+++ b/dev-util/shfmt/shfmt-9999.ebuild
@@ -16,7 +16,7 @@ else
SRC_URI+=" https://github.com/ran-dall/portage-deps/raw/master/${P}-deps.tar.xz"
KEYWORDS="~amd64 ~arm64 ~x86"
RESTRICT="mirror test"
- S="${WORKDIR}/${PN/fmt}-${PV}"
+ S="${WORKDIR}/${PN//fmt}-${PV}"
fi
LICENSE="MIT"
@@ -29,7 +29,6 @@ BDEPENDS="
"
src_unpack() {
- default
if [[ ${PV} == *9999 ]]; then
git-r3_fetch
git-r3_checkout
@@ -37,9 +36,9 @@ src_unpack() {
ego get
popd || die "location reset from module building failed"
else
- mv mvdan-sh-* || die "correct placement of directory failed"
go-module_src_unpack
fi
+ default
}
src_compile() {