aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-09-27 14:26:56 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-09-27 18:47:30 +0200
commit7a2d9bf67a3049d5c2e065683a42f36910e36936 (patch)
treee67748fe696dd9b94d067093a053de9aea9440b7
parentapp-admin/customrescuecd-x86_64: drop old version (diff)
downloadguru-7a2d9bf6.tar.gz
guru-7a2d9bf6.tar.bz2
guru-7a2d9bf6.zip
dev-python/oslo-concurrency: new version
Closes: https://bugs.gentoo.org/798702 Closes: https://bugs.gentoo.org/798705 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--dev-python/oslo-concurrency/Manifest2
-rw-r--r--dev-python/oslo-concurrency/oslo-concurrency-4.4.0.ebuild30
-rw-r--r--dev-python/oslo-concurrency/oslo-concurrency-4.4.1.ebuild41
3 files changed, 42 insertions, 31 deletions
diff --git a/dev-python/oslo-concurrency/Manifest b/dev-python/oslo-concurrency/Manifest
index f0ddbb735..6f2a74b2b 100644
--- a/dev-python/oslo-concurrency/Manifest
+++ b/dev-python/oslo-concurrency/Manifest
@@ -1 +1 @@
-DIST oslo.concurrency-4.4.0.tar.gz 58812 BLAKE2B 5e353ebfd3073e971e5ad37790560cf1014ebe7683870c49367a888becd665f41f0108cd99c338453cd5ef5c525345672a861f9075bcf6ec9b13ce7b51a138b2 SHA512 a1f2e25be7dd8136e20c8047e4b0e21c51b8be680fe986a6dfe4ff9f2343fbf9db0b533304b7e32dc7db93631f60139441699acfcbd5f7c01ccd63412b452c54
+DIST oslo.concurrency-4.4.1.tar.gz 58399 BLAKE2B ea28cdd53ae124fe458c0d901b305d99b7a5b5525835e6a04ca856177876fa6c6a1eff74842dcf260c78c205d95f353cd1b70f0cb6205e7bec841bae2d6ecd0d SHA512 1b7e6a2cb2e3ee0710f652489522c7a9e47a5292c46041f21a2ffe4c61a6bbae48b43e93507465013704b89778deec860da06fec32b4d3778e05cade9a6d39a1
diff --git a/dev-python/oslo-concurrency/oslo-concurrency-4.4.0.ebuild b/dev-python/oslo-concurrency/oslo-concurrency-4.4.0.ebuild
deleted file mode 100644
index acde72660..000000000
--- a/dev-python/oslo-concurrency/oslo-concurrency-4.4.0.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_8 )
-DISTUTILS_USE_SETUPTOOLS=bdepend
-
-inherit distutils-r1
-
-DESCRIPTION="library for running multi-thread, multi-process applications"
-HOMEPAGE="https://pypi.org/project/oslo.concurrency/"
-SRC_URI="mirror://pypi/${PN:0:1}/oslo.concurrency/oslo.concurrency-${PV}.tar.gz"
-S="${WORKDIR}/oslo.concurrency-${PV}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-IUSE=""
-RESTRICT=""
-
-CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
- !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
-DEPEND="${CDEPEND}"
-RDEPEND="
- ${CDEPEND}
- >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
- >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
- >=dev-python/fasteners-0.7.0[${PYTHON_USEDEP}]
-"
diff --git a/dev-python/oslo-concurrency/oslo-concurrency-4.4.1.ebuild b/dev-python/oslo-concurrency/oslo-concurrency-4.4.1.ebuild
new file mode 100644
index 000000000..df8ddada5
--- /dev/null
+++ b/dev-python/oslo-concurrency/oslo-concurrency-4.4.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=bdepend
+PYTHON_COMPAT=( python3_8 )
+
+inherit distutils-r1
+
+DESCRIPTION="library for running multi-thread, multi-process applications"
+HOMEPAGE="
+ https://pypi.org/project/oslo.concurrency
+ https://opendev.org/openstack/oslo.concurrency
+"
+SRC_URI="mirror://pypi/${PN:0:1}/oslo.concurrency/oslo.concurrency-${PV}.tar.gz"
+S="${WORKDIR}/oslo.concurrency-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/fasteners-0.7.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ >=dev-python/hacking-3.0.1[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.19.0[${PYTHON_USEDEP}]
+ >=dev-python/stestr-2.0.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest