aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2023-07-20 17:16:23 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2023-07-20 17:16:29 +0500
commit7a7c9ba5fef43f279cd5336ce6283315c1c8d0e4 (patch)
tree7eceda6bce6f418b9a2fb974aca986b34db15b8f
parentgui-apps/eww: fix getting crate dependencies (diff)
downloadguru-7a7c9ba5.tar.gz
guru-7a7c9ba5.tar.bz2
guru-7a7c9ba5.zip
gui-apps/hyprland-plugins: drop 0.25.0
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
-rw-r--r--gui-apps/hyprland-plugins/Manifest2
-rw-r--r--gui-apps/hyprland-plugins/hyprland-plugins-0.25.0.ebuild101
2 files changed, 0 insertions, 103 deletions
diff --git a/gui-apps/hyprland-plugins/Manifest b/gui-apps/hyprland-plugins/Manifest
index 4da845972..35328abd7 100644
--- a/gui-apps/hyprland-plugins/Manifest
+++ b/gui-apps/hyprland-plugins/Manifest
@@ -1,4 +1,2 @@
-DIST hyprland-plugins-0.25.0-split-monitor-workspaces.gh.tar.gz 4498 BLAKE2B 127081c953ce818b80b5865ec48fbf35584f3f5f2945c168e1ecf150dda5f71fdac499c236a5baa34502e0ab69e3fe0fc652d0bfd8c14aaedb74ecb03792b9ba SHA512 47e1dc0a9bcb014a6c7113405ddbc87a5e5f267d65e82ea9f557c1be156cd7e269fdf80406697b295e0f66f53e0d4ccc5a768910f201d6a459f68a8ad7708a93
-DIST hyprland-plugins-0.25.0.gh.tar.gz 12209 BLAKE2B c5f74cbe13e99f71a24a272a015df70f20ae62f9e552d35914ccff37474b564a28ff81e60584caf186d111e1e3a0716e7ba03b3e201823616167708ef0aa2a0f SHA512 875c7cdb2552d5c8e68a6705f7d82173fa6f3e7637b049125d88e6b4a130f330c66b49bbb2685d302345d101fba6f23d873e7511b2fad510d1a9286c127fbaf7
DIST hyprland-plugins-0.26.0-split-monitor-workspaces.gh.tar.gz 4498 BLAKE2B 127081c953ce818b80b5865ec48fbf35584f3f5f2945c168e1ecf150dda5f71fdac499c236a5baa34502e0ab69e3fe0fc652d0bfd8c14aaedb74ecb03792b9ba SHA512 47e1dc0a9bcb014a6c7113405ddbc87a5e5f267d65e82ea9f557c1be156cd7e269fdf80406697b295e0f66f53e0d4ccc5a768910f201d6a459f68a8ad7708a93
DIST hyprland-plugins-0.26.0.gh.tar.gz 12209 BLAKE2B c5f74cbe13e99f71a24a272a015df70f20ae62f9e552d35914ccff37474b564a28ff81e60584caf186d111e1e3a0716e7ba03b3e201823616167708ef0aa2a0f SHA512 875c7cdb2552d5c8e68a6705f7d82173fa6f3e7637b049125d88e6b4a130f330c66b49bbb2685d302345d101fba6f23d873e7511b2fad510d1a9286c127fbaf7
diff --git a/gui-apps/hyprland-plugins/hyprland-plugins-0.25.0.ebuild b/gui-apps/hyprland-plugins/hyprland-plugins-0.25.0.ebuild
deleted file mode 100644
index 7e28b83d1..000000000
--- a/gui-apps/hyprland-plugins/hyprland-plugins-0.25.0.ebuild
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit meson
-
-COMMIT=1228eb57f9debd35811f0ade43bef5eaa09aab42
-SPLITCOMMIT=44785cee3fc0b2aa34a92882df31568bea3af8f0
-DESCRIPTION="A blazing fast wayland wallpaper utility"
-HOMEPAGE="https://github.com/hyprwm/hyprland-plugins"
-SRC_URI="https://github.com/hyprwm/${PN}/archive/${COMMIT}.tar.gz -> ${P}.gh.tar.gz
- https://github.com/Duckonaut/split-monitor-workspaces/archive/${SPLITCOMMIT}.tar.gz \
- -> ${P}-split-monitor-workspaces.gh.tar.gz
-"
-S="${WORKDIR}/${PN}-${COMMIT}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="+borders-plus-plus csgo-vulkan-fix +hyprbars split-monitor-workspaces"
-REQUIRED_USE="|| ( borders-plus-plus csgo-vulkan-fix hyprbars split-monitor-workspaces )"
-
-RDEPEND="gui-wm/hyprland"
-DEPEND="${RDEPEND}"
-BDEPEND="
- ~gui-wm/hyprland-${PV}
- x11-libs/libdrm
- x11-libs/pixman
- x11-libs/xcb-util-wm
-"
-
-src_configure() {
- if use borders-plus-plus; then
- BUILD_DIR="${WORKDIR}/${P}-build/borders-plus-plus"
- EMESON_SOURCE="${S}/borders-plus-plus"
- meson_src_configure
- fi
-
- if use csgo-vulkan-fix; then
- BUILD_DIR="${WORKDIR}/${P}-build/csgo-vulkan-fix"
- EMESON_SOURCE="${S}/csgo-vulkan-fix"
- meson_src_configure
- fi
-
- if use hyprbars; then
- BUILD_DIR="${WORKDIR}/${P}-build/hyprbars"
- EMESON_SOURCE="${S}/hyprbars"
- meson_src_configure
- fi
-}
-
-src_compile() {
- if use borders-plus-plus; then
- BUILD_DIR="${WORKDIR}/${P}-build/borders-plus-plus"
- EMESON_SOURCE="${S}/borders-plus-plus"
- meson_src_compile
- fi
-
- if use csgo-vulkan-fix; then
- BUILD_DIR="${WORKDIR}/${P}-build/csgo-vulkan-fix"
- EMESON_SOURCE="${S}/csgo-vulkan-fix"
- meson_src_compile
- fi
-
- if use hyprbars; then
- BUILD_DIR="${WORKDIR}/${P}-build/hyprbars"
- EMESON_SOURCE="${S}/hyprbars"
- meson_src_compile
- fi
-
- if use split-monitor-workspaces; then
- emake -C "${WORKDIR}/split-monitor-workspaces-${SPLITCOMMIT}" split-monitor-workspaces.so
- fi
-}
-
-src_install() {
- insinto "/usr/share/hyprland/plugins"
-
- if use borders-plus-plus; then
- newins "${WORKDIR}/${P}-build/borders-plus-plus/libborders-plus-plus.so" "borders-plus-plus.so"
- fi
-
- if use csgo-vulkan-fix; then
- newins "${WORKDIR}/${P}-build/csgo-vulkan-fix/libcsgo-vulkan-fix.so" "csgo-vulkan-fix.so"
- fi
-
- if use hyprbars; then
- newins "${WORKDIR}/${P}-build/hyprbars/libhyprbars.so" "hyprbars.so"
- fi
-
- if use split-monitor-workspaces; then
- doins "${WORKDIR}/split-monitor-workspaces-${SPLITCOMMIT}/split-monitor-workspaces.so"
- fi
-}
-
-pkg_postinst() {
- einfo "Plugins are installed in /usr/share/hyprland/plugins"
- einfo "To load them, refer to the official documentation"
- einfo "https://wiki.hyprland.org/Plugins/Using-Plugins/"
-}