aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-06-26 06:27:30 -0400
committerAisha Tammy <gentoo@aisha.cc>2020-06-26 06:27:30 -0400
commit7aa554ddccec5098f0c3de4d91a5cda9d3cefc90 (patch)
tree52886a50075bf7cf580ce4fb7c5a2c34c8904af1
parentwww-apps/uwebsockets: remove unneeded patch (diff)
downloadguru-7aa554dd.tar.gz
guru-7aa554dd.tar.bz2
guru-7aa554dd.zip
www-apps/uwebsockets: version bump to 18.7.0
Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
-rw-r--r--www-apps/uwebsockets/Manifest1
-rw-r--r--www-apps/uwebsockets/uwebsockets-18.7.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/www-apps/uwebsockets/Manifest b/www-apps/uwebsockets/Manifest
index 6f60638b3..4f5a0f819 100644
--- a/www-apps/uwebsockets/Manifest
+++ b/www-apps/uwebsockets/Manifest
@@ -1 +1,2 @@
DIST uwebsockets-18.6.0.tar.gz 264309 BLAKE2B c1cea128b6b0d5b7df30bb2aba97b0ac7207392755090e6950c61ab1847dd146b4a6c95dcd18065f3e969cfeaf3c5ffc09b17a5a34b6c5531b767a23df322386 SHA512 f748c90cb5cc83f119a27bd10d3043643cdc1bd617ccbd5460086e96114af8cbd9583c590bb9506b77f447c4e91b1f0be0493e3504af3d4f52d543a4f02826ba
+DIST uwebsockets-18.7.0.tar.gz 264566 BLAKE2B 83e5cbf08c9f46f377128f1c2447eb148fb36a4a5acd9658e64c81d820be3a639fd081639859356c2131b4487b60e09ebe21824378282ad8d7347bcdc64e8aee SHA512 6dafd3eb9a86ebcc873ea5fe35bce46e40f415945197171d2dbfa71a28d57a3338bf61c594b00f5f5009f61dc3d0811f3d444b341270bf57613bfd1aa2c0e090
diff --git a/www-apps/uwebsockets/uwebsockets-18.7.0.ebuild b/www-apps/uwebsockets/uwebsockets-18.7.0.ebuild
new file mode 100644
index 000000000..2738b66dd
--- /dev/null
+++ b/www-apps/uwebsockets/uwebsockets-18.7.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="ultra fast, simple, secure & standards compliant web I/O"
+HOMEPAGE="https://github.com/uNetworking/uWebSockets"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/uNetworking/uWebSockets.git"
+else
+ SRC_URI="https://github.com/uNetworking/uWebSockets/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+ S="${WORKDIR}/uWebSockets-${PV}"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+RDEPEND=">=net-libs/usockets-0.4.1"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-src_Loop.h.patch"
+)
+
+src_prepare() {
+ default
+ mv src uWebSockets
+}
+
+src_compile() {
+ return 0
+}
+
+src_install() {
+ doheader -r uWebSockets
+}