aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2021-04-22 09:30:16 -0400
committerAisha Tammy <gentoo@aisha.cc>2021-04-22 09:30:23 -0400
commit7c77946cb7cafd84c0a1b64fe568c00d41e260c9 (patch)
treec0302198ebe4aa1396bc00eb18e699d46de5fc07
parentsys-apps/sampler-bin: add QA prebuilt (diff)
downloadguru-7c77946c.tar.gz
guru-7c77946c.tar.bz2
guru-7c77946c.zip
gui-apps/tiramisu: update to dated ebuild for LDFLAG fix
Bug: https://bugs.gentoo.org/781062 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
-rw-r--r--gui-apps/tiramisu/Manifest1
-rw-r--r--gui-apps/tiramisu/tiramisu-1.0_p20201110.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/gui-apps/tiramisu/Manifest b/gui-apps/tiramisu/Manifest
index 4a2a33f0d..f0af89293 100644
--- a/gui-apps/tiramisu/Manifest
+++ b/gui-apps/tiramisu/Manifest
@@ -1,2 +1,3 @@
DIST tiramisu-0_p20201110.tar.gz 3063380 BLAKE2B 52b8f46478323b401dd5db96a531c86271b38d61991ee9147ccef400f2563fadacc92a289ef6ea2ccc01507cb1af57f0186a1690d39a421dcccb5d1f73ca3825 SHA512 7f8c978e6ead387fc9ccfb9eb15c73f237e10b14c8eb53e537a869402897e89451af371eabdf76506b9fcf51d6080b21d97863978de5e5e43af2b25578535b1d
DIST tiramisu-1.0.tar.gz 3063267 BLAKE2B f837a188f34cfb4ecc23aff9cb3d918239dd8ea2ce0a3f7905c5defd4bd5cff37984088008ed6fcdc8b128f92eb1808aadc058a992d2dbf41d0900142b38fe62 SHA512 357a223afa1664d170249fea187924c1942427b4c488ec18476774e19a8c15bdac104c7d4e105f4b2e2a4ad66e8954f572dad8be60a4b313a16c1612fe88f5b7
+DIST tiramisu-1.0_p20201110.tar.gz 3063380 BLAKE2B 52b8f46478323b401dd5db96a531c86271b38d61991ee9147ccef400f2563fadacc92a289ef6ea2ccc01507cb1af57f0186a1690d39a421dcccb5d1f73ca3825 SHA512 7f8c978e6ead387fc9ccfb9eb15c73f237e10b14c8eb53e537a869402897e89451af371eabdf76506b9fcf51d6080b21d97863978de5e5e43af2b25578535b1d
diff --git a/gui-apps/tiramisu/tiramisu-1.0_p20201110.ebuild b/gui-apps/tiramisu/tiramisu-1.0_p20201110.ebuild
new file mode 100644
index 000000000..69dc2a0fa
--- /dev/null
+++ b/gui-apps/tiramisu/tiramisu-1.0_p20201110.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="minimalistic desktop notifications provider"
+HOMEPAGE="https://github.com/Sweets/tiramisu"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Sweets/tiramisu"
+else
+ COMMIT="8eb946dae0e2f98d3850d89e1bb535640e8c3266"
+ SRC_URI="https://github.com/Sweets/tiramisu/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${COMMIT}"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="dev-libs/glib:2[dbus]"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ tc-export CC
+ default
+}
+
+src_install() {
+ emake DESTDIR="${ED}" PREFIX=/usr install
+}