aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-04-06 13:06:10 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-04-06 13:06:30 +0200
commit7e51cda748034061c0bdc22c733773e0f31a53de (patch)
tree638c940199e6e6b66e2b17febadb6089d073eeda
parentapp-misc/navi: Update crates 9999.ebuild (diff)
downloadguru-7e51cda748034061c0bdc22c733773e0f31a53de.tar.gz
guru-7e51cda748034061c0bdc22c733773e0f31a53de.tar.bz2
guru-7e51cda748034061c0bdc22c733773e0f31a53de.zip
app-shells/zsh-history-to-fish: nmew package
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--app-shells/zsh-history-to-fish/Manifest1
-rw-r--r--app-shells/zsh-history-to-fish/metadata.xml17
-rw-r--r--app-shells/zsh-history-to-fish/zsh-history-to-fish-0.3.0.ebuild20
3 files changed, 38 insertions, 0 deletions
diff --git a/app-shells/zsh-history-to-fish/Manifest b/app-shells/zsh-history-to-fish/Manifest
new file mode 100644
index 0000000000..5afda0e0f7
--- /dev/null
+++ b/app-shells/zsh-history-to-fish/Manifest
@@ -0,0 +1 @@
+DIST zsh-history-to-fish-0.3.0.tar.gz 4618 BLAKE2B e895ac40a956701c1bd71f46030a0d4cec4b2d2531fb791cef80eea7555914552da5223e92a33f4674b7e32fe86c87409e8c4d5e857d4dcf19415f1deb7d361b SHA512 5ab6ac4520f7f3eadc655816ac59b39bf4b325964f8de0755b3d5454a4ccc688086ae7881136091413090a0ab152e1650589cdfe1ad9c00e1ad54ebfcd8f6d3b
diff --git a/app-shells/zsh-history-to-fish/metadata.xml b/app-shells/zsh-history-to-fish/metadata.xml
new file mode 100644
index 0000000000..0a28a40052
--- /dev/null
+++ b/app-shells/zsh-history-to-fish/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription>
+Bring your ZSH history to Fish shell
+
+This is a simple tool to ease the migration from ZSH to Fish shell, without losing your hard-earned history commands.
+
+As I was migrating myself, I've found out there's no tool to do this automatically, so I've made one for my own use. For that, I had to search for the specifications of both history files, and ended up involved in multiple threads with the right devs to try to understand and make it work. In the process, I've stumbled upon several people interested in a such a tool.
+
+Well, it has worked! So I've wrapped it in a python package to make it easy to use, and now I'm sharing with anyone who may need it! It's released on PyPI.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">rsalmei/zsh-history-to-fish</remote-id>
+ <remote-id type="pypi">zsh-history-to-fish</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-shells/zsh-history-to-fish/zsh-history-to-fish-0.3.0.ebuild b/app-shells/zsh-history-to-fish/zsh-history-to-fish-0.3.0.ebuild
new file mode 100644
index 0000000000..d3c296d67c
--- /dev/null
+++ b/app-shells/zsh-history-to-fish/zsh-history-to-fish-0.3.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7,8,9} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Bring your ZSH history to Fish shell"
+HOMEPAGE="
+ https://github.com/rsalmei/zsh-history-to-fish
+ https://pypi.org/project/portio
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DOCS=( README.md )