aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2021-10-27 23:53:10 +0300
committerSergey Torokhov <torokhov-s-a@yandex.ru>2021-10-27 23:53:10 +0300
commit85c4f567a9f07f9075c864b636f9245ed600fc49 (patch)
tree8d8345ceb731b8733102dea8fe2c475319b3ca8c
parentsys-cluster/opencoarrays: Fix MPI network testing. Re-enable tests. (diff)
downloadguru-85c4f567.tar.gz
guru-85c4f567.tar.bz2
guru-85c4f567.zip
sci-physics/SU2: switch to EAPI-8. Enable MPI network tests
Use EAPI-8 option PROPERTIES="test_network" to enable network testing that is required by MPI. Closes: https://bugs.gentoo.org/820293 Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru>
-rw-r--r--sci-physics/SU2/SU2-7.2.0.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/sci-physics/SU2/SU2-7.2.0.ebuild b/sci-physics/SU2/SU2-7.2.0.ebuild
index 32027c04f..8c0012dae 100644
--- a/sci-physics/SU2/SU2-7.2.0.ebuild
+++ b/sci-physics/SU2/SU2-7.2.0.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
PYTHON_COMPAT=( python3_{8..9} )
@@ -27,7 +27,13 @@ KEYWORDS="~amd64"
# pastix is disabled as it's require additional external bundled libs;
# autodiff (medi), directdiff (opti) features require additional external bundled libs.
IUSE="cgns mkl +mpi mpp openblas parmetis tecio test tutorials"
+
+# Tests fail with FEATURES="network-sandbox" for most versions of openmpi and mpich it with error:
+# "No network interfaces were found for out-of-band communications.
+# We require at least one available network for out-of-band messaging."
+PROPERTIES="test_network"
RESTRICT="!test? ( test )"
+
REQUIRED_USE="
${PYTHON_REQUIRED_USE}
mkl? ( !openblas )