aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2023-03-07 19:02:18 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2023-03-07 19:02:18 +0500
commit86610356a8c0fd924c8ae3c1e0f46aa78bb627ca (patch)
treed9113d5fd45c71e91d16f8e7eaa08a677f2d1420
parentapp-admin/krapplet: enable py3.11 (diff)
downloadguru-86610356a8c0fd924c8ae3c1e0f46aa78bb627ca.tar.gz
guru-86610356a8c0fd924c8ae3c1e0f46aa78bb627ca.tar.bz2
guru-86610356a8c0fd924c8ae3c1e0f46aa78bb627ca.zip
dev-python/openstep-plist: add 0.3.0_p1, drop 0.3.0
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
-rw-r--r--dev-python/openstep-plist/Manifest2
-rw-r--r--dev-python/openstep-plist/openstep-plist-0.3.0.ebuild32
-rw-r--r--dev-python/openstep-plist/openstep-plist-0.3.0_p1.ebuild39
3 files changed, 40 insertions, 33 deletions
diff --git a/dev-python/openstep-plist/Manifest b/dev-python/openstep-plist/Manifest
index 2fe0edf0e9..2360602a8c 100644
--- a/dev-python/openstep-plist/Manifest
+++ b/dev-python/openstep-plist/Manifest
@@ -1 +1 @@
-DIST openstep-plist-0.3.0.gh.tar.gz 20692 BLAKE2B 4be8190b08ad6146df92f774597405977af898dfa0dd7b639d8c07674641fec54c139f292ec15f04c44062c9c128e29716f1fa642e4d04d160d6c1b310128a68 SHA512 623fbe4b169805f42828e41ff949c2a9a91620b76c0adda33e4e66c19345826bef21ac645571e5c52208f029389b37b6b9918ad3e85388475b50c243e16ca715
+DIST openstep_plist-0.3.0.post1.zip 215537 BLAKE2B ff316db2cbbf4e171d9a4a67797e11da51bce5c9aac549ed5917182a4a1f266b894c3479215f9a8f568098ad2c8e2f931657b40b67c5b1a7414a47234776c866 SHA512 cb38c3da505de9788fc98e0bee407b4ad07d24d994c30c6b7665c25aa7830a44cf5567b4f22e75e75087058345d6c61a5b923a85ef386483b3c76d1b644c19bb
diff --git a/dev-python/openstep-plist/openstep-plist-0.3.0.ebuild b/dev-python/openstep-plist/openstep-plist-0.3.0.ebuild
deleted file mode 100644
index da8fd5dceb..0000000000
--- a/dev-python/openstep-plist/openstep-plist-0.3.0.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="ASCII plist parser written in Cython"
-HOMEPAGE="https://github.com/fonttools/openstep-plist"
-SRC_URI="https://github.com/fonttools/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-KEYWORDS="~amd64"
-LICENSE="MIT"
-SLOT="0"
-
-DEPEND=">=dev-python/cython-0.28.5[${PYTHON_USEDEP}]"
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest-cython[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- export SETUPTOOLS_SCM_PRETEND_VERSION="${PV%_*}"
- default
-}
diff --git a/dev-python/openstep-plist/openstep-plist-0.3.0_p1.ebuild b/dev-python/openstep-plist/openstep-plist-0.3.0_p1.ebuild
new file mode 100644
index 0000000000..905fbd86d3
--- /dev/null
+++ b/dev-python/openstep-plist/openstep-plist-0.3.0_p1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 pypi
+
+DESCRIPTION="ASCII plist parser written in Cython"
+HOMEPAGE="
+ https://pypi.org/project/openstep-plist/
+ https://github.com/fonttools/openstep-plist
+"
+SRC_URI="$(pypi_sdist_url ${PN} $(pypi_translate_version ${PV}) .zip)"
+
+KEYWORDS="~amd64"
+LICENSE="MIT"
+SLOT="0"
+
+BDEPEND="
+ >=dev-python/cython-0.28.5[${PYTHON_USEDEP}]
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-cython[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+ find "${S}" -name '*.cpp' -delete || die
+}
+
+src_configure() {
+ distutils-r1_src_configure
+ export SETUPTOOLS_SCM_PRETEND_VERSION="$(pypi_translate_version ${PV})"
+}