aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-05-02 21:50:12 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-05-02 22:01:15 +0200
commit87b134757377f77a4526e28e9c390e5bb29876be (patch)
tree0bbb2346c0dc70c3e2c21fd95a6b5eb7b3c97626
parentdev-python/types-paramiko: add 2.8.21, drop 2.8.17 (diff)
downloadguru-87b13475.tar.gz
guru-87b13475.tar.bz2
guru-87b13475.zip
dev-python/pytest-cython: add 0.2.0
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--dev-python/pytest-cython/Manifest1
-rw-r--r--dev-python/pytest-cython/pytest-cython-0.2.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pytest-cython/Manifest b/dev-python/pytest-cython/Manifest
index f5da597e9..646c449b7 100644
--- a/dev-python/pytest-cython/Manifest
+++ b/dev-python/pytest-cython/Manifest
@@ -1 +1,2 @@
DIST pytest-cython-0.1.1.tar.gz 817776 BLAKE2B d9b812cefc45153a1ce7abb0b1be2e7fc329b88d89ed48529f62a38c402d74bb164ed6b928f291586f0064820dc52156eacdf161da3a0d65d10f5a15681a17e4 SHA512 353a6c3b67df0608b24f24e04ba5d3fa48065d3960834e32bf44f2dfcd6248cb4c86de528c15dbfd20e36811bfb0ae04670f6441afb74bcb7bd1d7af71060463
+DIST pytest-cython-0.2.0.tar.gz 16201 BLAKE2B 7e32bdb0eb7b83d7d6444b8f102c25b64057e37d8f8d69bd579880f800151cee874c8e94c16b2aa12a82931666ff41112569ccd2ab225dafa95b87f89d44ddaa SHA512 0ab793c116f4b5b1dc20214d7151e71dc9b58473a19983105e9e06502568af962344853091f0f6bdeb70d6d044ba6a3add98148d4bd81eceb8e143050d288f79
diff --git a/dev-python/pytest-cython/pytest-cython-0.2.0.ebuild b/dev-python/pytest-cython/pytest-cython-0.2.0.ebuild
new file mode 100644
index 000000000..261f4d13a
--- /dev/null
+++ b/dev-python/pytest-cython/pytest-cython-0.2.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Plugin for testing Cython extension modules"
+HOMEPAGE="https://github.com/lgpage/pytest-cython"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ >=dev-python/pytest-4.6.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_sphinx docs dev-python/sphinx-py3doc-enhanced-theme
+distutils_enable_tests pytest