aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Zuber <a.zuber@gmx.ch>2020-08-02 18:20:47 +0200
committerAndreas Zuber <a.zuber@gmx.ch>2020-08-02 18:20:47 +0200
commit89c40d06d38bf9aa45434f785e638da5512b5029 (patch)
tree97aebf04b968d03269d8e82a0972ed455e5073a3
parentdev-libs/open62541: Drop old (diff)
downloadguru-89c40d06.tar.gz
guru-89c40d06.tar.bz2
guru-89c40d06.zip
games-util/gamehub: new package
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Andreas Zuber <a.zuber@gmx.ch>
-rw-r--r--games-util/gamehub/Manifest1
-rw-r--r--games-util/gamehub/gamehub-0.16.0.1.ebuild54
-rw-r--r--games-util/gamehub/metadata.xml11
3 files changed, 66 insertions, 0 deletions
diff --git a/games-util/gamehub/Manifest b/games-util/gamehub/Manifest
new file mode 100644
index 000000000..9282922aa
--- /dev/null
+++ b/games-util/gamehub/Manifest
@@ -0,0 +1 @@
+DIST gamehub-0.16.0.1.tar.gz 9714011 BLAKE2B ccc09cc9d0bdbab8c3f10c4ffdeffcc71a02159f7e5f35c861ba159d9a50980141100184386328ab56bb1e2ba9eb788331f298c514809ad24847dbf7e0f9c44d SHA512 50c701b7a41431f1f395f49b2379239a31833c60c99a5a6ac918bcc94b15a2dd40211acd5f7d0e099af4bd89d524155c2763218d4bfdcb2bacd00b4f1c8e1058
diff --git a/games-util/gamehub/gamehub-0.16.0.1.ebuild b/games-util/gamehub/gamehub-0.16.0.1.ebuild
new file mode 100644
index 000000000..8e242a128
--- /dev/null
+++ b/games-util/gamehub/gamehub-0.16.0.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome2-utils meson vala xdg-utils
+
+DESCRIPTION="GameHub is a unified library for all your games"
+HOMEPAGE="https://tkashkin.tk/projects/gamehub"
+
+MY_PN="GameHub"
+MY_PV="$(ver_rs 3 '-')-master"
+MY_P="${MY_PN}-${MY_PV}"
+
+SRC_URI="https://github.com/tkashkin/${MY_PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-db/sqlite:3
+ dev-libs/glib:2
+ dev-libs/json-glib
+ dev-libs/libgee:0.8
+ >=dev-libs/libmanette-0.2
+ dev-libs/libxml2
+ net-libs/libsoup:2.4
+ net-libs/webkit-gtk:4
+ sys-auth/polkit
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ x11-libs/libXtst"
+BDEPEND="
+ ${RDEPEND}
+ $(vala_depend)"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ vala_src_prepare
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ gnome2_schemas_update
+}
diff --git a/games-util/gamehub/metadata.xml b/games-util/gamehub/metadata.xml
new file mode 100644
index 000000000..81120a4e8
--- /dev/null
+++ b/games-util/gamehub/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>a.zuber@gmx.ch</email>
+ <name>Andreas Zuber</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">tkashkin/GameHub</remote-id>
+ </upstream>
+</pkgmetadata>