aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-09-08 11:24:59 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-09-08 12:06:56 +0200
commit8aa354b46fc4c815fba679c9d086cec77e2025cc (patch)
treefb42a66b93ee9836099a21a3d7a5b64b8c1ce23f
parentdev-lang/fbc: Version bump to 1.08.1 (diff)
downloadguru-8aa354b4.tar.gz
guru-8aa354b4.tar.bz2
guru-8aa354b4.zip
sci-libs/meschach: add 1.2b_p20170511
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--sci-libs/meschach/Manifest1
-rw-r--r--sci-libs/meschach/meschach-1.2b_p20170511.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/sci-libs/meschach/Manifest b/sci-libs/meschach/Manifest
index aa641bb63..df80a73fe 100644
--- a/sci-libs/meschach/Manifest
+++ b/sci-libs/meschach/Manifest
@@ -1,2 +1,3 @@
+DIST meschach-1.2b_p20170511.tar.gz 577104 BLAKE2B 83b47828c814d4a7f4957f02448babb0961383f61f329431ef74a8ec2800c196d5cb0e1363a258b06f18adccaf39d859e640f01bf7f98b5b0ac634adc5f58beb SHA512 054c9380ff2df4c8c3bda0eb20df2a9da8fe357fd939116a257bb2831d04893aad29999df0d2bd9434173a1246ec18a73779abdadc477f9c2dd9d027446393d1
DIST meschach_1.2b-14.debian.tar.xz 40664 BLAKE2B 753cdcdf8ecd63be14a294a6607380462df8a74c1cc84fafcfe4140cb10eaeb590dbe12883e2a973691a920b1e7f4efdf884781b49ea947b1132ff213f4a2652 SHA512 9793127a1785fb757b61132db1c471a2ff7949c383870f10d0b24ea2e1dafcb9d9379b61698179f91fdba4405e18e1692efcc26b759b1a5d9519e8c46206636b
DIST meschach_1.2b.orig.tar.gz 220166 BLAKE2B fe38d9887977f45cc54857fe9c33f1eb50d1192ce3cae643127962cfce7657d9890964aabd3690751648a3a850fbbb39c6fb2110f8b4fcd789c7b8efefcec2c5 SHA512 0b8748915739b624aa44b0bf6f2c59aaf3d09f69f9455220e4baeb423c094a89cc25c03d6ced0d58bfd7c5d6626f3995fc853119ab0f7d6af151d8479c326068
diff --git a/sci-libs/meschach/meschach-1.2b_p20170511.ebuild b/sci-libs/meschach/meschach-1.2b_p20170511.ebuild
new file mode 100644
index 000000000..8ddb5297b
--- /dev/null
+++ b/sci-libs/meschach/meschach-1.2b_p20170511.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit cmake
+
+COMMIT="201bcf933bcd4d971c3ab50e0651c6e65ba004b9"
+MAJOR="$(ver_cut 1)"
+VERSION="$(ver_cut 1-2)"
+
+DESCRIPTION="Meschach is a C-language library of routines for performing matrix computations"
+HOMEPAGE="
+ https://github.com/yageek/Meschach
+ http://homepage.divms.uiowa.edu/~dstewart/meschach
+"
+S="${WORKDIR}/${PN^}-${COMMIT}"
+
+SRC_URI="https://github.com/yageek/Meschach/archive/${COMMIT}.tar.gz -> ${PF}.tar.gz"
+LICENSE="meschach"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="+complex +double munroll old segmem +float +sparse unroll"
+
+#PATCHES=(
+# "${FILESDIR}/.patch"
+#)
+
+src_configure() {
+ mycmakeargs=(
+ -DANDROID_COMPILE=OFF
+ -DCOMPLEX_OPTION=$(usex complex)
+ -DREAL_DBL_OPTION=$(usex double)
+ -DREAL_FLT_OPTION=$(usex float)
+ -DMUNROLL_OPTION=$(usex munroll)
+ -DSEGMENTED_OPTION=$(usex segmem)
+ -DSPARSE_OPTION=$(usex sparse)
+ -DVUNROLL_OPTION=$(usex unroll)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+}
+
+src_install() {
+ pushd "${BUILD_DIR}" || die
+ ln -s "lib${PN}.so" "lib${PN}.so.${MAJOR}" || die
+ ln -s "lib${PN}.so.${MAJOR}" "lib${PN}.so.${VERSION}" || die
+ dolib.so "lib${PN}.so"
+ dolib.so "lib${PN}.so.${MAJOR}"
+ dolib.so "lib${PN}.so.${VERSION}"
+
+# exeinto "/usr/libexec/${PN}"
+# doexe iotort
+# doexe itertort
+# doexe memtort
+# doexe mfuntort
+# doexe sptort
+# doexe torture
+# doexe ztorture
+ popd || die
+
+ insinto "/usr/include/${PN}"
+ doins *.h
+
+ insinto "/usr/share/${PN}"
+ doins *.dat
+
+ dodoc -r DOC/.
+ dodoc README.md
+}