aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2022-12-22 20:01:23 -0500
committerJulien Roy <julien@jroy.ca>2022-12-22 20:01:23 -0500
commit8c37877c62a65f8ccce2af01146c020951e84e6a (patch)
tree2feec11b3cd954cfc059d1a106fa183fb4c5a672
parentdev-python/{PGPy,mistletoe}: fix warnings (diff)
downloadguru-8c37877c.tar.gz
guru-8c37877c.tar.bz2
guru-8c37877c.zip
dev-python/portion: new package, add 2.3.0
Signed-off-by: Julien Roy <julien@jroy.ca>
-rw-r--r--dev-python/portion/Manifest1
-rw-r--r--dev-python/portion/metadata.xml19
-rw-r--r--dev-python/portion/portion-2.3.0.ebuild27
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/portion/Manifest b/dev-python/portion/Manifest
new file mode 100644
index 000000000..710994cb3
--- /dev/null
+++ b/dev-python/portion/Manifest
@@ -0,0 +1 @@
+DIST portion-2.3.0.gh.tar.gz 32488 BLAKE2B 1efe8d2c5046b42704c753e775d3d0362e088bdff728688f0885d2975609d7cd8eccc2889a8942e92545b46189a52d984a89fec8a89014f55fd712d5f4dccbca SHA512 7552e9a640dd8dd5a55ad5009e976d7fdbc369eeac43ad82972a8ec0dea71e5dd33e425d2410527f8dc85caf08039d6eb879c694266ef8d7ff1362946707bfde
diff --git a/dev-python/portion/metadata.xml b/dev-python/portion/metadata.xml
new file mode 100644
index 000000000..34539baeb
--- /dev/null
+++ b/dev-python/portion/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>julien@jroy.ca</email>
+ <name>Julien Roy</name>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <name>Alexandre Decan</name>
+ <email>alexandre.decan@lexpage.net</email>
+ </maintainer>
+ <changelog>https://github.com/AlexandreDecan/portion/blob/master/CHANGELOG.md</changelog>
+ <doc>https://github.com/AlexandreDecan/portion#documentation--usage</doc>
+ <bugs-to>https://github.com/AlexandreDecan/portion/issues</bugs-to>
+ <remote-id type="github">AlexandreDecan/portion</remote-id>
+ <remote-id type="pypi">portion</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/portion/portion-2.3.0.ebuild b/dev-python/portion/portion-2.3.0.ebuild
new file mode 100644
index 000000000..790f78c8c
--- /dev/null
+++ b/dev-python/portion/portion-2.3.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="A Python library providing data structure and operations for intervals."
+HOMEPAGE="https://github.com/AlexandreDecan/portion"
+SRC_URI="https://github.com/AlexandreDecan/${PN}/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/black[${PYTHON_USEDEP}]
+)"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-python/sortedcontainers"
+
+distutils_enable_tests pytest