aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuel Bauer <samuel.bauer@yahoo.fr>2021-05-25 19:33:37 +0200
committerSamuel Bauer <samuel.bauer@yahoo.fr>2021-05-25 20:22:46 +0200
commit8e03ef5c5b5f2a883a339f754ee41dc7b2398d52 (patch)
tree5652fe26898663e84cfcf5fc4e4258d65d05095e
parentwww-servers/hinsightd: new version 0.9.4 (diff)
downloadguru-8e03ef5c.tar.gz
guru-8e03ef5c.tar.bz2
guru-8e03ef5c.zip
games-emulation/yuzu: sdl detection + cosmetic changes
Signed-off-by: Samuel Bauer <samuel.bauer@yahoo.fr>
-rw-r--r--games-emulation/yuzu/yuzu-9999.ebuild24
1 files changed, 14 insertions, 10 deletions
diff --git a/games-emulation/yuzu/yuzu-9999.ebuild b/games-emulation/yuzu/yuzu-9999.ebuild
index 7db25934a..0f50d353d 100644
--- a/games-emulation/yuzu/yuzu-9999.ebuild
+++ b/games-emulation/yuzu/yuzu-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2021 Gentoo Authors
+# Copyright 2020-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -85,14 +85,17 @@ src_prepare() {
# sed -i -e '/target_include_directories(xbyak/s:./xbyak/xbyak:/usr/include/xbyak/:' externals/CMakeLists.txt
# Unbundle vulkan headers
- sed -i -e 's:../../externals/Vulkan-Headers/include:/usr/include/vulkan/:' src/video_core/CMakeLists.txt src/yuzu/CMakeLists.txt src/yuzu_cmd/CMakeLists.txt
- sed -i -e '/VK_ERROR_INCOMPATIBLE_VERSION_KHR/d' src/video_core/vulkan_common/vulkan_wrapper.cpp
+ sed -i -e 's:../../externals/Vulkan-Headers/include:/usr/include/vulkan/:' src/video_core/CMakeLists.txt src/yuzu/CMakeLists.txt src/yuzu_cmd/CMakeLists.txt || die
+ sed -i -e '/VK_ERROR_INCOMPATIBLE_VERSION_KHR/d' src/video_core/vulkan_common/vulkan_wrapper.cpp || die
# Unbundle discord rapidjson
sed -i '/NOT RAPIDJSONTEST/,/endif(NOT RAPIDJSONTEST)/d;/find_file(RAPIDJSON/d;s:\${RAPIDJSON}:"/usr/include/rapidjson":' externals/discord-rpc/CMakeLists.txt || die
- # media-libs/libsdl2: use 2.0.14 in tree
- sed -i 's/2.0.15/2.0.14/' CMakeLists.txt
+ # Force disable bundled sdl2, use 2.0.14 in tree
+ if use sdl; then
+ sed -i '/find_package(SDL2/{s/2.0.15/2.0.14/;s/ QUIET//}' CMakeLists.txt || die
+ sed -i '/PS5_RUMBLE/d' src/input_common/sdl/sdl_impl.cpp
+ fi
cmake_src_prepare
}
@@ -100,14 +103,15 @@ src_prepare() {
src_configure() {
local -a mycmakeargs=(
-DBUILD_SHARED_LIBS=OFF
- -DENABLE_CUBEB=$(usex cubeb ON OFF)
+ -DENABLE_CUBEB=$(usex cubeb)
-DENABLE_QT=$(usex qt5)
-DENABLE_QT_TRANSLATION=$(usex qt5)
-DENABLE_SDL2=$(usex sdl)
- -DENABLE_WEB_SERVICE=$(usex webservice ON OFF)
- -DUSE_DISCORD_PRESENCE=$(usex discord ON OFF)
- -DYUZU_ENABLE_BOXCAT=$(usex boxcat ON OFF)
- -DYUZU_USE_QT_WEB_ENGINE=$(usex webengine ON OFF)
+ -DENABLE_WEB_SERVICE=$(usex webservice)
+ -DUSE_DISCORD_PRESENCE=$(usex discord)
+ -DYUZU_ALLOW_SYSTEM_SDL2=$(usex sdl)
+ -DYUZU_ENABLE_BOXCAT=$(usex boxcat)
+ -DYUZU_USE_QT_WEB_ENGINE=$(usex webengine)
-DENABLE_COMPATIBILITY_LIST_DOWNLOAD=OFF
)
cmake_src_configure