aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2021-10-30 02:21:17 +0200
committerRonny (tastytea) Gutbrod <gentoo@tastytea.de>2021-10-30 02:21:17 +0200
commit8f5614e9414eed6e11c5aac01b6b71e23751f2e0 (patch)
treeae00f413be0daf6ea82e3af1c6c9ce657b062308
parentwww-client/torbrowser-launcher: add missing dev-python/distro dep (diff)
downloadguru-8f5614e9414eed6e11c5aac01b6b71e23751f2e0.tar.gz
guru-8f5614e9414eed6e11c5aac01b6b71e23751f2e0.tar.bz2
guru-8f5614e9414eed6e11c5aac01b6b71e23751f2e0.zip
games-util/legendary: Version bump 0.20.18.
Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de>
-rw-r--r--games-util/legendary/Manifest1
-rw-r--r--games-util/legendary/legendary-0.20.18.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/games-util/legendary/Manifest b/games-util/legendary/Manifest
index 9f98f8f3a..5ae6b3eb0 100644
--- a/games-util/legendary/Manifest
+++ b/games-util/legendary/Manifest
@@ -1,2 +1,3 @@
DIST legendary-0.20.16.tar.gz 103162 BLAKE2B 2cc379544935fe032c4c132da4e49db646173f0b659f66d699b4da0175fee40218a7f71e677637fb0904f738572faf1c0092cc86a2b39a2b9b48f97cc3bf4bb1 SHA512 236009024767257d998508b0dd586113168a67a3dc3fe4b4df9b71df3c8d9f2e17141c782e489c5d6c5927a203d7bff2327befae3ad10215a9112b17d6415e2b
DIST legendary-0.20.17.tar.gz 105244 BLAKE2B 5313a6ffa732d159debb4e9bbaa7d4d60a3ce1ada694133224ed9fe12cf885f38f4fc078fc518f364a44e26c3e804952c1ab671c63cab669f3341c0507f3b845 SHA512 7fe89f1d286d7bf2a3dc1948758020b9c298d549164812a09ef7ff1e683672ea2d3311b215f7862a060ba74537a12b8178a2f71e1f6899cebbc3b6afbe6a7b5d
+DIST legendary-0.20.18.tar.gz 105531 BLAKE2B f321ae20c2d4207df5027ab95a31d7aab3673f38037c2a4a6ea07af999f5471bce1e790836d551f4109a600f6eba9b223db768046c937a05250c9a020b55d2e7 SHA512 25720fc5eee42c180f084a5cc2543c344608a0831bcf4d987d288544ea8164adc48d3c964ffe12fab4967d25a2a3285f3743233c6bf3e94c8934b167756dca15
diff --git a/games-util/legendary/legendary-0.20.18.ebuild b/games-util/legendary/legendary-0.20.18.ebuild
new file mode 100644
index 000000000..42ccdcc71
--- /dev/null
+++ b/games-util/legendary/legendary-0.20.18.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9,10} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_SETUPTOOLS="bdepend"
+
+inherit distutils-r1
+
+DESCRIPTION="A free and open-source replacement for the Epic Games Launcher"
+HOMEPAGE="https://github.com/derrod/legendary"
+SRC_URI="https://github.com/derrod/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="webview"
+
+# NOTE: dev-python/pywebview[qt5] is not much tested and does not function
+# correctly in some cases, according to release notes for 0.20.16.
+RDEPEND="
+ $(python_gen_cond_dep '
+ <dev-python/requests-3.0[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ webview? ( dev-python/pywebview[gtk,${PYTHON_USEDEP}] )
+ ')
+"
+DEPEND="${RDEPEND}"