aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2022-05-31 00:25:24 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2022-05-31 00:25:56 +0500
commit901344f1f14c39c0e26f68b5796f3ded22a75dd3 (patch)
tree52faf4323abced42ad2f349efa3fedf6f2407e8a
parentdev-vcs/got: add 0.70, drop 0.67 (diff)
downloadguru-901344f1.tar.gz
guru-901344f1.tar.bz2
guru-901344f1.zip
app-misc/mat2: enable py3.10
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
-rw-r--r--app-misc/mat2/Manifest1
-rw-r--r--app-misc/mat2/mat2-0.12.2.ebuild45
-rw-r--r--app-misc/mat2/mat2-0.12.4.ebuild34
3 files changed, 16 insertions, 64 deletions
diff --git a/app-misc/mat2/Manifest b/app-misc/mat2/Manifest
index 8cb8bafd5..9fb45e9e8 100644
--- a/app-misc/mat2/Manifest
+++ b/app-misc/mat2/Manifest
@@ -1,2 +1 @@
-DIST mat2-0.12.2.tar.gz 10463222 BLAKE2B 2c0285b3352b313a9cb11c28cbb0423acb4bb9d49ba1941bbfe772d8a4b4a44703d42ba99df5894a499bc920b233b79059438cc27e99bc8e02a5f83aaa01a452 SHA512 cdf13d58e48cd69c873e9324d4d4aa30f5b1e281e83751ed0e5c0f1d726b9f75f7da191d632dc8f2536db829cb23883a7c6b8613c7499b33cf6804d43f4d1e23
DIST mat2-0.12.4.tar.gz 10464411 BLAKE2B 161d92dfea16c7ab5a09e9271b5cd4fbd64ddeaca18187395ff3ffb5671d5fc5d98c70d2a081c566148cbed7b6c9923ca87f732552d0172cb841030edbf70192 SHA512 20936c80d0fa31dae9ee14c3d853c0e63a87b2d3ad5838a17bdbbc3e7cb4cf73462c9a9573d2aeab6e4ab0d6c18ce24c63a80e1a7cd044724c8ecc639d13da80
diff --git a/app-misc/mat2/mat2-0.12.2.ebuild b/app-misc/mat2/mat2-0.12.2.ebuild
deleted file mode 100644
index 6321250df..000000000
--- a/app-misc/mat2/mat2-0.12.2.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=(python3_{8..9})
-PYTHON_REQ_USE="xml"
-DISTUTILS_USE_SETUPTOOLS=bdepend
-
-inherit distutils-r1
-
-DESCRIPTION="Metadata Anonymisation Toolkit: handy tool to trash your metadata"
-HOMEPAGE="https://0xacab.org/jvoisin/mat2"
-SRC_URI="https://0xacab.org/jvoisin/mat2/-/archive/${PV}/${P}.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="+exif sandbox video"
-REQUIRED_USE="
- ${PYTHON_REQUIRED_USE}
- test? ( exif video )
-"
-
-RDEPEND="
- ${PYTHON_DEPS}
- app-text/poppler[introspection]
- dev-python/pycairo:0[${PYTHON_USEDEP}]
- dev-python/pygobject:3[${PYTHON_USEDEP}]
- gnome-base/librsvg:2[introspection]
- media-libs/mutagen:0[${PYTHON_USEDEP}]
- x11-libs/gdk-pixbuf:2[introspection]
- exif? ( media-libs/exiftool:* )
- sandbox? ( sys-apps/bubblewrap )
- video? ( media-video/ffmpeg:* )
-"
-DEPEND="
- ${RDEPEND}
- test? (
- media-video/ffmpeg[mp3,vorbis]
- x11-libs/gdk-pixbuf:2[jpeg,tiff]
- )
-"
-
-distutils_enable_tests unittest
diff --git a/app-misc/mat2/mat2-0.12.4.ebuild b/app-misc/mat2/mat2-0.12.4.ebuild
index c2e881888..3e728eb43 100644
--- a/app-misc/mat2/mat2-0.12.4.ebuild
+++ b/app-misc/mat2/mat2-0.12.4.ebuild
@@ -3,43 +3,41 @@
EAPI=8
-PYTHON_COMPAT=(python3_{8..9})
+PYTHON_COMPAT=(python3_{8..10})
PYTHON_REQ_USE="xml"
-DISTUTILS_USE_SETUPTOOLS=bdepend
-inherit distutils-r1
+inherit distutils-r1 optfeature
DESCRIPTION="Metadata Anonymisation Toolkit: handy tool to trash your metadata"
HOMEPAGE="https://0xacab.org/jvoisin/mat2"
-SRC_URI="https://0xacab.org/jvoisin/mat2/-/archive/${PV}/${P}.tar.gz"
+SRC_URI="https://0xacab.org/jvoisin/${PN}/-/archive/${PV}/${P}.tar.gz"
LICENSE="LGPL-3"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="+exif sandbox video"
-REQUIRED_USE="
- ${PYTHON_REQUIRED_USE}
- test? ( exif video )
-"
RDEPEND="
- ${PYTHON_DEPS}
- app-text/poppler[introspection]
dev-python/pycairo:0[${PYTHON_USEDEP}]
dev-python/pygobject:3[${PYTHON_USEDEP}]
- gnome-base/librsvg:2[introspection]
media-libs/mutagen:0[${PYTHON_USEDEP}]
- x11-libs/gdk-pixbuf:2[introspection]
- exif? ( media-libs/exiftool:* )
- sandbox? ( sys-apps/bubblewrap )
- video? ( media-video/ffmpeg:* )
"
-DEPEND="
- ${RDEPEND}
+BDEPEND="
test? (
+ media-libs/exiftool:*
media-video/ffmpeg[mp3,vorbis]
x11-libs/gdk-pixbuf:2[jpeg,tiff]
)
"
+DOCS=( doc {CHANGELOG,CONTRIBUTING,INSTALL,README}.md )
+
distutils_enable_tests unittest
+
+pkg_postinst() {
+ optfeature "PDF support" "app-text/poppler[introspection]"
+ optfeature "SVG support" "gnome-base/librsvg:2[introspection]"
+ optfeature "image support" "x11-libs/gdk-pixbuf:2[introspection]"
+ optfeature "misc file format support" media-libs/exiftool
+ optfeature "sandboxing" sys-apps/bubblewrap
+ optfeature "video support" media-video/ffmpeg
+}