aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-04-16 19:12:46 +0200
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-04-16 19:12:46 +0200
commit93eeab55e0620e22831f22dfb61bd4ac75fcee3a (patch)
tree9d7010a0d3e66b3e645dcd167fba1367ed731d2e
parentmedia-libs/amdvlk: new version 2020.2.1 (diff)
downloadguru-93eeab55.tar.gz
guru-93eeab55.tar.bz2
guru-93eeab55.zip
app-text/OCRmyPDF: enable doc building support
also tried to enable tests, but man does it use a lot of RAM not worth the trouble IMO Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
-rw-r--r--app-text/OCRmyPDF/Manifest2
-rw-r--r--app-text/OCRmyPDF/OCRmyPDF-9.7.2.ebuild (renamed from app-text/OCRmyPDF/OCRmyPDF-9.7.1.ebuild)19
2 files changed, 17 insertions, 4 deletions
diff --git a/app-text/OCRmyPDF/Manifest b/app-text/OCRmyPDF/Manifest
index f9690203a..419878a2d 100644
--- a/app-text/OCRmyPDF/Manifest
+++ b/app-text/OCRmyPDF/Manifest
@@ -1 +1 @@
-DIST OCRmyPDF-9.7.1.tar.gz 7859333 BLAKE2B 5f366d8655c55dafe911d2f1feaad84c4f032252454015693b314515d6bd308e91f93626cb3229d2956354e2c60df8420fb4d7a2023ca0a78636ea5c40d7ff56 SHA512 daf5f636afa2704c9163f4f0d49f944358919c2af229030d78bb29f10d0a8acf3e219060542d52982bc02180b410c6dca771c54f4d3239250365397707bccf6c
+DIST OCRmyPDF-9.7.2.tar.gz 7859735 BLAKE2B 2744c893f6dd0f23ada9a11570fdf007842d01bcd84a1892f01bb828ca5e4d62e25724adf8124f3c75186c6eb56b19ef3bbfcbd6f4c1f9fa5821b0d59a19be33 SHA512 03dd14940cafc74dbfbf4c4ec569ca5de4cd588a1e7da11fda65a48ddb40b0a0613a7d6bd6520b07b2b9dc705c4f0e744076c7826d9789d782014b4d1dacc16e
diff --git a/app-text/OCRmyPDF/OCRmyPDF-9.7.1.ebuild b/app-text/OCRmyPDF/OCRmyPDF-9.7.2.ebuild
index 3209a6331..b397cceda 100644
--- a/app-text/OCRmyPDF/OCRmyPDF-9.7.1.ebuild
+++ b/app-text/OCRmyPDF/OCRmyPDF-9.7.2.ebuild
@@ -2,7 +2,10 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+
+PYTHON_COMPAT=( python3_{6,7} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
inherit bash-completion-r1 distutils-r1
DESCRIPTION="OCRmyPDF adds an OCR text layer to scanned PDF files"
@@ -13,11 +16,18 @@ SRC_URI="https://github.com/${MY_GITHUB_AUTHOR}/${PN}/archive/v${PV}.tar.gz -> $
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64"
+
+# This uses *a lot* of RAM, I have 32gb and these tests tried to use it all
+RESTRICT="test"
IUSE="jbig2enc"
-DEPEND=""
+DEPEND="test? (
+ dev-python/pytest-helpers-namespace[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ ~dev-python/python-xmp-toolkit-2.0.1[${PYTHON_USEDEP}]
+)"
+
RDEPEND="
- ${DEPEND}
app-text/ghostscript-gpl
app-text/tesseract
app-text/unpaper
@@ -34,6 +44,9 @@ RDEPEND="
jbig2enc? ( media-libs/jbig2enc )
"
+distutils_enable_tests pytest
+distutils_enable_sphinx docs --no-autodoc
+
python_prepare_all() {
# do not depend on deprecated dep
sed -i -e '/pytest-runner/d' setup.py || die