aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-07-05 13:35:52 +0200
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-07-05 13:37:29 +0200
commit9479fbb7c196658779e0b2e0d2cc524e8c23be08 (patch)
treec49eae3b858abe052ca239e40f9f428cebec74dd
parentdev-python/graphql-core: version bump (diff)
downloadguru-9479fbb7c196658779e0b2e0d2cc524e8c23be08.tar.gz
guru-9479fbb7c196658779e0b2e0d2cc524e8c23be08.tar.bz2
guru-9479fbb7c196658779e0b2e0d2cc524e8c23be08.zip
dev-python/graphene: version bump
fix tests Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
-rw-r--r--dev-python/graphene/Manifest1
-rw-r--r--dev-python/graphene/graphene-2.1.8.ebuild17
-rw-r--r--dev-python/graphene/graphene-3.0.0_beta3.ebuild44
3 files changed, 56 insertions, 6 deletions
diff --git a/dev-python/graphene/Manifest b/dev-python/graphene/Manifest
index 08f9b68e9..3808419af 100644
--- a/dev-python/graphene/Manifest
+++ b/dev-python/graphene/Manifest
@@ -1 +1,2 @@
DIST graphene-2.1.8.tar.gz 102179 BLAKE2B 45c61f0f5965828f4b623a1a78678afdd9ef180c0ac83ff6d13ac4385479a787166e7401d75b4314cd125c623ebab7f43337fe2b00db471c1c8751177ca8b264 SHA512 238108c2047b9942de22f21b90581bbda42fb85ee3588ed5d4a26bd54784a6a71407c7a4e8308726ab22b6a62317e94253a60d1771272969e00e0097f3614d51
+DIST graphene-3.0.0_beta3.tar.gz 108606 BLAKE2B 20b1af8400b1fe3721eafb1ce6884702653c58931933d0e3d6058180c115b48bf00a59cc7b6feb61648e9a85195033d0b0ff8c7e4e44822c77b1904cfc3c3b45 SHA512 65b920e5d10d080678df5c9a57d173baab421a3d2c676d943fb3e25fe596cc3623ddb6987322dbdc47d3b299e8f4363e4136bdcd2df0af3c1cf4117e7bb18375
diff --git a/dev-python/graphene/graphene-2.1.8.ebuild b/dev-python/graphene/graphene-2.1.8.ebuild
index 52cadcadf..a5836aba4 100644
--- a/dev-python/graphene/graphene-2.1.8.ebuild
+++ b/dev-python/graphene/graphene-2.1.8.ebuild
@@ -15,14 +15,12 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-# We need newer graphql-core
-RESTRICT="test"
-
RDEPEND="
- dev-python/aniso8601[${PYTHON_USEDEP}]
+ <=dev-python/aniso8601-7[${PYTHON_USEDEP}]
dev-python/graphql-core[${PYTHON_USEDEP}]
dev-python/graphql-relay[${PYTHON_USEDEP}]
- dev-python/unidecode[${PYTHON_USEDEP}]"
+ dev-python/unidecode[${PYTHON_USEDEP}]
+"
DEPEND="test? (
dev-python/pytest-mock[${PYTHON_USEDEP}]
@@ -30,7 +28,8 @@ DEPEND="test? (
dev-python/promises[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/iso8601[${PYTHON_USEDEP}] )"
+ dev-python/iso8601[${PYTHON_USEDEP}]
+)"
python_prepare_all() {
# Package installs 'examples' package which is forbidden and likely a bug in the build system.
@@ -43,3 +42,9 @@ distutils_enable_tests pytest
# ModuleNotFoundError: No module named 'sphinx_graphene_theme'
# There is a github, but no releases at the moment
#distutils_enable_sphinx docs
+
+python_test() {
+ #distutils_install_for_testing
+ PYTHONPATH="${S}"
+ pytest -vv || die "Tests fail with ${EPYHTON}"
+}
diff --git a/dev-python/graphene/graphene-3.0.0_beta3.ebuild b/dev-python/graphene/graphene-3.0.0_beta3.ebuild
new file mode 100644
index 000000000..d13504753
--- /dev/null
+++ b/dev-python/graphene/graphene-3.0.0_beta3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 )
+
+inherit distutils-r1
+
+MYPV="${PV/_beta/b}"
+MYP="${PN}-${MYPV}"
+
+DESCRIPTION="GraphQL Framework for Python"
+HOMEPAGE="https://github.com/graphql-python/graphene"
+SRC_URI="https://github.com/graphql-python/${PN}/archive/v${MYPV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/aniso8601[${PYTHON_USEDEP}]
+ dev-python/graphql-core[${PYTHON_USEDEP}]
+ dev-python/graphql-relay[${PYTHON_USEDEP}]
+ dev-python/unidecode[${PYTHON_USEDEP}]
+"
+
+DEPEND="test? (
+ dev-python/iso8601[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/promises[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-benchmark[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/snapshottest[${PYTHON_USEDEP}]
+)"
+
+S="${WORKDIR}/${MYP}"
+
+distutils_enable_tests pytest
+# ModuleNotFoundError: No module named 'sphinx_graphene_theme'
+# There is a archived github, but no releases at the moment
+#distutils_enable_sphinx docs