aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2022-11-29 20:00:04 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2022-11-29 20:00:53 +0500
commit94c83418cf3446b81be3b65e3cc081659a8006d5 (patch)
tree5b4311b7a8bf95ff2f6a856f56d1257726d4cd46
parentmedia-video/syncplay: enable py3.11 (diff)
downloadguru-94c83418cf3446b81be3b65e3cc081659a8006d5.tar.gz
guru-94c83418cf3446b81be3b65e3cc081659a8006d5.tar.bz2
guru-94c83418cf3446b81be3b65e3cc081659a8006d5.zip
gnome-extra/junction: fix a broken ebuild
Closes: https://bugs.gentoo.org/866467 Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
-rw-r--r--gnome-extra/junction/Manifest2
-rw-r--r--gnome-extra/junction/junction-1.6-r1.ebuild58
-rw-r--r--gnome-extra/junction/junction-1.6.ebuild24
-rw-r--r--gnome-extra/junction/junction-9999.ebuild25
4 files changed, 60 insertions, 49 deletions
diff --git a/gnome-extra/junction/Manifest b/gnome-extra/junction/Manifest
new file mode 100644
index 000000000..39d62007d
--- /dev/null
+++ b/gnome-extra/junction/Manifest
@@ -0,0 +1,2 @@
+DIST junction-1.6.tar.gz 1882299 BLAKE2B ff4e51f65eea7fd12de4cade632762d4cc752df2de80057fc0bb1bd711e4802e812f2358fbe19d249e19e0c1c32e5e81cdf125a4e6b0e7730442ca56d375114a SHA512 c92207496ade1c49f2d4ab5846839c8f4afaf777d77a59285a7b9eea139736aa77618fe5cb0b2386b9d1a821ef6a27b23eb4abd2b4d094222211430cca76949b
+DIST troll-junction-1.6.tar.gz 469179 BLAKE2B cbbfd7be194f286149e673ea7fd5b314dcc99ca6cf1490012cffcd00645e0fa126cd32ab1b0162bfccdd3065c4dbb11edff0cea0b570335ebb03a170eb1d14a3 SHA512 4b9ea85d826f3a030d432b333e6c64bc59a9f1f8d48474e4d5a3edb9c1e528da1acd556055e430465ba66e338ac00fca0a782e4f995c9946f22063a1051f6c61
diff --git a/gnome-extra/junction/junction-1.6-r1.ebuild b/gnome-extra/junction/junction-1.6-r1.ebuild
new file mode 100644
index 000000000..d7d8303e6
--- /dev/null
+++ b/gnome-extra/junction/junction-1.6-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+TROLL_COMMIT="8d7c2be66a4bf1cbb2081121997a33662fc19cd0"
+DESCRIPTION="Application/browser chooser"
+HOMEPAGE="
+ https://apps.gnome.org/app/re.sonny.Junction/
+ https://github.com/sonnyp/Junction
+"
+SRC_URI="
+ https://github.com/sonnyp/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/sonnyp/troll/archive/${TROLL_COMMIT}.tar.gz -> troll-${P}.tar.gz
+"
+S="${WORKDIR}/${PN^}-${PV}"
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64"
+SLOT="0"
+
+DEPEND="
+ dev-libs/gjs
+ dev-libs/glib:2
+"
+RDEPEND="${DEPEND}
+ dev-libs/gobject-introspection
+ dev-libs/libportal[introspection]
+ gui-libs/gtk:4[introspection]
+ gui-libs/libadwaita:1[introspection]
+ net-libs/libsoup:3.0[introspection]
+"
+BDEPEND="
+ dev-util/blueprint-compiler
+ sys-devel/gettext
+"
+
+src_unpack() {
+ default
+
+ rmdir "${S}"/troll || die
+ mv "${WORKDIR}"/troll-${TROLL_COMMIT} "${S}"/troll || die
+}
+
+src_configure() {
+ local mymesonargs=(
+ --datadir=/usr/share
+ )
+
+ meson_src_configure
+}
+
+# only data files validators, skip them
+src_test() {
+ :
+}
diff --git a/gnome-extra/junction/junction-1.6.ebuild b/gnome-extra/junction/junction-1.6.ebuild
deleted file mode 100644
index 533490046..000000000
--- a/gnome-extra/junction/junction-1.6.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit git-r3 meson
-
-DESCRIPTION="Application/browser chooser"
-HOMEPAGE="https://apps.gnome.org/app/re.sonny.Junction/"
-
-EGIT_REPO_URI="https://github.com/sonnyp/Junction.git"
-
-if [[ ${PV} != *9999 ]]; then
- EGIT_COMMIT="v${PV}"
- KEYWORDS="~amd64"
-fi
-
-LICENSE="GPL-3+"
-SLOT="0"
-
-src_configure() {
- meson_src_configure \
- --datadir=/usr/share
-}
diff --git a/gnome-extra/junction/junction-9999.ebuild b/gnome-extra/junction/junction-9999.ebuild
deleted file mode 100644
index 561a653dc..000000000
--- a/gnome-extra/junction/junction-9999.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit git-r3 meson
-
-DESCRIPTION="Application/browser chooser"
-HOMEPAGE="https://apps.gnome.org/app/re.sonny.Junction/"
-
-EGIT_REPO_URI="https://github.com/sonnyp/Junction.git"
-
-if [[ ${PV} != *9999 ]]; then
- EGIT_TAG="v${PV}"
- KEYWORDS="~amd64"
-fi
-
-LICENSE="GPL-3+"
-KEYWORDS=""
-SLOT="0"
-
-src_configure() {
- meson_src_configure \
- --datadir=/usr/share
-}