aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKurt Kanzenbach <kurt@kmk-computers.de>2022-11-06 13:55:48 +0100
committerKurt Kanzenbach <kurt@kmk-computers.de>2022-11-06 13:55:48 +0100
commit9a021267a101f6adc94c38f818147bd015757f18 (patch)
tree01d2484ca9baf9e235d0d2cafe4adb350360b416
parentkde-frameworks/kirigami-addons: try to fix tests (diff)
downloadguru-9a021267a101f6adc94c38f818147bd015757f18.tar.gz
guru-9a021267a101f6adc94c38f818147bd015757f18.tar.bz2
guru-9a021267a101f6adc94c38f818147bd015757f18.zip
net-dialup/tio: add 2.3
Signed-off-by: Kurt Kanzenbach <kurt@kmk-computers.de>
-rw-r--r--net-dialup/tio/Manifest1
-rw-r--r--net-dialup/tio/tio-2.3.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/net-dialup/tio/Manifest b/net-dialup/tio/Manifest
index 65507f9d9..458a9241c 100644
--- a/net-dialup/tio/Manifest
+++ b/net-dialup/tio/Manifest
@@ -1 +1,2 @@
DIST tio-2.2.tar.xz 3416172 BLAKE2B f41d8b99f770142abd471ccc98669915a9b7dbe5b98fafa84d90b1bab0fec311b1b7eb03c12d184ea83dddf28af37c91f4193ab866497b9c87c22d241feb26a5 SHA512 74f6147b219fbee498e48bec1e66755dd0ebc0506ca7bf7853eed48eabdef10cb75733dc1e4c53ce5391f4dbdae7c2b788848c25c8b428296479b748f44e54fd
+DIST tio-2.3.tar.xz 3416720 BLAKE2B cecca8b4c9bab7e6ece0f98e39069e70547ddba82e758a1f02f4aeb8d4310e8f3a9af1f4a968fe54929cd09d4c93bce3a3ac530f81e740d75666973b481d6794 SHA512 0f8a825c5c57bb2bc9ca83f45ee92c7d70c3c74d3684a485cde46cd9e5bb4009526d780cc78fa92e8fbd3b7a6332f1e72609e1b4f06eeb8c7b52a1d4cc177610
diff --git a/net-dialup/tio/tio-2.3.ebuild b/net-dialup/tio/tio-2.3.ebuild
new file mode 100644
index 000000000..aa1af5f4e
--- /dev/null
+++ b/net-dialup/tio/tio-2.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson bash-completion-r1
+
+DESCRIPTION="Simple TTY terminal application"
+HOMEPAGE="https://tio.github.io/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+SLOT="0"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-libs/inih
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dbashcompletiondir="$(get_bashcompdir)"
+ )
+
+ meson_src_configure
+}