aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-05-28 04:35:39 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-05-28 04:35:39 +0200
commit9abf86a464190ffc1a65ad179af35fd2b84863e9 (patch)
treee370ab305d0f128ccd728f272f00ea1744268e01
parentdev-python/atomiclong: treeclean (diff)
downloadguru-9abf86a4.tar.gz
guru-9abf86a4.tar.bz2
guru-9abf86a4.zip
dev-python/raven: treeclean
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--dev-python/raven/Manifest1
-rw-r--r--dev-python/raven/files/no-coverage.patch10
-rw-r--r--dev-python/raven/metadata.xml13
-rw-r--r--dev-python/raven/raven-6.10.0.ebuild64
4 files changed, 0 insertions, 88 deletions
diff --git a/dev-python/raven/Manifest b/dev-python/raven/Manifest
deleted file mode 100644
index ffc242aa4..000000000
--- a/dev-python/raven/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST raven-6.10.0.tar.gz 288902 BLAKE2B e72f48511347910d65cae9ba342a0a592bead9e848ec932b5efc361e7993ce77ce7213fce63c7cfb40534ace536c9ed55751928c991272ed123e12222047b096 SHA512 37ca6d5953dc92b57b3bf4e2edb3947d41f33711d9babfc9eafb8712dc5923829f8810e5123e63749710aeecceb66e56bf8b5b60868f61d750704e20add3c747
diff --git a/dev-python/raven/files/no-coverage.patch b/dev-python/raven/files/no-coverage.patch
deleted file mode 100644
index 70a48d142..000000000
--- a/dev-python/raven/files/no-coverage.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/setup.cfg 2018-12-19 11:00:58.000000000 -0000
-+++ b/setup.cfg 2021-05-08 01:39:02.631499047 -0000
-@@ -1,6 +1,6 @@
- [tool:pytest]
- python_files = test*.py
--addopts = --tb=native -p no:doctest -p no:logging --cov=raven
-+addopts = --tb=native -p no:doctest -p no:logging
- norecursedirs = raven build bin dist htmlcov hooks node_modules .* {args}
- django_settings_module = tests.contrib.django.settings
- python_paths = tests
diff --git a/dev-python/raven/metadata.xml b/dev-python/raven/metadata.xml
deleted file mode 100644
index 3abb195a1..000000000
--- a/dev-python/raven/metadata.xml
+++ /dev/null
@@ -1,13 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <description>comaintainers welcome</description>
- <email>lssndrbarbieri@gmail.com</email>
- <name>Alessandro Barbieri</name>
- </maintainer>
- <upstream>
- <remote-id type="pypi">raven</remote-id>
- <remote-id type="github">getsentry/raven-python</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/raven/raven-6.10.0.ebuild b/dev-python/raven/raven-6.10.0.ebuild
deleted file mode 100644
index 44e5526c5..000000000
--- a/dev-python/raven/raven-6.10.0.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-DESCRIPTION="Raven is a client for Sentry"
-HOMEPAGE="https://github.com/getsentry/raven-python"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-RESTRICT="test" #tests broken with pytest >=4
-
-RDEPEND="
- dev-python/contextlib2[${PYTHON_USEDEP}]
-"
-DEPEND="
- ${RDEPEND}
- test? (
- dev-python/aiohttp[${PYTHON_USEDEP}]
- >=dev-python/blinker-1.1[${PYTHON_USEDEP}]
- dev-python/bottle[${PYTHON_USEDEP}]
- >=dev-python/celery-2.5[${PYTHON_USEDEP}]
- >=dev-python/exam-0.5.2[${PYTHON_USEDEP}]
- >=dev-python/flask-0.8[${PYTHON_USEDEP}]
- >=dev-python/flask-login-0.2.0[${PYTHON_USEDEP}]
- dev-python/logbook[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/paste[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/pytest-pythonpath[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- >=dev-python/sanic-0.7.0[${PYTHON_USEDEP}]
- dev-python/unittest2[${PYTHON_USEDEP}]
- dev-python/webob[${PYTHON_USEDEP}]
- dev-python/webpy[${PYTHON_USEDEP}]
- dev-python/webtest[${PYTHON_USEDEP}]
- dev-python/wheel[${PYTHON_USEDEP}]
- dev-python/zconfig[${PYTHON_USEDEP}]
- >=www-servers/tornado-4.1[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES="${FILESDIR}/no-coverage.patch"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- export DJANGO_SETTINGS_MODULE=tests.contrib.django.settings
-
- #test not working with >=www-servers/tornado-6
- rm tests/contrib/tornado/tests.py || die
- #test not working with >=dev-python/django-3
- rm tests/contrib/django/tests.py || die
- default
-}