aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-06-29 05:13:46 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-06-29 05:25:00 +0200
commit9cea627aafe3aca38fcc5a06928fef55dfb30271 (patch)
tree8679aa8aa3496c01533a13b509019112712868da
parentdev-python/bson: initial import (diff)
downloadguru-9cea627aafe3aca38fcc5a06928fef55dfb30271.tar.gz
guru-9cea627aafe3aca38fcc5a06928fef55dfb30271.tar.bz2
guru-9cea627aafe3aca38fcc5a06928fef55dfb30271.zip
dev-python/cattrs: add more test deps
Closes: https://bugs.gentoo.org/799080 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--dev-python/cattrs/cattrs-1.7.0.ebuild17
1 files changed, 12 insertions, 5 deletions
diff --git a/dev-python/cattrs/cattrs-1.7.0.ebuild b/dev-python/cattrs/cattrs-1.7.0.ebuild
index d8e1cf75e..faf55aabb 100644
--- a/dev-python/cattrs/cattrs-1.7.0.ebuild
+++ b/dev-python/cattrs/cattrs-1.7.0.ebuild
@@ -1,24 +1,31 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=8
+EAPI=7
DISTUTILS_USE_SETUPTOOLS=pyproject.toml
-PYTHON_COMPAT=( python3_{8..9} pypy3 )
+PYTHON_COMPAT=( python3_{8..9} )
inherit distutils-r1
SRC_URI="https://github.com/Tinche/cattrs/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS=""
DESCRIPTION="Complex custom class converters for attrs"
HOMEPAGE="https://github.com/Tinche/cattrs"
LICENSE="MIT"
SLOT="0"
-RDEPEND="dev-python/attrs[${PYTHON_USEDEP}]"
+RDEPEND=">=dev-python/attrs-20[${PYTHON_USEDEP}]"
DEPEND="
${RDEPEND}
- test? ( dev-python/hypothesis[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/bson[${PYTHON_USEDEP}]
+ dev-python/immutables[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/orjson[${PYTHON_USEDEP}]
+ dev-python/pytest-benchmark[${PYTHON_USEDEP}]
+ dev-python/ujson[${PYTHON_USEDEP}]
+ )
"
distutils_enable_tests pytest