aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2021-04-23 21:17:23 +0200
committerRonny (tastytea) Gutbrod <gentoo@tastytea.de>2021-04-23 21:17:23 +0200
commita3801d8749295e6efcaa6aefd3d5d185e287f2f7 (patch)
tree7ba2c09a566ffbf83d949a67a231244c669a93d7
parentmedia-gfx/glimpse: Set compiler explicitly. (diff)
downloadguru-a3801d8749295e6efcaa6aefd3d5d185e287f2f7.tar.gz
guru-a3801d8749295e6efcaa6aefd3d5d185e287f2f7.tar.bz2
guru-a3801d8749295e6efcaa6aefd3d5d185e287f2f7.zip
x11-misc/xob: Set CC.
Makefile calls `$(CC)`, which seems to default to `cc`. Closes: https://bugs.gentoo.org/785211 Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de>
-rw-r--r--x11-misc/xob/xob-0.2.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/x11-misc/xob/xob-0.2.ebuild b/x11-misc/xob/xob-0.2.ebuild
index 2a73d3f57..0b54a8433 100644
--- a/x11-misc/xob/xob-0.2.ebuild
+++ b/x11-misc/xob/xob-0.2.ebuild
@@ -1,8 +1,10 @@
-# Copyright 2020 Gentoo Authors
+# Copyright 2020-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit toolchain-funcs
+
DESCRIPTION="A lightweight overlay volume (or anything) bar for the X Window System"
HOMEPAGE="https://github.com/florentc/xob"
SRC_URI="https://github.com/florentc/xob/archive/v${PV}.tar.gz -> ${P}.tar.gz"
@@ -17,6 +19,11 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
+src_compile() {
+ tc-export CC
+ default
+}
+
src_install() {
emake prefix="${EPREFIX}"/usr \
sysconfdir="${EPREFIX}"/etc \