aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2022-11-04 04:28:18 +0100
committerRonny (tastytea) Gutbrod <gentoo@tastytea.de>2022-11-04 04:28:18 +0100
commita4dcdd8aa6f171dd57b3ba2ec86f7408c6c5e937 (patch)
tree6da2d811a211022e54f70fa91da1902a38e1cd44
parentmpv-plugin/mpv_thumbnail_script: update Manifest (diff)
downloadguru-a4dcdd8a.tar.gz
guru-a4dcdd8a.tar.bz2
guru-a4dcdd8a.zip
games-util/legendary: add 0.20.30
Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de>
-rw-r--r--games-util/legendary/Manifest1
-rw-r--r--games-util/legendary/legendary-0.20.30.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/games-util/legendary/Manifest b/games-util/legendary/Manifest
index 89f13bce38..9e67fa93ed 100644
--- a/games-util/legendary/Manifest
+++ b/games-util/legendary/Manifest
@@ -1,2 +1,3 @@
DIST legendary-0.20.28.tar.gz 129629 BLAKE2B 652f8484eee51aaee777a24dd72a4fceb51f355904ba4c01e44e3a2e7999f08e82d4e11494a57205d221414581f87aa345a35b2fad47046914b5301d8957dc84 SHA512 55dee20075e1b71b95ec498523271830442d053abe663b2a21d6ff040f696cf31f893b8136c9de26922ad9124041cb1e9529c20f8328eb90dd0eb2d73acbc6a7
DIST legendary-0.20.29.tar.gz 129774 BLAKE2B d5876bfb6c8e085221d1c6eee6bf7b0d932bfb648f78eadf32dabb53af203db9081c47094171d648231ef6dd34713f0fac41dea65ce8c23565f32dfaf0efd07f SHA512 70c189b26dfb9e31bd2a8003604b047483bbc1f30eafcf30591dfea52c31dfb016df5173ae88c41b9f91b5370aaa3afc3b9ff7718533fd4003f2369fbc59c67e
+DIST legendary-0.20.30.tar.gz 130093 BLAKE2B af1ca08d289de58ff4080a607da0d0a6261c6718061fe57e1852b97936919aef7cf3b7132730cbc1826e535a1dde8c934a6a3be3e5a3c93aa48ebf0108f84aff SHA512 3ae1be8d1aeee7a36ddfdb62b010b7096516518f6a9a264c8a1fedbc87a1e1d6b71e458996536e7e9a350e4d006e73d27cd421a34e94255958ced25e7796b62a
diff --git a/games-util/legendary/legendary-0.20.30.ebuild b/games-util/legendary/legendary-0.20.30.ebuild
new file mode 100644
index 0000000000..b23539c5cd
--- /dev/null
+++ b/games-util/legendary/legendary-0.20.30.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_SINGLE_IMPL=1
+inherit distutils-r1
+
+DESCRIPTION="A free and open-source replacement for the Epic Games Launcher"
+HOMEPAGE="https://github.com/derrod/legendary"
+SRC_URI="https://github.com/derrod/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="webview"
+
+# NOTE: dev-python/pywebview[qt5] is not much tested and does not function
+# correctly in some cases, according to release notes for 0.20.16.
+RDEPEND="
+ $(python_gen_cond_dep '
+ <dev-python/requests-3.0[${PYTHON_USEDEP}]
+ webview? ( dev-python/pywebview[gtk,${PYTHON_USEDEP}] )
+ ')
+"
+DEPEND="${RDEPEND}"