aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-04-27 02:06:12 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-04-27 02:08:37 +0200
commita51f39476bd05eed422ee9968ce626fd146d74a6 (patch)
treec08227a9cd2073f23eb5a63c93cce85782bbff89
parentdev-ml/tiny_httpd: new package, add 0.12 (diff)
downloadguru-a51f3947.tar.gz
guru-a51f3947.tar.bz2
guru-a51f3947.zip
dev-ml/ocamlfuse: new package, add 2.7.1_p7
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--dev-ml/ocamlfuse/Manifest1
-rw-r--r--dev-ml/ocamlfuse/metadata.xml24
-rw-r--r--dev-ml/ocamlfuse/ocamlfuse-2.7.1_p7.ebuild29
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-ml/ocamlfuse/Manifest b/dev-ml/ocamlfuse/Manifest
new file mode 100644
index 000000000..f94f2f666
--- /dev/null
+++ b/dev-ml/ocamlfuse/Manifest
@@ -0,0 +1 @@
+DIST ocamlfuse-2.7.1_p7.tar.gz 21469 BLAKE2B fa587d19124c2e2d320091bb42b098644d3112e39652dbf621c88f701effdab0ce15372b6f2461709eb3afe628e2888db3a7a0c9abeab8b8a136d09c69c84ac4 SHA512 342a6ce8a81ac05d47d4458ef6e9aa750e4e7643a89d28705664852f0549e1932643e8db5d93225ba496611654b3f11fef6aca1e6e40e8d4b30064fc9c65f7fd
diff --git a/dev-ml/ocamlfuse/metadata.xml b/dev-ml/ocamlfuse/metadata.xml
new file mode 100644
index 000000000..54ac06525
--- /dev/null
+++ b/dev-ml/ocamlfuse/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <description>co-maintainers welcome</description>
+ <email>lssndrbarbieri@gmail.com</email>
+ <name>Alessandro Barbieri</name>
+ </maintainer>
+ <longdescription lang="en">This is a binding to FUSE for the OCaml programming language, enabling
+you to write multithreaded filesystems in the OCaml language. It has
+been designed with simplicity as a goal, as you can see by looking at
+example/fusexmp.ml. Efficiency has also been a separate goal. The
+Bigarray library is used for read and writes, allowing the library to
+do zero-copy in OCaml land.</longdescription>
+ <upstream>
+ <bugs-to>https://github.com/astrada/ocamlfuse/issues</bugs-to>
+ <remote-id type="github">astrada/ocamlfuse</remote-id>
+ <remote-id type="sourceforge">ocamlfuse</remote-id>
+ <maintainer>
+ <name>Alessandro Strada</name>
+ <email>alessandro.strada@gmail.com</email>
+ </maintainer>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/ocamlfuse/ocamlfuse-2.7.1_p7.ebuild b/dev-ml/ocamlfuse/ocamlfuse-2.7.1_p7.ebuild
new file mode 100644
index 000000000..93ab86f8c
--- /dev/null
+++ b/dev-ml/ocamlfuse/ocamlfuse-2.7.1_p7.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+MYPV="${PV/_p/_cvs}"
+
+DESCRIPTION="OCaml binding for fuse"
+HOMEPAGE="
+ https://sourceforge.net/projects/ocamlfuse/
+ https://github.com/astrada/ocamlfuse
+ https://opam.ocaml.org/packages/ocamlfuse
+"
+SRC_URI="https://github.com/astrada/${PN}/archive/v${MYPV}.tar.gz -> ${PF}.tar.gz"
+S="${WORKDIR}/${PN}-${MYPV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="ocamlopt"
+
+RDEPEND="
+ dev-ml/camlidl:=
+ sys-fs/fuse:0
+"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-ml/dune-configurator"