aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2023-01-31 23:37:05 -0500
committerJulien Roy <julien@jroy.ca>2023-01-31 23:40:37 -0500
commita6abb68ee10123bb4fefb8b28be00dbd224ef653 (patch)
treea84256d732d36b3b55dd3025206d62f1d4380d23
parentnet-vpn/fastd: keepdir /etc/fastd (diff)
downloadguru-a6abb68e.tar.gz
guru-a6abb68e.tar.bz2
guru-a6abb68e.zip
dev-python/futurist: add 2.4.1, drop 2.3.0-r1
Closes: https://bugs.gentoo.org/835031 Closes: https://bugs.gentoo.org/799485 Closes: https://bugs.gentoo.org/799482 Signed-off-by: Julien Roy <julien@jroy.ca>
-rw-r--r--dev-python/futurist/Manifest2
-rw-r--r--dev-python/futurist/futurist-2.4.1.ebuild (renamed from dev-python/futurist/futurist-2.3.0-r1.ebuild)15
2 files changed, 10 insertions, 7 deletions
diff --git a/dev-python/futurist/Manifest b/dev-python/futurist/Manifest
index 33baaef09..96683d973 100644
--- a/dev-python/futurist/Manifest
+++ b/dev-python/futurist/Manifest
@@ -1 +1 @@
-DIST futurist-2.3.0.tar.gz 42993 BLAKE2B ace10473ee65dedfa33f021437e6d2e974e7e9acd7eb5c6ae6955b133d74376d0bc5e966a8db502f17ff1825abaad1f6b583c6a21dcdd33d87ed4063d35a4638 SHA512 fa12314ce1bc12ccb7d8dd0e99a76a63dbd6a1c6560ca976eacb782f2c28a6003aee820d8ea745b59d35280b047e67563b046c761737d76fefb5928fdfba20e9
+DIST futurist-2.4.1.tar.gz 44796 BLAKE2B a1a4c031100da989e6dcd96347da2a29fdf29f229c46d6838d2f661ecf61643c9ba9603036d151a106195ab176e0b82c5607c3e0b8b7d98da9e2aeda9dcfbfb7 SHA512 39a5ccdbfd3f513356ef6f951ba2c53048b43fd7084001e025a776a4ceca8f53e9759711f3e0548b6bebd94c8760be095117084990e72e5284db0c09e0df7003
diff --git a/dev-python/futurist/futurist-2.3.0-r1.ebuild b/dev-python/futurist/futurist-2.4.1.ebuild
index 49c4fdf09..f165b01b5 100644
--- a/dev-python/futurist/futurist-2.3.0-r1.ebuild
+++ b/dev-python/futurist/futurist-2.4.1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-DISTUTILS_USE_SETUPTOOLS=bdepend
-PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1
@@ -27,12 +27,15 @@ RDEPEND="
DEPEND="
${RDEPEND}
test? (
- >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/eventlet[${PYTHON_USEDEP}]
>=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ dev-python/stestr[${PYTHON_USEDEP}]
+ >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
>=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
>=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
- >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
)
"
-distutils_enable_tests pytest
+distutils_enable_tests unittest