aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuciano Degni <degni.public@gmail.com>2022-02-25 14:24:07 +0100
committerLuciano Degni <degni.public@gmail.com>2022-02-25 14:24:07 +0100
commita6f94984fdd444db1022c051544c49300cee4416 (patch)
treebd2aba8feb100e6c022acc8c10aa8cfe50342a11
parentapp-misc/xplr: add 0.17.2 (diff)
downloadguru-a6f94984.tar.gz
guru-a6f94984.tar.bz2
guru-a6f94984.zip
app-misc/macchina: add 6.0.6
Signed-off-by: Luciano Degni <degni.public@gmail.com>
-rw-r--r--app-misc/macchina/Manifest1
-rw-r--r--app-misc/macchina/macchina-6.0.6.ebuild203
2 files changed, 204 insertions, 0 deletions
diff --git a/app-misc/macchina/Manifest b/app-misc/macchina/Manifest
index 2affb87603..f2023445d2 100644
--- a/app-misc/macchina/Manifest
+++ b/app-misc/macchina/Manifest
@@ -72,6 +72,7 @@ DIST lock_api-0.4.5.crate 25199 BLAKE2B c91adefaa0dc3efa786957794b67cf219f515990
DIST log-0.4.14.crate 34582 BLAKE2B ddfba35947ae1f5905cd9ecb9eb862a78af6f00ee8b8fe6258b369b140928fe677a02b1b3ca5bdec36ff2b16abd85a9f49688fd5f3d1ba2b2905e7f96b8a84c1 SHA512 796100167663d85a7bc4244cd305e9b3f0a1b1520764b63464698eb136318d0928c40c16f5d19d9f602a5bf769851275bbd48d66b088b0c37be7a6fb62def7cc
DIST macchina-5.0.2.tar.gz 50764 BLAKE2B 5e4d0e53cf1d242a8ae6a7891de7ee40e16ecd6e063a5135471c8e942e12dce729e3baf11fec51888171565e4efc2628237e1a377c5776971f48257f8eeea051 SHA512 6746d3812d0a58555d6e2f7287717ddb496bf66c2fae5d8fece110e4188913e6cb17c5a0cf6a5de79db484589ad3682b42b10c6cb24ba2e16e024c198adaf879
DIST macchina-6.0.5.tar.gz 60655 BLAKE2B 6396424d9cb59a16405aff429b81570b07ab768c8ba886feb7755ee3904df17a2409943ab3041860edad22d7fe525c028278135b6bd1947b947fbd102ede96c9 SHA512 9080fe923a0e0f088de702812a18b7ec4226e5813037054b6682314ec6ff919d2441d6a0b66c44e08410addf95eded91efba7c6e8221883cadc482f8f891e3f1
+DIST macchina-6.0.6.tar.gz 59957 BLAKE2B 84dc2812ec40f8b34164554e858095d1e34a6a85bc3cbdf264df3f66461c8a6972a9b5d40ec55db895c327afa636f92e5ff7fbe2a9f614fc225c9ec6eb76ba72 SHA512 9e88d06c58925d396c5c92627e950f9e3de71e8d9d1c36ef7c2e5888bc8800f41f990ea08f2855d4b3aebfd9754df6aa88e65384e2750e325cb4e3f7d4527156
DIST mach-0.3.2.crate 19611 BLAKE2B 683aba7d140a3697933835efe4e2e5a6a107f0a6122ce4533bd9079c0de4346dd1a817abeca4372a44a85406a424af9deff87496e79359df4c8d9ff89daab7e9 SHA512 73622b37915f3445a57cbac5eb378bfee61f5a2383c0dd8bd7c29b5e46447405ebaeb706f3a3274e5afe37b0506afaf1511836cb8897d9d480a3abd41f18fa26
DIST matches-0.1.9.crate 2246 BLAKE2B de155202636c6a03ed68cdb21e8ef96e19b45be040a82943d2d7e5192c0ab5c253ab6d65f0b30b2689e21da79cba684af5be6e63c48266681aceba356f6eea41 SHA512 6a2809687d30ff04ea97bf9d1610d746e097699a4c3625ffd1b7b1e4a9673ece9d559058c9f760b99d6ab509024f7b338e7cfa6fe767499c983efa98bfb98305
DIST memalloc-0.1.0.crate 2410 BLAKE2B d1c2630a07268091f69e25d0a13bb6feb3c25f6d3a6dbcdd63c116827bf94f4e6ea7909125a75b53dd332c45f955eaa82f9084d047fcf8047e42e49263f26257 SHA512 666a30ad179b9387a534337bb13d1b7fa13130fac972acc652520fd83c284721f27bf899a3ed5a6e6ca87e388fe6de163b4043546503baca25cc39085f6043ed
diff --git a/app-misc/macchina/macchina-6.0.6.ebuild b/app-misc/macchina/macchina-6.0.6.ebuild
new file mode 100644
index 0000000000..be50aa0de9
--- /dev/null
+++ b/app-misc/macchina/macchina-6.0.6.ebuild
@@ -0,0 +1,203 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CRATES="
+ aho-corasick-0.7.18
+ ansi-to-tui-0.4.1
+ ansi_term-0.12.1
+ anyhow-1.0.52
+ atty-0.2.14
+ autocfg-1.0.1
+ bitflags-1.2.1
+ byteorder-1.4.3
+ bytesize-1.1.0
+ cassowary-0.3.0
+ cc-1.0.72
+ cfg-if-1.0.0
+ chrono-0.4.19
+ clap-2.34.0
+ color-to-tui-0.1.3
+ colored-2.0.0
+ const-sha1-0.2.0
+ core-foundation-0.9.2
+ core-foundation-sys-0.8.3
+ core-graphics-0.22.3
+ core-graphics-types-0.1.1
+ crossterm-0.20.0
+ crossterm_winapi-0.8.0
+ dirs-4.0.0
+ dirs-next-2.0.0
+ dirs-sys-0.3.6
+ dirs-sys-next-0.1.2
+ either-1.6.1
+ enum-iterator-0.7.0
+ enum-iterator-derive-0.7.0
+ foreign-types-0.3.2
+ foreign-types-shared-0.1.1
+ form_urlencoded-1.0.1
+ gethostname-0.2.1
+ getrandom-0.2.3
+ getset-0.1.2
+ git2-0.13.25
+ heck-0.3.3
+ hermit-abi-0.1.19
+ home-0.5.3
+ idna-0.2.3
+ if-addrs-0.6.7
+ if-addrs-sys-0.3.2
+ instant-0.1.12
+ itertools-0.10.3
+ itoa-1.0.1
+ jobserver-0.1.24
+ lazy_static-1.4.0
+ libc-0.2.112
+ libgit2-sys-0.12.26+1.3.0
+ libmacchina-6.0.0
+ libz-sys-1.1.3
+ local-ip-address-0.4.4
+ lock_api-0.4.5
+ log-0.4.14
+ mach-0.3.2
+ matches-0.1.9
+ memalloc-0.1.0
+ memchr-2.4.1
+ memoffset-0.6.5
+ mio-0.7.14
+ miow-0.3.7
+ neli-0.5.3
+ nix-0.22.2
+ nix-0.23.1
+ ntapi-0.3.6
+ num-integer-0.1.44
+ num-traits-0.2.14
+ num_cpus-1.13.1
+ os-release-0.1.0
+ parking_lot-0.11.2
+ parking_lot_core-0.8.5
+ percent-encoding-2.1.0
+ pkg-config-0.3.24
+ ppv-lite86-0.2.16
+ proc-macro-error-1.0.4
+ proc-macro-error-attr-1.0.4
+ proc-macro2-1.0.36
+ quote-1.0.14
+ rand-0.8.4
+ rand_chacha-0.3.1
+ rand_core-0.6.3
+ rand_hc-0.3.1
+ redox_syscall-0.2.10
+ redox_users-0.4.0
+ regex-1.5.4
+ regex-syntax-0.6.25
+ rustc_version-0.4.0
+ rustversion-1.0.6
+ ryu-1.0.9
+ same-file-1.0.6
+ scopeguard-1.1.0
+ semver-1.0.4
+ serde-1.0.132
+ serde_derive-1.0.132
+ serde_json-1.0.73
+ shellexpand-2.1.0
+ signal-hook-0.3.13
+ signal-hook-mio-0.2.1
+ signal-hook-registry-1.4.0
+ smallvec-1.7.0
+ sqlite-0.26.0
+ sqlite3-src-0.3.0
+ sqlite3-sys-0.13.0
+ strsim-0.8.0
+ structopt-0.3.25
+ structopt-derive-0.4.18
+ syn-1.0.84
+ sysctl-0.4.3
+ textwrap-0.11.0
+ thiserror-1.0.30
+ thiserror-impl-1.0.30
+ time-0.1.43
+ tinyvec-1.5.1
+ tinyvec_macros-0.1.0
+ toml-0.5.8
+ tui-0.16.0
+ unicode-bidi-0.3.7
+ unicode-normalization-0.1.19
+ unicode-segmentation-1.8.0
+ unicode-width-0.1.9
+ unicode-xid-0.2.2
+ url-2.2.2
+ vcpkg-0.2.15
+ vec_map-0.8.2
+ vergen-6.0.0
+ version_check-0.9.4
+ walkdir-2.3.2
+ wasi-0.10.2+wasi-snapshot-preview1
+ widestring-0.5.1
+ winapi-0.3.9
+ winapi-i686-pc-windows-gnu-0.4.0
+ winapi-util-0.1.5
+ winapi-wsapoll-0.1.1
+ winapi-x86_64-pc-windows-gnu-0.4.0
+ windows-0.18.0
+ windows-0.29.0
+ windows_aarch64_msvc-0.29.0
+ windows_gen-0.18.0
+ windows_i686_gnu-0.29.0
+ windows_i686_msvc-0.29.0
+ windows_macros-0.18.0
+ windows_x86_64_gnu-0.29.0
+ windows_x86_64_msvc-0.29.0
+ winreg-0.10.1
+ wmi-0.9.2
+ x11rb-0.9.0
+"
+
+inherit cargo xdg-utils
+
+SRC_URI="
+ https://github.com/Macchina-CLI/macchina/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+ $(cargo_crate_uris)
+"
+
+DESCRIPTION="A system information fetcher, with an (unhealthy) emphasis on performance."
+# Double check the homepage as the cargo_metadata crate
+# does not provide this value so instead repository is used
+HOMEPAGE="https://github.com/Macchina-CLI/macchina"
+# License set may be more restrictive as OR is not respected
+LICENSE="
+ || ( Apache-2.0 )
+ || ( Apache-2.0 MIT )
+ BSD
+ MIT
+ Apache-2.0
+ MPL-2.0
+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ app-portage/portage-utils:0=
+ dev-libs/libgit2:0=
+"
+RDEPEND="${DEPEND}"
+
+QA_FLAGS_IGNORED="usr/bin/.*"
+
+src_compile() {
+ cargo_src_compile
+}
+
+src_install() {
+ dodoc CHANGELOG.txt CONTRIBUTING.md README.md
+ cd target/release || die
+ dobin macchina
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}