aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandru Campeanu <tiotags1@gmail.com>2022-08-27 09:50:47 +0300
committerAlexandru Campeanu <tiotags1@gmail.com>2022-08-27 09:55:44 +0300
commita714e34286de0c8cae9cf4445f4403a5b791d56f (patch)
treeda65d1c6a4aee4766c56f748c664b449cb257600
parentapp-emulation/dxvk-bin: treeclean (diff)
downloadguru-a714e342.tar.gz
guru-a714e342.tar.bz2
guru-a714e342.zip
www-servers/hinsightd: fixed qa issues
Signed-off-by: Alexandru Campeanu <tiotags1@gmail.com>
-rw-r--r--www-servers/hinsightd/hinsightd-0.9.15_p20220826.ebuild18
-rw-r--r--www-servers/hinsightd/hinsightd-9999.ebuild18
2 files changed, 18 insertions, 18 deletions
diff --git a/www-servers/hinsightd/hinsightd-0.9.15_p20220826.ebuild b/www-servers/hinsightd/hinsightd-0.9.15_p20220826.ebuild
index e4732875c..4417c15a7 100644
--- a/www-servers/hinsightd/hinsightd-0.9.15_p20220826.ebuild
+++ b/www-servers/hinsightd/hinsightd-0.9.15_p20220826.ebuild
@@ -17,7 +17,7 @@ mycommit="60ff105ba76746ac8f669616ed3658f7c03c3ab3"
if [[ ${PV} == *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://gitlab.com/tiotags/hin9.git"
-elif [[ ! -z "$mycommit" ]]; then
+elif [[ ! -z "${mycommit}" ]]; then
SRC_URI="https://gitlab.com/tiotags/hin9/-/archive/${mycommit}/hin9-${mycommit}.tar.gz"
S="${WORKDIR}/hin9-${mycommit}"
else
@@ -55,13 +55,13 @@ FILECAPS=(
)
pkg_setup() {
- linux-info_pkg_setup;
+ linux-info_pkg_setup
lua-single_pkg_setup
}
src_configure() {
version=$(ver_cut 1-2 $(lua_get_version))
- if [ "$version" == "2.1" ]; then
+ if [[ "${version}" == "2.1" ]]; then
version="jit"
fi
local emesonargs=(
@@ -70,7 +70,7 @@ src_configure() {
$(meson_use fcgi)
$(meson_use rproxy)
$(meson_use ffcall)
- -Dforce-lua-version=$version
+ -Dforce-lua-version=${version}
)
meson_src_configure
}
@@ -78,19 +78,19 @@ src_configure() {
src_install() {
meson_src_install
- newinitd "${S}/external/packaging/$PN.initd.sh" $PN
- newconfd "${S}/external/packaging/$PN.confd.sh" $PN
- systemd_dounit "${FILESDIR}/$PN.service" # not tested
+ newinitd "${S}/external/packaging/${PN}.initd.sh" ${PN}
+ newconfd "${S}/external/packaging/${PN}.confd.sh" ${PN}
+ systemd_dounit "${FILESDIR}/${PN}.service" # not tested
# config
- insinto /etc/$PN
+ insinto /etc/${PN}
doins "${S}/workdir/main.lua"
doins "${S}/workdir/lib.lua"
doins -r "${S}/workdir/config/"
# logrotate
insinto /etc/logrotate.d
- newins "${S}/external/packaging/$PN.logrotate.sh" $PN
+ newins "${S}/external/packaging/${PN}.logrotate.sh" ${PN}
}
pkg_postinst() {
diff --git a/www-servers/hinsightd/hinsightd-9999.ebuild b/www-servers/hinsightd/hinsightd-9999.ebuild
index 60ce5a5ee..2f6e9c8e9 100644
--- a/www-servers/hinsightd/hinsightd-9999.ebuild
+++ b/www-servers/hinsightd/hinsightd-9999.ebuild
@@ -15,7 +15,7 @@ SLOT="0"
if [[ ${PV} == *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://gitlab.com/tiotags/hin9.git"
-elif [[ ! -z "$mycommit" ]]; then
+elif [[ ! -z "${mycommit}" ]]; then
SRC_URI="https://gitlab.com/tiotags/hin9/-/archive/${mycommit}/hin9-${mycommit}.tar.gz"
S="${WORKDIR}/hin9-${mycommit}"
else
@@ -53,13 +53,13 @@ FILECAPS=(
)
pkg_setup() {
- linux-info_pkg_setup;
+ linux-info_pkg_setup
lua-single_pkg_setup
}
src_configure() {
version=$(ver_cut 1-2 $(lua_get_version))
- if [ "$version" == "2.1" ]; then
+ if [[ "${version}" == "2.1" ]]; then
version="jit"
fi
local emesonargs=(
@@ -68,7 +68,7 @@ src_configure() {
$(meson_use fcgi)
$(meson_use rproxy)
$(meson_use ffcall)
- -Dforce-lua-version=$version
+ -Dforce-lua-version=${version}
)
meson_src_configure
}
@@ -76,19 +76,19 @@ src_configure() {
src_install() {
meson_src_install
- newinitd "${S}/external/packaging/$PN.initd.sh" $PN
- newconfd "${S}/external/packaging/$PN.confd.sh" $PN
- systemd_dounit "${FILESDIR}/$PN.service" # not tested
+ newinitd "${S}/external/packaging/${PN}.initd.sh" ${PN}
+ newconfd "${S}/external/packaging/${PN}.confd.sh" ${PN}
+ systemd_dounit "${FILESDIR}/${PN}.service" # not tested
# config
- insinto /etc/$PN
+ insinto /etc/${PN}
doins "${S}/workdir/main.lua"
doins "${S}/workdir/lib.lua"
doins -r "${S}/workdir/config/"
# logrotate
insinto /etc/logrotate.d
- newins "${S}/external/packaging/$PN.logrotate.sh" $PN
+ newins "${S}/external/packaging/${PN}.logrotate.sh" ${PN}
}
pkg_postinst() {